hihoCoder#1079(线段树+坐标离散化)

时间限制:10000ms

单点时限:1000ms

内存限制:256MB

描述

小Hi和小Ho在回国之后,重新过起了朝7晚5的学生生活,当然了,他们还是在一直学习着各种算法~

这天小Hi和小Ho所在的学校举办社团文化节,各大社团都在宣传栏上贴起了海报,但是贴来贴去,有些海报就会被其他社团的海报所遮挡住。看到这个场景,小Hi便产生了这样的一个疑问——最后到底能有几张海报还能被看见呢?

于是小Ho肩负起了解决这个问题的责任:因为宣传栏和海报的高度都是一样的,所以宣传栏可以被视作长度为L的一段区间,且有N张海报按照顺序依次贴在了宣传栏上,其中第i张海报贴住的范围可以用一段区间[a_i, b_i]表示,其中a_i, b_i均为属于[0, L]的整数,而一张海报能被看到当且仅当存在长度大于0的一部分没有被后来贴的海报所遮挡住。那么问题就来了:究竟有几张海报能被看到呢?

提示一:正确的认识信息量

提示二:小Hi大讲堂之线段树的节点意义

输入

每个测试点(输入文件)有且仅有一组测试数据。

每组测试数据的第1行为两个整数N和L,分别表示总共贴上的海报数量和宣传栏的宽度。

每组测试数据的第2-N+1行,按照贴上去的先后顺序,每行描述一张海报,其中第i+1行为两个整数a_i, b_i,表示第i张海报所贴的区间为[a_i, b_i]。

对于100%的数据,满足N<=10^5,L<=10^9,0<=a_i<b_i<=L。

输出

对于每组测试数据,输出一个整数Ans,表示总共有多少张海报能被看到。

样例输入
5 10
4 10
0 2
1 6
5 9
3 4
样例输出
5
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=200005;
struct Node{
    int color;//0表示没有贴海报,1表示贴有混合海报
    int l,r;
}a[MAXN*3];
struct Query{
    int l,r;
}qer[MAXN];
int n,L;
int hax[MAXN],cnt;
void build(int rt,int l,int r)
{
    a[rt].l=l;
    a[rt].r=r;
    if(l==r)
    {
        a[rt].color=0;
        return ;
    }
    int mid=(l+r)>>1;
    build(rt<<1,l,mid);
    build((rt<<1)|1,mid+1,r);
    if(a[rt<<1].color==a[(rt<<1)|1].color)    a[rt].color=a[rt<<1].color;
    else    a[rt].color=-1;
}
void update(int rt,int l,int r,int val)
{
    if(a[rt].l==l&&a[rt].r==r)
    {
        a[rt].color=val;
        return ;
    }
    if(a[rt].color!=0&&a[rt].color!=-1)
    {
        a[rt<<1].color=a[rt].color;
        a[(rt<<1)|1].color=a[rt].color;
    }
    int mid=(a[rt].l+a[rt].r)>>1;
    if(r<=mid)
    {
        update(rt<<1,l,r,val);
    }
    else if(mid<l)
    {
        update((rt<<1)|1,l,r,val);
    }
    else
    {
        update(rt<<1,l,mid,val);
        update((rt<<1)|1,mid+1,r,val);
    }
    if(a[rt<<1].color==a[(rt<<1)|1].color)    a[rt].color=a[rt<<1].color;
    else    a[rt].color=-1;
}
int vis[MAXN],res;
void query(int rt,int l,int r)
{
    if(a[rt].color==0)
    {
        return ;
    }
    if(a[rt].l==l&&a[rt].r==r)
    {
        if(a[rt].color!=-1)
        {
            if(!vis[a[rt].color])
            {
                vis[a[rt].color]=1;
                res++;
            }
            return ;
        }
    }
    if(a[rt].color!=0&&a[rt].color!=-1)
    {
        a[rt<<1].color=a[rt].color;
        a[(rt<<1)|1].color=a[rt].color;
    }
    int mid=(a[rt].l+a[rt].r)>>1;
    query(rt<<1,l,mid);
    query((rt<<1)|1,mid+1,r);
}
int main()
{
    while(scanf("%d%d",&n,&L)!=EOF)
    {
        cnt=0;
        res=0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&qer[i].l,&qer[i].r);
            hax[cnt++]=qer[i].l;
            hax[cnt++]=qer[i].r;
        }
        sort(hax,hax+cnt);
        cnt=unique(hax,hax+cnt)-hax;
        build(1,1,cnt);
        int col=1;
        for(int i=0;i<n;i++)
        {
            int l=lower_bound(hax,hax+cnt,qer[i].l)-hax+1;
            int r=lower_bound(hax,hax+cnt,qer[i].r)-hax;//不需加1
            update(1,l,r,col);
            col++;
        }
        query(1,1,cnt);
        printf("%d\n",res);
    }
    return 0;
}

时间: 2024-10-09 02:30:14

hihoCoder#1079(线段树+坐标离散化)的相关文章

hdu1542 Atlantis (线段树+扫描线+离散化)

Atlantis Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9032    Accepted Submission(s): 3873 Problem Description There are several ancient Greek texts that contain descriptions of the fabled i

poj2299--B - Ultra-QuickSort(线段树,离散化)

Ultra-QuickSort Time Limit: 7000MS   Memory Limit: 65536K Total Submissions: 41215   Accepted: 14915 Description In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swappin

POJ 3277 City Horizon(线段树+扫描线+离散化)

题目地址:POJ 3277 水题..稍微处理一下然后用求面积并的方法求即可. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #include <ctype.h> #include <queue> #include <

Mayor&#39;s posters---poj2528线段树、离散化

题目链接:http://poj.org/problem?id=2528 题意:有n张海报要贴,每张需要用的区间为L到R,后面的可以贴在之前的上面,就是吧之前的挡住,求最后我们能看到几张海报: 我们可以倒着处理,因为最后贴的我们是能看到的:如果区间被贴过了result不加,没有贴过就+1并标记一下: 由于数据范围太大所以用线段树 #include<stdio.h> #include<math.h> #include<string.h> #include<algori

poj2528 Mayor&#39;s posters(线段树,离散化)

离散化的思想: 对于这样的数据 (3,10000), (9,1000000), (5,100000), (1,1000), (7,1000000) 我们可以将其处理为 (2,7), (5,9), (3,8), (1,6), (4,9) 我们再对离散化之后的数据进行处理就行了. 题目意思: n(n<=10000)个人依次贴海报,给出每张海报所贴的范围li,ri(1<=li<=ri<=10000000). 求出最后还能看见多少张海报. 参考代码: #include <iostre

POJ2528Mayor&#39;s posters 线段树,离散化技巧

题意:一个坐标轴从1~1e7,每次覆盖一个区间(li,ri),问最后可见区间有多少个(没有被其他区间挡住的) 线段树,按倒序考虑,贴上的地方记为1,每次看(li,ri)这个区间是否全是1,全是1就说明在它后面贴的把它给挡住了,否则该海报可见. 然后就愉快的MLE了.... 再看看数据范围,离散化如下,比如如果海报的左右端点如下 那图中橙色的一块的大小其实对结果没有影响,可以把他们都缩为1 最后离散化结果如下图: 代码: 1 #include <algorithm> 2 #include <

HDU 1542 Atlantis(线段树扫描线+离散化求面积的并)

Atlantis Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11551    Accepted Submission(s): 4906 Problem Description There are several ancient Greek texts that contain descriptions of the fabled

hiho1079 : 离散化(线段树+区间离散化)

#1079 : 离散化 时间限制:10000ms 单点时限:1000ms 内存限制:256MB 描述 小Hi和小Ho在回国之后,重新过起了朝7晚5的学生生活,当然了,他们还是在一直学习着各种算法~ 这天小Hi和小Ho所在的学校举办社团文化节,各大社团都在宣传栏上贴起了海报,但是贴来贴去,有些海报就会被其他社团的海报所遮挡住.看到这个场景,小Hi便产生了这样的一个疑问--最后到底能有几张海报还能被看见呢? 于是小Ho肩负起了解决这个问题的责任:因为宣传栏和海报的高度都是一样的,所以宣传栏可以被视作

贴海报 (线段树染色-离散化

n(n<=10000) 个人依次贴海报,给出每张海报所贴的范围li,ri(1<=li<=ri<=10000000) .求出最后还能看见多少张海报. 虽然之前学过离散化,但用的时候就想不起来 emm: 10000个海报 最多有10000个区间 20000个坐标值,远少于10000000,因此采用离散化 将离散化后的坐标对应数组下标储存到线段树中 : 染色区间是整段的,本身就可以看做 lazy标记 ,需要下推函数: 下推 : void push_down(int pos){ if( c