--最小生成树的处理(始终抓取最小边的克鲁斯卡尔算法)

Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in
this contest. But we apprehend that many of your descendants may not have this luxury. For, as you
know, we are the dwellers of one of the most polluted cities on earth. Pollution is everywhere, both in
the environment and in society and our lack of consciousness is simply aggravating the situation.
However, for the time being, we will consider only one type of pollution - the sound pollution. The
loudness or intensity level of sound is usually measured in decibels and sound having intensity level 130
decibels or higher is considered painful. The intensity level of normal conversation is 6065 decibels and
that of heavy tra?c is 7080 decibels.
Consider the following city map where the edges refer to streets and the nodes refer to crossings.
The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.
To get from crossing A to crossing G you may follow the following path: A-C-F-G. In that case
you must be capable of tolerating sound intensity as high as 140 decibels. For the paths A-B-E-G,
A-B-D-G and A-C-F-D-G you must tolerate respectively 90, 120 and 80 decibels of sound intensity.
There are other paths, too. However, it is clear that A-C-F-D-G is the most comfortable path since
it does not demand you to tolerate more than 80 decibels.
In this problem, given a city map you are required to determine the minimum sound intensity level
you must be able to tolerate in order to get from a given crossing to another.
Input
The input may contain multiple test cases.
The rst line of each test case contains three integers C( 100), S( 1000) and Q( 10000) where
C indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 to
C), S represents the number of streets and Q is the number of queries.
Each of the next S lines contains three integers: c1; c2 and d indicating that the average sound
intensity level on the street connecting the crossings c1 and c2 (c1 ?= c2) is d decibels.
Each of the next Q lines contains two integers c1 and c2 (c1 ?= c2) asking for the minimum sound
intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.
The input will terminate with three zeros form C, S and Q.
Output
For each test case in the input rst output the test case number (starting from 1) as shown in the
sample output. Then for each query in the input print a line giving the minimum sound intensity level
(in decibels) you must be able to tolerate in order to get from the rst to the second crossing in the
query. If there exists no path between them just print the line \no path".
Print a blank line between two consecutive test cases.
Sample Input
7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0
Sample Output
Case #1
80
60
60
Case #2
40
no path
80

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int pre[110];
struct node{
    int x,y,cost;
}edges[10010];

bool cmp(node a,node b){
    return a.cost < b.cost;
}

void init(){
    for(int i = 0;i<=110;i++){
        pre[i] = i;
    }
}

int finds(int x){
    int t = x;
    while(x != pre[x]){
         x = pre[x];
    }
    while(t != pre[t]){
        int m = t;
        t = pre[t];
        pre[m] = x;
    }
    return x;
}

int main(){
    int cases = 1;
    int flag = 1;
    int n,m,q;
    int ms[110][110];
    while(scanf("%d%d%d",&n,&m,&q),n||m||q){

        memset(ms,0,sizeof(ms));

        int x,y,c;

        init();

        for(int i = 0;i<m;i++){

            scanf("%d%d%d",&x,&y,&c);
            edges[i].x = x;
            edges[i].y = y;
            edges[i].cost = c;

        }
        sort(edges,edges+m,cmp);
        int qs_u[10010],qs_v[10010];
        for(int i = 0;i<q;i++){

            scanf("%d%d",&qs_u[i],&qs_v[i]);

        }
        for(int i=0 ;i<m;i++){

            int u = finds(edges[i].x);
            int v = finds(edges[i].y);
            if(u != v){
                pre[u] = v;
                ms[edges[i].x][edges[i].y] = ms[edges[i].y][edges[i].x] = edges[i].cost;
            }

        }

        if(flag ==1 )flag  = 0;
        else puts("");

        printf("Case #%d\n",cases++);
        for(int i = 0;i<q;i++){

            int is_find = 0;
            int vis[110];
            int s = qs_u[i];
            int e = qs_v[i];
            queue<int> qq;
            queue<int> cc;

            memset(vis,0,sizeof(vis));

            qq.push(s);
            vis[s] = 1;
            cc.push(0);

            while(!qq.empty()){

                int z = qq.front();
                int cf = cc.front();
                qq.pop();
                cc.pop();

                if(z == e){
                    is_find = 1;
                    printf("%d\n",cf);
                    break;
                }
                for(int j = 1;j<=n;j++){
                    if(ms[z][j]&& vis[j] == 0){

                        vis[j] = 1;
                        qq.push(j);
                        cc.push(max(cf,ms[z][j]));
                    }
                }

            }
            if(is_find == 0)puts("no path");
        }

    }
}

  

时间: 2024-08-01 03:02:15

--最小生成树的处理(始终抓取最小边的克鲁斯卡尔算法)的相关文章

树(最小乘积生成树,克鲁斯卡尔算法):BOI timeismoney

The NetLine company wants to offer broadband internet to N towns. For this, it suffices to constructa network of N-1 broadband links between the towns, with the property that a message can travelfrom any town to any other town on this network. NetLin

最小生成树(普利姆算法、克鲁斯卡尔算法)

给定一个加权无向连通图,如何选择一个生成树,使权利的最小总和的边缘所有树,叫最小生成树. 求最小生成树算法 (1) 克鲁斯卡尔算法 图的存贮结构採用边集数组,且权值相等的边在数组中排列次序能够是随意的.该方法对于边相对照较多的不是非常有用,浪费时间. (2) p=1313">普里姆算法 图的存贮结构採用邻接矩阵.此方法是按各个顶点连通的步骤进行,须要用一个顶点集合,開始为空集,以后将以连通的顶点陆续增加到集合中,所有顶点增加集合后就得到所需的最小生成树 . 以下来详细讲下: 克鲁斯卡尔算法

(转)最小生成树之普利姆算法、克鲁斯卡尔算法

 最小生成树之prim算法 边赋以权值的图称为网或带权图,带权图的生成树也是带权的,生成树T各边的权值总和称为该树的权. 最小生成树(MST):权值最小的生成树. 生成树和最小生成树的应用:要连通n个城市需要n-1条边线路.可以把边上的权值解释为线路的造价.则最小生成树表示使其造价最小的生成树. 构造网的最小生成树必须解决下面两个问题: 1.尽可能选取权值小的边,但不能构成回路: 2.选取n-1条恰当的边以连通n个顶点: MST性质:假设G=(V,E)是一个连通网,U是顶点V的一个非空子集.若(

数据结构课程设计-克鲁斯卡尔算法最小生成树

假设连通网N=(V,{E}),则令最小生成树的初始状态为只有n个顶点而无边的非连通图T=(V,{∮}),图中每个顶点自成一个连通分量.在E中选择代价最小的边,若该边依附的顶点落在T中不同的连通分量上,则将此边加入到T中,否则舍去此边而选择下一条代价最小的边.依次类推,直至T中所有顶点都在同一连通分量上为止. (1)根据原图,构造一个只含n个顶点,边集为空的子图.若将图中各个顶点看成一棵树的根节点,则它是一个含有n棵树的森林. (2)从网的边集 E 中选取一条权值最小的边,若该条边的两个顶点分属不

贪心算法(Greedy Algorithm)之最小生成树 克鲁斯卡尔算法(Kruskal&amp;#39;s algorithm)

克鲁斯卡尔算法(Kruskal's algorithm)是两个经典的最小生成树算法的较为简单理解的一个.这里面充分体现了贪心算法的精髓.大致的流程能够用一个图来表示.这里的图的选择借用了Wikipedia上的那个.很清晰且直观. 首先第一步,我们有一张图,有若干点和边 例如以下图所看到的: 第一步我们要做的事情就是将全部的边的长度排序,用排序的结果作为我们选择边的根据.这里再次体现了贪心算法的思想.资源排序,对局部最优的资源进行选择. 排序完毕后,我们领先选择了边AD. 这样我们的图就变成了 第

最小生成树( 克鲁斯卡尔算法)

/* Name: Copyright: Author: Date: 01-12-14 20:17 Description: 最小生成树( 克鲁斯卡尔算法) 关于并查集的算法,参见<一种简单而有趣的数据结构--并查集>http://blog.csdn.net/qiaoruozhuo/article/details/39674991 */ #include<stdio.h> #include<stdlib.h> #define MAXN 1000 //最大顶点数量 #def

hdu 1233(还是畅通工程)(prime算法,克鲁斯卡尔算法)(并查集,最小生成树)

还是畅通工程 Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 26860    Accepted Submission(s): 11985 Problem Description 某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离.省政府"畅通工程"的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路

hdu 1233(还是畅通project)(prime算法,克鲁斯卡尔算法)(并查集,最小生成树)

还是畅通project Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 26860    Accepted Submission(s): 11985 Problem Description 某省调查乡村交通状况,得到的统计表中列出了随意两村庄间的距离.省政府"畅通project"的目标是使全省不论什么两个村庄间都能够实现公路交

hdu-1863畅通工程 最小生成树克鲁斯卡尔算法kruskal(并查集实现)

畅通工程 Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 16994    Accepted Submission(s): 7134 Problem Description 省政府"畅通工程"的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可).经过调查评估,得到的统计表中列出