HDU 4371 Alice and Bob

Alice and Bob

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 691    Accepted Submission(s): 420

Problem Description

Alice and Bob are interested in playing games. One day, they invent a game which has rules below:

1. Firstly, Alice and Bob choose some random positive integers, and here we describe them as n, d1, d2,..., dm.

2. Then they begin to write numbers alternately. At the first step, Alice has to write a “0”, here we let s1 = 0 ; Then, at the second step, Bob has to write a number s2which satisfies the condition that s2 =
s1 + dk and s2 <= n, 1<= k <= m ; From the third step, the person who has to write a number in this step must write a number siwhich satisfies the condition that si = si-1 + dk or
si = si-1 - dk , and si-2 < si <= n, 1 <= k <= m, i >= 3 at the same time.

3. The person who can’t write a legal number at his own step firstly lose the game.

Here’s the question, please tell me who will win the game if both Alice and Bob play the game optimally.

Input

At the beginning, an integer T indicating the total number of test cases.

Every test case begins with two integers n and m, which are described before. And on the next line are m positive integers d1, d2,..., dm.

T <= 100;

1 <= n <= 106;

1 <= m <= 100;

1 <= dk <= 106, 1 <= k <= m.

Output

For every test case, print “Case #k: ” firstly, where k indicates the index of the test case and begins from 1. Then if Alice will win the game, print “Alice”, otherwise “Bob”.

Sample Input

2
7 1
3
7 2
2 6

Sample Output

Case #1: Alice
Case #2: Bob

两个人轮流写数字,写不出来的那个人就算输了。

因为要是数列处于间隔上升趋势,那么只要每次都选择最小的数字,不给对手做减法的余地

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#define N 1000009
using namespace std;

int a[N];
int n,m;
int t;

int main()
{
    while(~scanf("%d",&t))
    {
        for(int ca=1;ca<=t;ca++)
        {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        scanf("%d",&a[i]);

        sort(a+1,a+1+m);

        int s=0;
        int num=1;
        while(1)
        {
            num++;
            if(s+a[1]>n)
            {
                break;
            }
            s+=a[1];
        }

        printf("Case #%d: ",ca);
        if(num%2==0)
        cout<<"Alice"<<endl;
        else
        cout<<"Bob"<<endl;
        }

    }
    return 0;
}
时间: 2024-12-22 14:58:35

HDU 4371 Alice and Bob的相关文章

HDU 4268 Alice and Bob(贪心+multiset)

HDU 4268 题意:Alice与Bob在玩卡片游戏,他们每人有n张卡片,若Alice的一张卡片长与宽都不小于Bob的一张卡片,则Bob的卡片就会被盖住,一张卡片只可以使用一次,且不可旋转求Alice最多可以盖住多少张Bob的卡片. 思路:记录两人卡片情况,并按照长度将两人卡片分别降序排序.遍历两人的卡片,将长度小于Alice的卡片长度的Bob卡片的宽度插入multiset中,在multiset中找到小于等于Alice卡片宽度的第一个数,将这个数给消去且答案+1.//贪心法自行发挥即可. co

hdu 4111 Alice and Bob 记忆化搜索 博弈论

Alice and Bob Time Limit: 20 Sec  Memory Limit: 256 MB 题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=4111 Description Alice and Bob are very smart guys and they like to play all kinds of games in their spare time. The most amazing thing is that they

HDU 4111 Alice and Bob (博弈)

Alice and Bob Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1799    Accepted Submission(s): 650 Problem Description Alice and Bob are very smart guys and they like to play all kinds of games i

HDU 4268 Alice and Bob(贪心+Multiset的应用)

 题意: Alice和Bob有n个长方形,有长度和宽度,一个矩形可以覆盖另一个矩形的条件的是,本身长度大于等于另一个矩形,且宽度大于等于另一个矩形,矩形不可旋转,问你Alice最多能覆盖Bob的几个矩形? 思路:贪心,先按照h将Alice和Bob的矩形排序,对于Alice的每个矩形,如果Bob的矩形的h小于Alice的h,将Bob的w插入到集合中. 然后,在集合中找到不大于Alice矩形d的最大的Bob的d,那么这样做肯定是最优的. #include<cstdio> #include<

hdu 4268 Alice and Bob

Alice and Bob Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 5   Accepted Submission(s) : 1 Font: Times New Roman | Verdana | Georgia Font Size: ← → Problem Description Alice and Bob's game nev

hdu 4268 Alice and Bob(贪心+multiset+二分)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3511    Accepted Submission(s): 1129 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In thi

HDU 4268 Alice and Bob(multiset的使用)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3046    Accepted Submission(s): 995 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

hdu 4268 Alice and Bob(multiset|段树)

Alice and Bob Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2901    Accepted Submission(s): 941 Problem Description Alice and Bob's game never ends. Today, they introduce a new game. In this

HDU 4268 Alice and Bob(贪心)

Alice and Bob                                                                Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Problem Description Alice and Bob's game never ends. Today, they introduce a new game. I