Color the ball(线段树)

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11355    Accepted Submission(s): 5655

Problem Description

N
个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <=
b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜
色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3

1 1

2 2

3 3

3

1 1

1 2

1 3

0

Sample Output

1 1 1

3 2 1

思路:很典型的线段树,按题意更新区间的值

/*time  memy
  780ms 9132k
  by  orc
  2015 4 15
  */
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 120005;
int n,qans;
struct node{
    int lt,rt,val;
    int add;
}s[4 * N];

void build(int v,int l,int r)
{
    s[v].lt = l;
    s[v].rt = r;
    s[v].val = 0;
    s[v].add = 0;
    if(l == r) return;
    int m = (l + r) >> 1;
    build(v * 2, l, m);
    build(v * 2 + 1, m + 1, r);
}
void update(int v,int l,int r)
{
    if(s[v].lt == l && s[v].rt == r)
    { s[v].add += 1; return; }//只记录增量,本身先不加,待下次查询的时候先加
    if(s[v].add)
    {
        s[2 * v].add += s[v].add;
        s[2 * v + 1].add += s[v].add;
        s[v].val += s[v].add;
        s[v].add = 0;
    }
    int m = (s[v].lt + s[v].rt) >> 1;
    if(r <= m) update(2 * v, l, r);
    else if(l > m) update(2 * v + 1, l, r);
    else {
        update(2 * v, l, m);
        update(2 * v + 1, m + 1, r);
    }
}
void query(int v,int l,int r)
{
    if(s[v].add)//查询的时候先看看增量,并传递
    {
        s[2 * v].add += s[v].add;
        s[2 * v + 1].add += s[v].add;
        s[v].val += s[v].add * (s[v].rt - s[v].lt + 1);//先把自身的增量加到自身
        s[v].add = 0;
    }
    if(s[v].lt == l && s[v].rt == r)
    { qans += s[v].val; return; }
    int m =  (s[v].lt + s[v].rt) >> 1;
    if(r <= m) query(2 * v, l, r);
    else if(l > m) query(2 * v + 1, l, r);
    else {
        query(2 * v, l, m);
        query(2 * v +1, m + 1, r);
    }
}
void solve()
{
    build(1, 1, n);
    qans=0;
    int a,b;
    for(int i = 0;i < n; ++i)
    {
        cin>>a>>b;
        update(1, a, b);
    }
    for(int i = 1;i < n; ++i){
    qans=0;
    query(1, i, i);
    cout<<qans<<‘ ‘;
    }
    qans=0;
    query(1, n, n);
    cout<<qans<<endl;
}
int main()
{
    std::ios::sync_with_stdio(0);
    while(cin>>n && n)
    solve();
    return 0;
}
时间: 2024-10-05 19:30:45

Color the ball(线段树)的相关文章

HDU 1556 Color the ball 线段树

HDU 1556 Color the ball 线段树模版题,存个模板 1 #include <iostream> 2 #include <cstdio> 3 #include <fstream> 4 #include <algorithm> 5 #include <cmath> 6 #include <deque> 7 #include <vector> 8 #include <queue> 9 #inclu

[ACM] Color the ball [线段树水题][数组开大]

Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色.但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗? Input 每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N).  当N

HDU 1556 Color the ball 线段树更新区间查点

点击打开链接 Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9120    Accepted Submission(s): 4665 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽

hdu1556 Color the ball(线段树区间更新)

Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 12814    Accepted Submission(s): 6401 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"

hdu 1556 Color the ball(线段树区间维护+单点求值)

传送门:Color the ball Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 25511    Accepted Submission(s): 12393 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele

HDU 1556 Color the Ball 线段树 题解

本题使用线段树自然能够,由于区间的问题. 这里比較难想的就是: 1 最后更新须要查询全部叶子节点的值,故此须要使用O(nlgn)时间效率更新全部点. 2 截取区间不能有半点差错.否则答案错误. 这两点卡了我下.看来我的线段树还是不够熟,须要多多练习. 线段树是二分法的高级应用,可是却不是简单应用,要锻炼好并应用好线段树思维还是比二分法难非常多的. static const int SIZE = 100005; static const int TREESIZE = SIZE<<2; int a

Color the ball 线段树 区间更新但点查询

#include<iostream> #include<cstdio> #include<cmath> #include<cstring> #include<sstream> #include<algorithm> #include<queue> #include<deque> #include<iomanip> #include<vector> #include<cmath>

Color the ball (线段树的区间更新问题)

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色.但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗? Input每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N). 当N = 0,输入结束.Output每个测

hdu 1556 Color the ball(树状数组)

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1556 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色.但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气

HDU 1566 Color the ball(树状数组or线段树)

Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11387    Accepted Submission(s): 5680 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"