HDU1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35961    Accepted Submission(s): 15867

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)

/*
ID: LinKArftc
PROG: 1016.cpp
LANG: C++
*/

#include <map>
#include <set>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <cstdio>
#include <string>
#include <utility>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-8
#define randin srand((unsigned int)time(NULL))
#define input freopen("input.txt","r",stdin)
#define debug(s) cout << "s = " << s << endl;
#define outstars cout << "*************" << endl;
const double PI = acos(-1.0);
const double e = exp(1.0);
const int inf = 0x3f3f3f3f;
const int INF = 0x7fffffff;
typedef long long ll;

int n;
int vis[30];
int ans[30];

bool isPrime(int x) {
    for (int i = 2; i * i <= x; i ++) {
        if (x % i == 0) return false;
    }
    return true;
}

void dfs(int cur, int cnt) {
    if (cnt > n) {
        for (int i = 1; i <= n; i ++) printf("%d%c", ans[i], i == n ? ‘\n‘ : ‘ ‘);
        return ;
    }
    for (int i = 2; i <= n; i ++) {
        if (!vis[i] && isPrime(i + cur)) {
            if (cnt == n) {
                if (!isPrime(i + 1)) continue;
            }
            ans[cnt] = i;
            vis[i] = true;
            dfs(i, cnt + 1);
            vis[i] = false;
        }
    }
}

int main() {

    int _t = 1;
    while (~scanf("%d", &n)) {
        printf("Case %d:\n", _t ++);
        memset(vis, 0, sizeof(vis));
        vis[1] = true;
        ans[1] = 1;
        dfs(1, 2);
        printf("\n");
    }

    return 0;
}
时间: 2024-10-04 16:33:31

HDU1016 Prime Ring Problem的相关文章

HDU-1016 Prime Ring Problem(DFS深搜+打表)

题目回顾(HDU-1016): Prime Ring Problem Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.Note: the number

HDU1016 Prime Ring Problem(深度优先搜索)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 27488 Accepted Submission(s): 12248 Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1,

hdu1016 Prime Ring Problem dfs 素数打表

意思是给你一个数n,要构成一个素数环,这个素数由1-n组成,它的特征是选中环上的任意一个数字i,i与它相连的两个数加起来都分别为素数,满足就输出. 这个题的做法和hdu1015做法差不多都是使用dfs 回溯.不同之处在于这个要全部搜索,而hdu1015只需要搜索第一组就可以. 其次在这个题目中使用素数打表的方式简化素数判定,在一定情况下也是对效率有所提高的. Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others) Memory Limi

HDU1016 Prime Ring Problem(DFS回溯)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 34609    Accepted Submission(s): 15327 Problem Description A ring is compose of n circles as shown in diagram. Put natural numb

HDU1016 Prime Ring Problem DFS 简单题

题意:输入n,代表有一个n个节点的环,然后在节点分别填入1到n这n个数,规定,第一个填入的必须是1. 0<n<40 要求填入后满足,任意相邻的2个节点的数之和为素数. 将满足条件的填法按照字典序的顺序小到大依次输出. 其实刚开始做的时候我觉得这道题会做很久的,想好后就开始打了,打着打着发现这道题打好了,有点意外,原来这么简单. 注意回溯,在每次DFS后要记得把状态恢复原样,比如这道题是每次DFS后都要把当前DFS的数字i恢复为vis[i]=false; 先考虑好初始化,结束条件,回溯. 先来一

HDU1016——Prime Ring Problem

http://acm.hdu.edu.cn/showproblem.php?pid=1016 这道题是经典的素数环问题,相邻的两个数之和是素数. 解题方法:用的是深搜,以1为起点,搜索,下一个数为出去前面的数字的集合.(用vis数组记录访问过的节点) 剪枝:当前搜索值与数组前一个值之和不为素数的时候返回. #include <iostream> #include <cstdio> #include <cstring> #include<math.h> usi

HDU1016 Prime Ring Problem (回溯 + 剪枝)

题意: 给你一个数字N(N <= 20),要求你把这N个数组成一个环,环内的数字不能重复,左右相邻的两个的和是素数.给出最后的答案. 思路: 利用回溯剪枝算法,N个数,每个数有N种状态,枚举这N个状态,枚举过程中剪枝优化. 代码: #include <cstdio> #include <iostream> #include <cstring> #include <cstring> #include <cmath> #include <

Prime Ring Problem——HDU1016

  Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 40419    Accepted Submission(s): 17843 Problem Description A ring is compose of n circles as shown in diagram. Put natural n

Prime Ring Problem—hdu1016(DFS)

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 40339    Accepted Submission(s): 17813 Problem Description A ring is compose of n circles as shown in diagram. Put natural num