OpenJudge4980:拯救行动//stl有限队列

总时间限制: 
10000ms
内存限制: 
65536kB
描述

公主被恶人抓走,被关押在牢房的某个地方。牢房用N*M (N, M <= 200)的矩阵来表示。矩阵中的每项可以代表道路(@)、墙壁(#)、和守卫(x)。 
英勇的骑士(r)决定孤身一人去拯救公主(a)。我们假设拯救成功的表示是“骑士到达了公主所在的位置”。由于在通往公主所在位置的道路中可能遇到守卫,骑士一旦遇到守卫,必须杀死守卫才能继续前进。 
现假设骑士可以向上、下、左、右四个方向移动,每移动一个位置需要1个单位时间,杀死一个守卫需要花费额外的1个单位时间。同时假设骑士足够强壮,有能力杀死所有的守卫。

给定牢房矩阵,公主、骑士和守卫在矩阵中的位置,请你计算拯救行动成功需要花费最短时间。

输入
第一行为一个整数S,表示输入的数据的组数(多组输入)
随后有S组数据,每组数据按如下格式输入 
1、两个整数代表N和M, (N, M <= 200). 
2、随后N行,每行有M个字符。"@"代表道路,"a"代表公主,"r"代表骑士,"x"代表守卫, "#"代表墙壁。
输出
如果拯救行动成功,输出一个整数,表示行动的最短时间。
如果不可能成功,输出"Impossible"
样例输入
2
7 8
#@#####@
#@a#@@[email protected]
#@@#[email protected]@@
@@#@@#@#
#@@@##@@
@#@@@@@@
@@@@@@@@
13 40
@[email protected]@##[email protected]#[email protected]#xxxx##@#[email protected]@@#x#@#x#@@[email protected]#@x
xx###[email protected]#@@##[email protected]@@#@[email protected]@#[email protected]@@#[email protected]#[email protected]@[email protected]
#@x#@x#x#@@##@@x#@xx#[email protected]@x##@@@#@[email protected]@[email protected]
@##[email protected]@@x#xx#@@#xxxx#@@[email protected]@#@[email protected]@@[email protected]#@#[email protected]#
@#xxxxx##@@x##[email protected]@@#[email protected]####@@@x#x##@#@
#xxx#@#x##[email protected]@#[email protected]@@[email protected]#@#[email protected]#####
#[email protected]#@[email protected]@@@##@x#xx#[email protected]#xx#@#####x#@x
xx##@#@x##x##x#@x#@a#[email protected]##@#@##[email protected]#@@[email protected]
x#x#@[email protected]#x#@##@[email protected]#[email protected]##x##xx#@#[email protected]@
#[email protected]@#@###x##[email protected]#@@#@@[email protected]@@[email protected]@@@##@@[email protected]@x
x#[email protected]###@xxx#@#x#@@###@#@##@x#@[email protected]#@@#@@
#@#[email protected]#x#x###@[email protected]@xxx####[email protected]##@x####xx#@x
#x#@x#x######@@#[email protected]#xxxx#[email protected]@@#xx#x#####@
样例输出
13
7

分析:

这道题就是一道水题。看起来好像有一些动态规划。但是!这怎么可能DP。所以。考虑BFS。BFS要保证最少步数的优先,这样最先走到目标一定是最优接。

放出代码:

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
struct node{
    int x,y,step;
    friend bool operator < (node a,node b){
        return a.step>b.step;
    }
};
priority_queue<node>qu;
char map_1[210][210];
int visit[210][210];
int left[4]={0,0,1,-1},right[4]={1,-1,0,0};
int starx,stary,lastx,lasty;
void BFS()
{
    node start;
    start.step=0;
    start.x=starx;start.y=stary;
    visit[starx][stary]=1;
    qu.push(start);
    while(!qu.empty()){
        node first=qu.top();
        qu.pop();
        if(first.x==lastx&&first.y==lasty){
            printf("%d\n",first.step);
            return ;
        }
        for(int i=0;i<4;++i)
        {
            if(map_1[first.x+left[i]][first.y+right[i]]==‘#‘)continue;
            if(visit[first.x+left[i]][first.y+right[i]])continue;
            if(map_1[first.x+left[i]][first.y+right[i]]==‘x‘){
                node news;
                news.x=first.x+left[i];
                news.y=first.y+right[i];
                news.step=first.step+2;
                qu.push(news);
                visit[news.x][news.y]=1;
            }
            else {
                node news;
                news.x=first.x+left[i];
                news.y=first.y+right[i];
                news.step=first.step+1;
                qu.push(news);
                visit[news.x][news.y]=1;
            }
        }
    }
    printf("Impossible\n");
    return ;
}
int main()
{
    //freopen("4980.in","r",stdin);
    //freopen("4980.out","w",stdout);
    int T;
    scanf("%d",&T);
    while(T--){
        memset(map_1,‘#‘,sizeof(map_1));
        int x,y;
        scanf("%d%d\n",&x,&y);
        for(int i=1;i<=x;++i)
        {
            for(int j=1;j<=y;++j)
            {
                scanf("%c",&map_1[i][j]);
                if(map_1[i][j]==‘a‘){
                    lastx=i;
                    lasty=j;
                }
                if(map_1[i][j]==‘r‘){
                    starx=i;
                    stary=j;
                }
            }
            scanf("\n");
        }
        memset(visit,0,sizeof(visit));
        while(!qu.empty())qu.pop();
        BFS();
    }
    //fclose(stdin);
    //fclose(stdout);
    return 0;
}
时间: 2024-11-06 17:25:59

OpenJudge4980:拯救行动//stl有限队列的相关文章

【STL】优先队列priority_queue详解+OpenJudge-4980拯救行动

一.关于优先队列 队列(queue)这种东西广大OIer应该都不陌生,或者说,队列都不会你还学个卵啊(╯‵□′)╯︵┻━┻咳咳,通俗讲,队列是一种只允许从前端(队头)删除元素.从后端(队尾)插入元素的数据结构.而优先队列(priority queue)是一种赋予每个队列中元素以一个优先级的队列.在执行删除操作时,优先队列会删除具有最高优先级的元素.如此奇妙的优先队列有什么用呢,举个例子,给定一个长为n的序列和m组询问,对于每组询问,我们要找出删去序列中最小的数,再向序列加入一个数.朴素的想法是对

STL中队列(queue)的使用方法

STL 中队列的使用(queue) 基本操作: push(x) 将x压入队列的末端 pop() 弹出队列的第一个元素(队顶元素),注意此函数并不返回任何值 front() 返回第一个元素(队顶元素) back() 返回最后被压入的元素(队尾元素) empty() 当队列为空时,返回true size() 返回队列的长度 使用方法: 头文件: #include <queue> 声明方法: 1.普通声明 queue<int>q; 2.结构体 struct node { int x, y

STL的队列和栈简单使用

STL的队列和栈简单使用 #include <iostream>#include <cstdio>#include <string.h>#include <algorithm>#include <queue>#include <stack>using namespace std;int main(){ queue<int> Q; stack<int> S; int i; for(i=1;i<=10;i++

poj 2243 bfs 利用 结构体中的step成员保存步数 ,STL的队列

//BFS #include <iostream> #include <queue> using namespace std; bool used[8][8]; int move[8][2]={1,2, -1,2, -2,1, -2,-1, -1,-2, 1,-2, 2,-1, 2,1}; struct position { int i,j; int step; position(int a,int b,int c) { i=a; j=b; step=c; } }; int mai

STL之队列的运用

卡片游戏:很好地介绍了队列的特点和应用 桌上有一叠牌,从第一张牌开始从上往下依次编号1~n.当至少还剩两张牌时进行如下操作:把第一张牌扔掉,然后把新的第一张牌放到整叠牌的最后.输入n,输出每次扔掉的牌,以及最后剩下的牌. 样例输入:7 样例输出:1 3 5 7 4 2 6 代码如下: #include<iostream> #include<queue> using namespace std; queue<int> q; //声明队列 int main() { int

利用STl实现队列

队列的使用注意:1.无法输出数列,可以返回队尾或队首. 2.队列是先进后出,相当于一群人排队,队列头的人先走,后来的人站在队尾. 3.利用STL来实现普通队列: q.pop() 删除队首 q.front() 返回队首 q.back() 返回队尾 q.push(x) 队尾加入一个元素x q.empty() 队列为空则为真为0 q.size() 返回队列长度,元素个数 #include <algorithm> #include <cstring> #include <queue&

POJ 2431 Expedition (STL 优先权队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8053   Accepted: 2359 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

UVA - 540 Team Queue(STL,队列 )

Team Queue Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Submit Status Description Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known,

C++ STL queue 队列容器 基本方法

创建队列 queue<int> que; 读取队首元素 que.front(); 读取队尾元素 que.back(); 元素入队 queue.pust(); 元素出队 queue.pop(); 队列大小 queue.size(); 队列是否为空 queue.empty(); 原文地址:https://www.cnblogs.com/izayoi/p/9629488.html