poj3087--Shuffle'm Up(小模拟)

Shuffle‘m Up

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5983   Accepted: 2809

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2,
each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C =
5:

The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2.
On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing
that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is
placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to
form a new S1 and the topmost C chips from S12 to form a new S2.
The shuffle operation may then be repeated to form a newS12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack
(S1 and S2). The second line of each dataset specifies the colors of each of theC chips in stack S1,
starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost
chip. Colors are expressed as a single uppercase letter (A throughH). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase
letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero
or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant
stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (?1) for the number of shuffle operations.

Sample Input

2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output

1 2
2 -1

Source

简单小模拟,按照给的规则,看能不能洗出想要的牌,如果出现了曾经出现过的序列,那么就陷入一个环,不能得到结果,否则找到次数输出

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char s[1000][500] , s1[300] , s2[300] ;
int main()
{
    int t , tt = 1 , n , l , flag , i , j ;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        scanf("%s %s", s1, s2);
        scanf("%s", s[0]);
        flag = 0 ;
        for(l = 1 ; l <= 100 ; l++)
        {
            j = 0 ;
            for(i = 0 ; i < n ; i++)
            {
                s[l][j++] = s2[i] ;
                s[l][j++] = s1[i] ;
            }
            s[l][j] = '\0' ;
            if( !strcmp(s[0],s[l]) )
            {
                flag = 1 ;
                break;
            }
            for(i = 1 ; i < l ; i++)
                if( !strcmp(s[i],s[l]) )
                    break;
            if(i < l) break;
            for(i = 0 ; i < n ; i++)
                s1[i] = s[l][i] ;
            s1[i] = '\0' ;
            for( ; i < 2*n ; i++)
                s2[i-n] = s[l][i];
            s2[i-n] = '\0' ;
        }
        if( flag )
            printf("%d %d\n",tt++, l);
        else
            printf("%d -1\n", tt++);
    }
    return 0;
}

poj3087--Shuffle'm Up(小模拟)

时间: 2024-10-18 18:32:22

poj3087--Shuffle'm Up(小模拟)的相关文章

poj3087 Shuffle&#39;m Up(模拟)

Shuffle'm Up Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10766   Accepted: 4976 Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks o

POJ3087 Shuffle&#39;m Up 简单模拟

题意:就是给你两副扑克,然后一张盖一张洗牌,不断重复这个过程,看能不能达到目标的扑克顺序 分析:然后就模拟下,-1的情况就是有循环节 #include<cstdio> #include<algorithm> #include<iostream> #include<cstring> #include<cmath> #include<map> #include<queue> #include<stdlib.h> #

POJ3087:Shuffle&#39;m Up(模拟)

http://poj.org/problem?id=3087 Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stac

poj3087 Shuffle&#39;m Up

Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several

POJ 3087 Shuffle&#39;m Up (模拟)

Shuffle'm Up Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5850   Accepted: 2744 Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of

FZU2152 文件系统 小模拟

Description 每个Linux文件具有四种访问权限:可读(r).可写(w).可执行(x)和无权限(-). 利用ls -l命令可以看到某个文件或目录的权限,它以显示数据的第一个字段为准.第一个字段由10个字符组成,如下: -rwxr-xr-x 第1位表示文件类型,-表示文件,d表示目录 2-4位表示文件所有者的权限,u权限 5-7位表示文件所属组的成员的权限,g权限 8-10位表示所有者和所属组的成员之外的用户的权限,o权限 2-10位的权限总和有时称为a权限 以上例子中,表示这是一个文件

poj 3087 Shuffle&#39;m Up (模拟搜索)

Shuffle'm Up Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5953   Accepted: 2796 Description A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of

POJ 3087 Shuffle&#39;m Up(模拟)

题意   给两堆牌s1,s2交给你洗 每堆有c张  每次洗牌得到s12  其中s2的最下面一张在s12的最下面一张然后按顺序一张s1一张s2  洗好之后可以把s12下面的c张做s1   上面的c张做s2  求多少次洗牌之后可以得到输入给你的串s  不能得到输出-1 简单模拟  s1+s2!=s就一直洗牌   如果回到初始状态都没得到s就不会得到s了   得到s就可以输出洗牌次数了 #include<iostream> #include<string> using namespace

【11.8校内测试】【倒计时2天】【状压DP】【随机化?/暴力小模拟】

Solution 数据范围疯狂暗示状压,可是一开始发现状态特别难受. 将每一层的奇偶性状压,预处理所有状态的奇偶性.每一层的输入代表的其实可以是下一层某个点可以被从这一层哪些点转移到. 所以枚举每个状态,再枚举下一层转移到哪个点,统计这个点被这个状态更新的话正边和反边分别的奇偶性,转移即可. 第二层和最后一层单独处理即可. Code #include<bits/stdc++.h> #define mod 998244353 using namespace std; int x, dp[2][(