杭电---2053 Switch Game

Problem Description  There are many lamps in a line. All of themare off at first. A series of operations are carried out on these lamps. On thei-th operation, the lamps whose numbers are the multiple of i change thecondition ( on to off and off to on ).

Input Each test case contains only a number n ( 0< n<= 10^5) in a line.

Output Output the condition of the n-th lamp after infinity operations ( 0 -off, 1 - on ).

Sample Input  1

5

Sample Output  1

0

Hint

Consider the second test case:

The initial condition      : 0 0 0 0 0 …

After the first operation  : 1 1 1 1 1 …

After the second operation : 1 0 1 0 1 …

After the third operation  : 1 0 0 0 1 …

After the fourth operation : 1 0 0 1 1 …

After the fifth operation  : 1 0 0 1 0 …

The later operations cannot change thecondition of the fifth lamp any more. So the answer is 0.

Author LL

分析:这道题刚开始灯是灭的,当时1的时候,所有是1倍数的灯都会亮,当是2的时候所有是2倍数的灯都会灭,当是3的时候所有的灯是3的倍数的也都会发生变化,,,等输入一个数的时候,要判断该灯是亮还是灭,只需判断灯发生变化的次数是奇数还是偶数即可,当是奇数的时候的灯是亮的,当是偶数的时候灯是灭的

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        int t=0;
        for(int i=1;i<=n;i++)
        {
            if(n%i==0)
                t++;
        }
        if(t%2==0)
            cout<<0<<endl;
        else
            cout<<1<<endl;
    }
    return 0;
}
时间: 2024-10-18 00:27:24

杭电---2053 Switch Game的相关文章

杭电2053

#include<stdio.h> int main() { int n,i; while(scanf("%d",&n)!=EOF) { int num=0; for(i=1;i<=n;i++) { if(n%i==0) num++; } if(num%2==0) printf("0\n"); else printf("1\n"); } } 看输入的数有多少个因数,有多少个因数就表示被改变了几次状态,因数的数目为偶数的,

杭电2053 WA

#include<stdio.h> int main() { int n,i,a[105]; while(scanf("%d",&n)!=EOF) { for(i=0;i<=100;i++) { a[i]=0; } a[0]=1; for(i=1;i<=100;i++) { if((i+1)%n==0) { if(a[i+1]==1) a[i+1]=0; else a[i+1]=1; } } for(i=0;i<=100;i++) printf(&

杭电2053,简单易懂的C语言代码!!!

Re:题意:有无限多的电灯排成一列,一开始都是关,操作无限多次,第i次操作会把编号为i和i的倍数的电灯改变状态.问最后第i盏电灯的状态是开还是关 //后边有数据... #include<stdio.h> int main() { int b,n,i; while(scanf("%d",&n)!=EOF) { if(n==1)//第一次操作,开关全变为1: printf("1\n"); else { b=0; for(i=2;i<=n;i++

杭电 acm 2053 ( Switch Game )

这题思路: 一开始有n盏灯,且全部为关闭状态,都记为 0  就是  The initial condition :      0 0 0 0 0 … 然后之后进行i操作就是对这些灯以是否能被i整除,进行改变状态,如将 0 改为 1 或 将 1 改为 0 正如提醒里的 After the first operation :  1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation :  1 0 0

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

杭电 HDU 1038 Biker&#39;s Trip Odometer

Biker's Trip Odometer Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4745    Accepted Submission(s): 3144 Problem Description Most bicycle speedometers work by using a Hall Effect sensor faste

杭电ACM题目分类

杭电ACM题目分类 基础题:1000.1001.1004.1005.1008.1012.1013.1014.1017.1019.1021.1028. 1029.1032.1037.1040.1048.1056.1058.1061.1070.1076.1089.1090.1091.1092. 1093.1094.1095.1096.1097.1098.1106.1108.1157.1163.1164.1170.1194.1196. 1197.1201.1202.1205.1219.1234.123

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI

杭电 2059 龟兔赛跑

转载请标明出处:http://blog.csdn.net/lmj623565791/article/details/28441197 现在很多APP都给ScrollView添加了反弹效果,QQ.小米私密短信等.恰好在网上看到一个类:BounceScrollView , 原创地址是:http://blog.csdn.net/h7870181/article/details/8960430 , 可惜作者没有提供一个效果图,于是我发现小米短信列表页往下拉,有反弹效果,且拉到1/3以上时,会打开私密短信