kuangbin专题五:B - The Suspects POJ - 1611

B - The Suspects

POJ - 1611

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there
are many student groups. Students in the same group intercommunicate
with each other frequently, and a student may join several groups. To
prevent the possible transmissions of SARS, the NSYSU collects the
member lists of all student groups, and makes the following rule in
their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the
suspects when a student is recognized as a suspect. Your job is to write
a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with
two integers n and m in a line, where n is the number of students, and m
is the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer
between 0 and n?1, and initially student 0 is recognized as a suspect in
all the cases. This line is followed by m member lists of the groups,
one line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1题意:给 n 个学生 0--n-1  顺序编号 , 然后 第 0 号 同学被认为是 传染病嫌疑者 , 之后 有 m 个团体 ,    后面 m 行 , 每行 第一个数字 k 表示 这个团体有 k 个人 , 之后 k 个数字 表示 这个团体内同学的编号    最后  统计 多少个人 是 传染病的怀疑者 (与第 0 号 同学 同一个集合的同学有多少位)思路:并查集 模板题目 

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std ; 

#define maxn 50000
int father[maxn] ;
int n , m , k ;
int num[maxn] ;
// 初始化 编号 , 每一个元素都是一个 集合
void init(){
    for(int i=0 ; i<=n ; i++){
        father[i] = i ;
    }
    return;
}
// 查找 x 元素 所在集合的代表元素的 编号
// 同时 理顺 上一次 对本集合 合并
// 导致的部分成员 没有指向代表元素
int find(int x){
    if(x!=father[x]){
        father[x] = find(father[x]) ;
    }
    return father[x] ;
}
// y 所在集合 所有元素 都指向 rooty
// x 所在集合 所有元素 都指向 rootx
// 如果 x y 不是 统一集合 ,则把 y 集合的代表元素 指向 x 集合的代表元素 rootx
// 上述方法实现合并 , 会导致 一部分 y 集合元素 没有指向 rootx
// 这种情况 会在 下一次 调用 find() 函数 时 解决
void Union_set(int x , int y){
    int rootx = find(x) ;
    int rooty = find(y) ;
    if(rootx!=rooty){
        father[rooty] = rootx ;
    }
}
// 通过检查 两元素 的所在集合的代表元素 是否相等 来判断两元素是不是统一集合的元素
bool check(int x , int y){
    return find(x) == find(y) ;
}

int main(){

    while(~scanf("%d %d" , &n , &m)){
        if(n==0&&m==0){
            break ;
        }
        init() ; 

        for(int i=1 ; i<=m ; i++){
            scanf("%d" ,&k) ; 

            for(int j=1 ; j<=k ;  j++){
                scanf("%d" , &num[j]) ;
            }

            for(int j=1 ; j<k ; j++){
                Union_set(num[j] , num[j+1]) ;
            }
        }

        int result = 0 ;
        for(int i=0 ; i<n ; i++){
            // 和 0 号 同学是 同一集合的 同学都是 嫌疑人
            if(check(i , 0 )){
                result ++ ;
            }
        }

        printf("%d\n" , result) ;
    }
    return 0 ;
}

时间: 2024-10-27 20:02:45

kuangbin专题五:B - The Suspects POJ - 1611的相关文章

B - The Suspects POJ - 1611

B - The Suspects POJ - 1611 Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 61692   Accepted: 29146 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mi

The Suspects POJ - 1611 并查集,同集合的数

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.In the Not-Spread

kuangbin专题五、并查集

题意:给你1~n的点的坐标,O x,表示x点修好,S x y表示查询x点能否连通y点,连通的条件是dis<d 直接判断最后查询时,是否在同一个集合就可以. ps:注意两点是否在同一集合,必须用find()找,因为fa[]找的,可能不是最终的爸爸. 1 #include<iostream> 2 #include<cstdio> 3 using namespace std; 4 5 int n,d; 6 int x[1005],y[1005]; 7 int vis[1005],f

kuangbin专题五:C - How Many Tables HDU - 1213

C - How Many Tables HDU - 1213 Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends

The Suspects POJ - 1611

#include<iostream> using namespace std; const int N=30010; int n,m,ans,p[N]; int find(int x) { if(p[x]!=x) p[x]=find(p[x]); return p[x]; } int main() { while(cin>>n>>m,m||n) { int res=0; for(int i=0;i<=n;i++) p[i]=i; int num,fa; int t

POJ 1611 The Suspects(并查集)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 22296   Accepted: 10842 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ 1611 The Suspects(特别无语的并查集)

很简单的一道题目,开始用的是并查集的分离集合森林做,不知道怎么的特别不稳定,太奇怪了,WA无数次,无奈之下改成一维数组了..sad AC #include <iostream> #include <cstdio> #include <cstdlib> #include <cstring> #include <algorithm> #include <math.h> #define PI acos(-1,0) using namespa

[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 21586   Accepted: 10456 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

poj 1611:The Suspects(并查集,经典题)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 21472   Accepted: 10393 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T