POJ - 2236 Wireless Network(简单并查集)

Wireless Network

Time Limit: 10000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

Submit Status

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by
one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the
communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers
xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

1. "O p" (1 <= p <= N), which means repairing computer p.

2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

简单并查集,输入n电脑数量和d两台电脑的最大通信距离,下面n行是1-n台电脑的位置坐标,接下来输入到文件结束是操作O a,表示修好第a台电脑,S a b查询这两台电脑是否可以通信。每次修好一台电脑遍历存在的电脑,把通信范围内的电脑并入一个集合就好了。注意输入到文件结束。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

struct Point
{
	int x, y;
};

const int MAXN = 1000 + 100;
int parent[MAXN];
int n, d;
Point p[MAXN];
bool isrep[MAXN];

void make_set()
{
	for (int i = 0; i <= n; i++)
	{
		parent[i] = i;
		isrep[i] = false;
	}
}

int find_set(int t)
{
	if (parent[t] == t)
		return t;
	else
		return parent[t] = find_set(parent[t]);
}

void union_set(int a, int b)
{
	int t1 = find_set(a);
	int t2 = find_set(b);
	if (t1 != t2)
	{
		parent[t2] = t1;
	}
}

bool isIn(Point a, Point b)
{
	int dd = (a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y);
	if (dd <= d*d) return true;
	return false;
}

int main()
{
	scanf("%d%d", &n, &d);
	for (int i = 1; i <= n; i++)
	{
		scanf("%d%d", &p[i].x, &p[i].y);
	}

	char op;
	int a, b;

	make_set();

	while(cin>>op)
	{
		if (op == 'S')
		{
			scanf("%d%d", &a, &b);
			if (find_set(parent[a]) == find_set(parent[b]))
				printf("SUCCESS\n");
			else
				printf("FAIL\n");
		}
		else
		{
			scanf("%d", &a);
			for (int j = 1; j <= n; j++)
			{
				if (isrep[j])
				{
					if (isIn(p[a], p[j]))
						union_set(a, j);
				}
			}
			isrep[a] = true;
		}
	}
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-11-08 23:08:33

POJ - 2236 Wireless Network(简单并查集)的相关文章

poj 2236:Wireless Network(并查集,提高题)

Wireless Network Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 16065   Accepted: 6778 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computer

poj 2236 Wireless Network(并查集)

题目大意: 给你N台电脑,从1-N.一个数字,表示两台计算机的最大通信距离,超过这个距离就无法进行通信.然后分别告诉这些电脑的坐标,接下来有两种操作,第一种O表示这点电脑修好,第二种S,表示测试这两台电脑能不能进行正常的通信   解题思路: 并查集的简单应用,对每次修好的电脑对其它已经修好的电脑遍历,如果距离小于等于最大通信距离就将他们合并.之后判断2台电脑是不是一个集合中就KO了 1 #pragma comment(linker, "/STACK:1024000000,1024000000&q

poj 2236 Wireless Network 【并查集】

Wireless Network Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 16832   Accepted: 7068 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computer

POJ - 2236 Wireless Network (并查集)

https://cn.vjudge.net/problem/POJ-2236 题意 有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,修理(O)和检测两台计算机是否连通(S),只有修理好的计算机才能连通.连通有个规则,两台计算机的距离不能超过给定的最大距离D(一开始会给你n台计算机的坐标).检测的时候输出两台计算机是否能连通. 分析 注意审题..只有修理好的才能算联通.于是把所有修理好的并一起就行了. #include <iostream> #include <

Wireless Network——简单并查集

题目链接 题意: 有n台电脑,x,y代表电脑坐标 ,两台修好的电脑如果距离<=d就可以联网, O p 代表 修理p电脑  S p q代表链接p q 题解: 并查集维护即可,在O操作下,在已经修好的电脑里面找到与当前电脑距离<=d 的,join()一下 代码: #include<iostream> #include<stdio.h> #include<math.h> using namespace std; typedef long long ll; cons

POJ 2236 Wireless Network ||POJ 1703 Find them, Catch them 并查集

POJ 2236 Wireless Network http://poj.org/problem?id=2236 题目大意: 给你N台损坏的电脑坐标,这些电脑只能与不超过距离d的电脑通信,但如果x和y均能C通信,则x和y可以通信.现在给出若干个操作, O p 代表修复编号为p的电脑 S p q代表询问p和q是不是能通信. 思路: 并查集即可.. 如果修复了一台电脑,则把与它相连距离不超过d的且修复了的放在一个集合里面. #include<cstdio> #include<cstring&

POJ2236 wireless network 【并查集水题】

前端开发whqet,csdn,王海庆,whqet,前端开发专家 今天是个好日子,2014年5月20日,表白的最佳时机,虽说孩子已经四岁.结婚已经五年,但是也不可以偷懒,于是有了这个效果. 在线研究点这里,下载收藏点这里.程序猿and程序媛,大胆秀出你的爱吧. 利用html5 canvas实现动态的文字粒子效果,效果如下. OK,简单看看原理,首先我们需要在canvas里面实现描边文字,然后利用getImageData获得描边文字的像素矩阵,将粒子效果绑定在描边文章上. 整个效果如下. html文

POJ 2236 Wireless Network

Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 18146   Accepted: 7660 Description An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpec

POJ 2524 Ubiquitous Religions (简单并查集,三种方式)

Ubiquitous Religions Time Limit: 5000MS   Memory Limit: 65536K Total Submissions: 30791   Accepted: 14928 Description There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in findi