Cylinder Candy(积分+旋转体)

Cylinder Candy



Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge



Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm.

The candy center needs to be covered with a uniform coat of chocolate. The uniform coat of chocolate is dmm thick.

You are asked to calcualte the volume and the surface of the chocolate covered candy.

Input

There are multiple test cases. The first line of input contains an integer T(1≤ T≤ 1000) indicating the number of test cases. For each test case:

There are three integers rhd in one line. (1≤ rhd ≤
100)

Output

For each case, print the volume and surface area of the candy in one line. The relative error should be less than 10-8.

Sample Input

2
1 1 1
1 3 5

Sample Output

32.907950527415 51.155135338077
1141.046818749128 532.235830206285

经过这几天的思考,以及各种抓狂,我只能说数学老师就是牛,一语点了醒我!好纠结,,,难道以后要背着高数跑。。。



这是我最初的想法,然后经过求证,体积并不要减去里面的圆柱;

过程已经写得很详尽了。。。

转载请注明出处:寻找&星空の孩子 
题目链接:http://acm.zju.edu.cn/onlinejudge/contestInfo.do?contestId=361


#include<stdio.h>
#include<math.h>
#define PI acos(-1.0)
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        double r,h,d;
        double v,s;
        scanf("%lf%lf%lf",&r,&h,&d);
        v=PI*PI*r*d*d+4.0/3*PI*d*d*d+2*PI*r*r*d+PI*h*((d+r)*(d+r));
        s=2*(PI*PI*r*d+2*PI*d*d+PI*r*r+PI*h*(r+d));
        printf("%.12lf %.12lf\n",v,s);

    }
    return 0;
}

				
时间: 2024-10-31 11:34:22

Cylinder Candy(积分+旋转体)的相关文章

Cylinder Candy(积分)

Cylinder Candy Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm. The candy center needs to

ZOJ 3866 Cylinder Candy (浙大校赛+积分应用)

题目链接:ZOJ 3866 Cylinder Candy 题意:抽象出来就是求一个圆柱体外面加一层厚度为d的巧克力,求包装完这个立体图形的体积和表面积. 剖析: 以下是包装后的三视图: 图3 接下里就是积分了 2*V1是图3绕y轴的体积 V2是中间的半径为(r+d)的圆柱体积 S1是中间的半径为(r+d)的圆柱的表面积 S2是上下两个半径为r的圆的面积 S3是图3绕y轴的侧面积 附上旋转体的侧面积和体积求法: AC代码: #include <stdio.h> #include <math

ZOJ - 3866 Cylinder Candy (数学,积分)

Cylinder Candy Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %lld & %llu Submit Status Description Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm an

2016 省热身赛 Cylinder Candy

Cylinder Candy Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Description Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm

ZOJ 3866 Cylinder Candy

Cylinder Candy Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm. The candy center

浙大第十五届校赛 G-Cylinder Candy

Cylinder Candy Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylinder with radius r mm and height h mm. The candy center

模拟3

    ID Origin Title 6 / 12 Problem A ZOJ 3860 Find the Spy 6 / 27 Problem B ZOJ 3861 Valid Pattern Lock     Problem C ZOJ 3862 Intersection   0 / 1 Problem D ZOJ 3863 Paths on the Tree     Problem E ZOJ 3864 Quiz for EXO-L     Problem F ZOJ 3865 Supe

15th浙大校赛 zoj3860-3868

比赛链接: here 题目对应到ZOJ3860~3868 A Find the Spy 水 #include<cstdio> #include<map> #include<cstring> #include<iostream> using namespace std; map<int,int>mp; map<int,int>::iterator it; int main() { int T,n,x; scanf("%d&qu

zoj 3866

G - Cylinder Candy Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu Submit Status Practice ZOJ 3866 Description Edward the confectioner is making a new batch of chocolate covered candy. Each candy center is shaped as a cylin