HDU1078 FatMouse and Cheese 【内存搜索】

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4966    Accepted Submission(s): 2035

Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100
blocks of cheese in a hole. Now he‘s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1‘s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

Source

Zhejiang University Training Contest 2001

题意:给定一张N*N的图。每一个格子上有一些豆子,初始位置是(0,0)。每次仅仅能向一个方向走最多m步,然后停下吃掉这个格子上的豆子。但有个限制是当前格子上的豆子必须比之前呆的一个格子里的豆子多。问最多能吃多少豆子。

题解:深搜,dp[i][j]表示从(i,j)点出发最多能吃到的豆子。

#include <stdio.h>
#include <string.h>

#define maxn 105

int G[maxn][maxn], n, m;
int dp[maxn][maxn];
const int mov[][2] = {1, 0, -1, 0, 0, 1, 0, -1};

void getMap() {
	int i, j;
	for(i = 0; i < n; ++i)
		for(j = 0; j < n; ++j)
			scanf("%d", &G[i][j]);
}

int max(int a, int b) {
	return a > b ?

a : b;
}

bool check(int x, int y) {
	if(x < 0 || x >= n || y < 0 || y >= n)
		return 0;
	return 1;
}

int DFS(int xx, int yy) {
	int i, j, x, y, maxv = 0;
	if(dp[xx][yy]) return dp[xx][yy];
	for(i = 1; i <= m; ++i) {
		for(j = 0; j < 4; ++j) {
			x = xx + mov[j][0] * i;
			y = yy + mov[j][1] * i;
			if(check(x, y) && G[x][y] > G[xx][yy])
				maxv = max(maxv, DFS(x, y));
		}
	}
	return dp[xx][yy] = maxv + G[xx][yy];
}

void solve() {
	int i, j;
	memset(dp, 0, sizeof(dp));
	printf("%d\n", DFS(0, 0));
}

int main() {
	// freopen("stdin.txt", "r", stdin);
	while(scanf("%d%d", &n, &m), n > 0) {
		getMap();
		solve();
	}
	return 0;
}

版权声明:本文博主原创文章。博客,未经同意不得转载。

时间: 2024-12-21 18:18:06

HDU1078 FatMouse and Cheese 【内存搜索】的相关文章

hdu1078 FatMouse and Cheese(记忆化搜索)

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1078 Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q

HDU1078 FatMouse and Cheese 【记忆化搜索】

FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4966    Accepted Submission(s): 2035 Problem Description FatMouse has stored some cheese in a city. The city can be considere

FatMouse and Cheese 动态化搜索

FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7576    Accepted Submission(s): 3133 Problem Description FatMouse has stored some cheese in a city. The city can be considered

hdu1078 FatMouse and Cheese(记忆化搜索)

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1078 题目大意: 题目中的k表示横向或者竖直最多可曾经进的距离,不可以拐弯.老鼠的出发点是(1,1). 对于老鼠从当前点可以到达的点.筛选出从这些点到达当前点所能获得的cheese的最大值. 思路:记忆化搜索. 假设对于当前的点.没有被搜索过(dp[i][j]=0).那么就对其进行搜索.搜索过程中记录下最优的解. 假设已经被搜索过了,就能够直接利用已经记录的值来进行推断 了,不须要再去搜索. 假设

HDU1078:FatMouse and Cheese(记忆化)

Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 a

hdu 1078 FatMouse and Cheese (dfs+记忆化搜索)

pid=1078">FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4811    Accepted Submission(s): 1945 Problem Description FatMouse has stored some cheese in a city. The city can

FatMouse and Cheese (hdu 1078 记忆化搜索)

FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5463    Accepted Submission(s): 2227 Problem Description FatMouse has stored some cheese in a city. The city can be considere

(记忆化搜索) FatMouse and Cheese(hdu 1078)

题目大意: 给n*n地图,老鼠初始位置在(0,0),它每次行走要么横着走要么竖着走,每次最多可以走出k个单位长度,且落脚点的权值必须比上一个落脚点的权值大,求最终可以获得的最大权值 (题目很容易会理解错题意,道友小心) #include <iostream> #include <cstdio> #include <cstring> #include <algorithm> #include <cmath> using namespace std;

HDU 1078 FatMouse and Cheese(记忆化搜索)

FatMouse and Cheese Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8610    Accepted Submission(s): 3611 Problem Description FatMouse has stored some cheese in a city. The city can be considere