POJ1273_Drainage Ditches(网络流)

Drainage Ditches

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54887   Accepted: 20919

Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s
clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points
for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow
through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

解题报告

听说第一发网络流要纪念一下,有模板的嫌疑,Discuss的情况都遇上了,多组忘了清零,重边忘了处理。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define inf 99999999
#define M 200+10
using namespace std;
struct edge
{
    int c,f;
}edge[M][M];
int n,m,vis[M],a[M],pre[M],f;
queue<int>Q;
void ford()
{
    while(1)
    {
        memset(pre,-1,sizeof(pre));
        memset(a,-1,sizeof(a));
        memset(vis,-1,sizeof(vis));
        while(!Q.empty())
        Q.pop();
        Q.push(1);
        pre[1]=1;
        vis[1]=0;
        a[1]=inf;
        while(!Q.empty()&&vis[m]==-1)
        {
            int u=Q.front();
            Q.pop();
            for(int v=1;v<=m;v++)
            {
                if(vis[v]==-1)
                {
                    if(edge[u][v].f<edge[u][v].c)
                    {
                        a[v]=min(a[u],edge[u][v].c-edge[u][v].f);
                        vis[v]=0;
                        pre[v]=u;
                        Q.push(v);
                    }
                    else if(edge[v][u].f>0)
                    {
                        a[v]=min(a[u],edge[v][u].f);
                        vis[v]=0;
                        pre[v]=-u;
                        Q.push(v);
                    }
                }
            }
            vis[u]=1;
        }
        if(vis[m]==-1||a[m]==0)
        break;
        int k1=m,k2=abs(pre[k1]);
        int aaa=a[m];
        while(1)
        {
            edge[k2][k1].f+=aaa;
            edge[k1][k2].f-=aaa;
            if(k2==1)break;
            k1=k2;k2=abs(pre[k2]);
        }
        f+=a[m];
    }
}
int main()
{
    int i,j,u,v,w;
    while(~scanf("%d%d",&n,&m))
    {
        f=0;
        memset(edge,0,sizeof(edge));
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            edge[u][v].c+=w;
        }
        ford();
        printf("%d\n",f);
    }
    return 0;
}

POJ1273_Drainage Ditches(网络流)

时间: 2024-10-03 14:37:17

POJ1273_Drainage Ditches(网络流)的相关文章

POJ 1273 Drainage Ditches(网络流 最大流)

Drainage Ditches Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 55893   Accepted: 21449 Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by

POJ 1273 Drainage Ditches 网络流基础

Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage

HDU1532_Drainage Ditches(网络流/EK模板)

Drainage Ditches Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8599    Accepted Submission(s): 4005 Problem Description Every time it rains on Farmer John's fields, a pond forms over Bessie's

POJ 1273 Drainage Ditches (网络流Dinic模板)

Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage

POJ 1273 Drainage Ditches (网络流最大流基础 Edmonds_Karp算法)

Drainage Ditches Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 59219   Accepted: 22740 Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by

USACO 4.2 Drainage Ditches(网络流模板题)

Drainage DitchesHal Burch Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a se

[POJ1273]Drainage Ditches 网络流(最大流)

题目链接:http://poj.org/problem?id=1273 网络流裸题,注意有重边.重边的处理方法很简单,就是将对应的c叠加到对应边上.注意初始化为0. 我用的是最朴素的FF方法,即找增广路.之前用dfs找增广路WA了,应该是碰到了随机找一条增光路这种方法碰到了killer case.给出WA代码(初学用喜闻乐见链式前向星建图,比较繁琐.不过好在最终还是WA掉了). 1 #include <algorithm> 2 #include <iostream> 3 #incl

poj 1273 Drainage Ditches 网络流最大流基础

Drainage Ditches Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 59176   Accepted: 22723 Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by

NYOJ 323 &amp;&amp; HDU 1532 &amp;&amp; POJ 1273 Drainage Ditches (网络流之最大流入门)

链接:click here 题意:给出n个河流,m个点,以及每个河流的流量,求从1到m点的最大流量. 思路:最裸的网络流题目  意思就是求从源点到汇点的最大流. 第一道网络流,一边看着书上的介绍,一边敲下代码: 用的是网络流算法ford-fulkerson 题目数据量小,邻接表和邻接矩阵都可以过 代码: #include <ctype.h> //最大流 入门 #include <stdio.h> #include <vector> #include <stdlib