POJ 3268 Silver Cow Party(SPFA)

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X

Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

两次SPFA水过。

题意:N个农场,每个农场的都有一个奶牛去参加派对,M条单向路。

求对于所有奶牛来说花费在路上的最长时间(PS:奶牛都是选择最短的路)

1:以X为源点,各顶点的出边构成邻接表,求源点到各顶点的最短路。

2:以X为源点,各顶点的入边做出边,构成邻接表,求源点到各顶电的最短路。

将两次时间加起来最大的即为答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<queue>
using namespace std;
const int maxn=101000;
const int INF=0x3f3f3f3f;
int head[maxn],end[maxn];
int next[maxn],cost[maxn];
int u[maxn],v[maxn],w[maxn];
int d1[maxn],d2[maxn],e;
int visit[maxn],cnt[maxn];
void init()
{
    e=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v,int w)
{
    end[e]=v;
    cost[e]=w;
    next[e]=head[u];
    head[u]=e++;
}
void spfa(int x,int n)
{
    memset(visit,0,sizeof(visit));
    memset(cnt,0,sizeof(cnt));
    memset(d1,INF,sizeof(d1));
    queue<int>q;
    q.push(x);
    visit[x]=1;
    cnt[x]++;
    d1[x]=0;
    while(!q.empty())
    {
        int uu=q.front();
        q.pop();
        visit[uu]=0;
        for(int i=head[uu];i!=-1;i=next[i])
        {
            int vv=end[i];
            int ww=cost[i];
            if(d1[vv]>d1[uu]+ww)
            {
                d1[vv]=d1[uu]+ww;
                if(!visit[vv])
                {
                    visit[vv]=1;
                    q.push(vv);
                    if(++cnt[vv]>n)
                        return ;
                }
            }
        }
    }
}
int main()
{
    int n,m,x;
    while(~scanf("%d%d%d",&n,&m,&x))
    {
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u[i],&v[i],&w[i]);
            add(u[i],v[i],w[i]);
        }
        spfa(x,n);
        for(int i=1;i<=n;i++)
            d2[i]=d1[i];
        init();
        for(int i=0;i<m;i++)
            add(v[i],u[i],w[i]);
        spfa(x,n);
//        for(int i=1;i<=n;i++)
 //           cout<<d1[i]<<" "<<d2[i]<<endl;
        int minn=-INF;
        for(int i=1;i<=n;i++)
        {
            if(i!=x)
                minn=max(minn,d1[i]+d2[i]);
        }
        printf("%d\n",minn);
    }
    return 0;
}

POJ 3268 Silver Cow Party(SPFA),布布扣,bubuko.com

时间: 2024-10-03 11:06:29

POJ 3268 Silver Cow Party(SPFA)的相关文章

poj 3268 Silver Cow Party , spfa , dijkstra

点击打开链接 两次求最短路(第二次把边反向求) 1.spfa //poj 3268 Silver Cow Party //SPFA #include <cstdio> #include <cstring> #include <queue> using namespace std; const int M = 100000 + 100; const int N = 1000 + 100; const int inf = 1<<25; struct Graph

图论 ---- spfa + 链式向前星 ---- poj 3268 : Silver Cow Party

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12674   Accepted: 5651 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

poj 3268 Silver Cow Party(最短路)

poj 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

POJ 3268 Silver Cow Party 最短路—dijkstra算法的优化。

POJ 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

POJ 3268 Silver Cow Party dijkstra单源最短路

裸dijkstra 思路:以x为源点,求到其他点的最短路,之后把邻接矩阵转置,再求一次x源 点的最短路,这样就一次是来的,一次是走的,相加迭代最大值即可 代码: /* poj 3268 8108K 47MS */ #include<cstdio> #include<iostream> #define MAXN 1005 #define MAX_INT 2147483647 using namespace std; int gra_in[MAXN][MAXN],gra_out[MAX

POJ 3268 Silver Cow Party (来回最短路 SPFA)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14384   Accepted: 6490 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤X ≤

poj 3268 Silver Cow Party(dijkstra||SPFA)(中等)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14900   Accepted: 6746 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

POJ 3268 Silver Cow Party (Dijkstra)

题目链接:POJ 3268 Description One cow from each of \(N\) farms \((1 ≤ N ≤ 1000)\) conveniently numbered \(1..N\) is going to attend the big cow party to be held at farm #\(X (1 ≤ X ≤ N)\). A total of \(M (1 ≤ M ≤ 100,000)\) unidirectional (one-way roads

POJ 3268 Silver Cow Party

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 20274   Accepted: 9278 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X