Uva 10815-Andy's First Dictionary(串)


Problem B: Andy‘s First Dictionary


Time limit: 3 seconds

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself,
he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this
is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter
are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words
in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
给一篇文章。。然后生成一个字典。按字典序输出。。

set乱搞
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 360
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
char t[210],tem[210];
int main()
{
	set <string> s;
	while (gets(t))
	{
		int len=strlen(t),p;
		for(int i=0;i<=len;)
		{
			if(isalpha(t[i]))
			{
				p=0;
				tem[p++]=tolower(t[i]);
				i++;
				while(isalpha(t[i]))
				tem[p++]=tolower(t[i++]);
				tem[p++]=‘\0‘;string x(tem);s.insert(x);
			}
			else
			i++;
		}
	}
	set <string>::iterator it=s.begin();
	while(it!=s.end())
	{
		cout<<*it<<endl;
		it++;
	}
	return 0;
}

Uva 10815-Andy's First Dictionary(串)

时间: 2024-08-06 11:58:29

Uva 10815-Andy&#39;s First Dictionary(串)的相关文章

UVA - 10815 Andy&#39;s First Dictionary

1 #include <iostream> 2 #include <cstring> 3 #include <algorithm> 4 #include <set> 5 using namespace std; 6 7 set<string> out; 8 9 int main() 10 { 11 string s,temp; 12 while(cin>>s) 13 { 14 int len(s.size()); 15 for(int

UVa - 10815 Andy&#39;s First Dictionary(STL)

题目链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=18649 #include <iostream> #include <string> #include <set> #include <sstream> using namespace std; /******************************************************************

UVA 10815 Andy&#39;s First Dictionary(字符处理)

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his book

UVA 10815 Andy‘s First Dictionary(STL: set)

代码如下: #include <iostream> #include <sstream> #include <stdio.h> #include <set> #include <algorithm> #include <string.h> using namespace std; set<string> dict; int main(){ string s,b; while(cin>>s){ for(int i

Andy&amp;#39;s First Dictionary

Description Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. F

安迪的第一个字典 Andy&#39;s First Dictionary, UVa 10815

(Time limit: 3 seconds) Andy, 8, has a dream - he wants to produce hisvery own dictionary. This is not an easy task forhim, as the number of words that he knows is,well, not quite enough. Instead of thinking up allthe words himself, he has a briliant

【UVa 10815】Andy&#39;s First Dictionary

真的只用set和string就行了. 如果使用PASCAL的同学可能就要写个treap什么的了,还要用ansistring. #include<cstdio> #include<cstring> #include<iostream> #include<string> #include<set> using namespace std; string s; string now; set<string> dict; bool is_al

Andy&#39;s First Dictionary UVA 10815

#include <stdio.h> #include <ctype.h> #include <string.h> #define MAXN 5000+5 #define MAXM 200+5 typedef struct Dic{ char str[MAXN]; struct Dic* next; }Dic; Dic *head; char word[MAXM]; int cnt=0; int get_word(); void convert_word(); void

F - Andy&#39;s First Dictionary (UVA - 10815)

- 题目大意 给出一段文章,然后将其中不重复的单词拿出来(全为小写并且由a-z的顺序). - 解题思路 我在网上看到的一个stringstream函数,它除了进行字符串和数字转换之外的另一个用途:分割单词.将字符串中所有非单词字符全部转换为空格,然后再用代码中的方法分割出单词.有这种方法就好做多了.结合set容器即可. - 代码 #include<iostream> #include<set> #include<string> #include<sstream&g

【UVA - 10815】Andy&#39;s First Dictionary (set)

Andy's First Dictionary Description 不提英文了 直接上中文大意吧 XY学长刚刚立下了再不过CET就直播xx的flag,为了不真的开启直播模式,XY学长决定好好学习英语.于是他每天都读一篇只包含生词的英语文章,并以自己高达450的智商在一秒钟之内记忆下来. 现在给你一篇XY学长今天要读的文章,请你写一个程序,输出他都学习到了哪些单词.要求:如果文章中有相同的单词,那么仅仅输出一次:而且如果两个单词只有大小写不同,将他们视为相同的单词. Input 测试数据将输入