(KMP 1.4)hdu 3746 Cyclic Nacklace(使用next数组来求循环节的长度——求一个字符串需要添加多少个字符才能使该字符串的循环节的个数>=2)

题目:

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3387    Accepted Submission(s): 1549

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

Author

possessor WC

Source

HDU 3rd “Vegetable-Birds Cup” Programming Open Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  3336 1358 2222 3068 2896

题目大意:

对于一个给定的字符串,需要添加多少个字符才能使该字符串的循环节的个数>=2。

题目分析:

KMP。简单题。

这道题需要记住以下几点:

1、len-next[len]   :  该字符串的最小循环节的长度

2、如果len%(len-next[len]) == 0 ,表明该字符串由循环节组成,那么循环节的个数是len/(len-next[len])。

代码如下:

/*
 * hdu3746.cpp
 *
 *  Created on: 2015年4月18日
 *      Author: Administrator
 */

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn = 100001;

int m;//目标串的长度

char pattern[maxn];//模式串
int nnext[maxn];//next数组.直接起next可能会跟系统中预定的重名.

/*O(m)的时间求next数组*/
void get_next() {
	m = strlen(pattern);

	nnext[0] = nnext[1] = 0;
	for (int i = 1; i < m; i++) {
		int j = nnext[i];
		while (j && pattern[i] != pattern[j])
			j = nnext[j];
		nnext[i + 1] = pattern[i] == pattern[j] ? j + 1 : 0;
	}
}

int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%s",pattern);

		get_next();

		int len = strlen(pattern);//计算模式串的长度

		/**
		 * 如果该字符串已经是由多个循环节组成.
		 * len%(len-nnext[len]) == 0 : 该字符串由循环节组成
		 * (len != len-nnext[len]) :字符串的长度不等于循环节的长度
		 *
		 * ----->该字符串本身已经由多个循环节组成
		 */
		if(len%(len-nnext[len]) == 0 && (len != len-nnext[len]) ){
			printf("0\n");//那这时候需要添加的字符的数量是0
		}else{
			/**
			 * len-nnext[len] : 循环节的长度
			 * len%(len-nnext[len] : 字符串中不是循环节的部分的长度
			 */
			int ans = (len-nnext[len]) - (len%(len-nnext[len]));//计算还需要添加的字符的数量
			printf("%d\n",ans);
		}
	}

	return 0;
}
时间: 2024-10-13 23:30:29

(KMP 1.4)hdu 3746 Cyclic Nacklace(使用next数组来求循环节的长度——求一个字符串需要添加多少个字符才能使该字符串的循环节的个数>=2)的相关文章

hdu 3746 Cyclic Nacklace (KMP求最小循环节)

//len-next[len]为最小循环节的长度 # include <stdio.h> # include <algorithm> # include <string.h> using namespace std; int len; char a[100010]; int next[100010]; void Getnext() { int i=0,j=-1; next[0]=-1; while(i<=len) { if(j==-1||a[i]==a[j]) i

HDU 3746 Cyclic Nacklace (KMP最小循环节)

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11264    Accepted Submission(s): 4821 Problem Description CC always becomes very depressed at the end of this month, he has check

模板题 + KMP + 求最小循环节 --- HDU 3746 Cyclic Nacklace

Cyclic Nacklace Problem's Link: http://acm.hdu.edu.cn/showproblem.php?pid=3746 Mean: 给你一个字符串,让你在后面加尽量少的字符,使得这个字符串成为一个重复串. 例: abca---添加bc,成为abcabc abcd---添加abcd,成为abcdabcd aa---无需添加 analyse: 经典的求最小循环节. 首先给出结论:一个字符串的最小循环节为:len-next[len]. 证明: 举个例子:abcab

HDU 3746 Cyclic Nacklace (KMP 循环节)

分析:对next数组的深入理解,最重要的还是对最小循环节的处理. #include <stdio.h> #include <string.h> int next[100005]; char str2[100005]; void build_next(int len2) { int i=0,j=-1; next[0] = -1; while (i < len2) { if (j==-1 || str2[i] == str2[j]) { i++; j++; // if (str2

hdu 3746 Cyclic Nacklace KMP循环节问题

Cyclic Nacklace Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4124    Accepted Submission(s): 1866 Problem Description CC always becomes very depressed at the end of this month, he has checke

HDU 3746 Cyclic Nacklace (KMP找循环节)

题目链接:HDU 3746 Sample Input 3 aaa abca abcde Sample Output 0 2 5 Author possessor WC Source HDU 3rd "Vegetable-Birds Cup" Programming Open Contest Solution 题意 给定一个字符串,问至少需要在末尾添加多少个字符使得字符串循环. 思路 KMP 设前缀函数为 \(\pi()\),字符串长度为 \(n\),下标从 \(1\) 开始. 最小循环

HDU 3746 Cyclic Nacklace 环形项链(KMP,循环节)

题意:给一个字符串,问:要补多少个字符才能让其出现循环?比如abc要补3个变成abcabc.若已经循环,输出0. 思路:KMP的next数组解决.如果已经出现循环,那么答案为0.但是不循环呢?要根据next[len]来断定.我们要用最少字符来补上使其循环,而我们所知的就是要令循环节为k=len-next[len]这么长,即串开头的这么长.补到串长为k的倍数为止,此时,k就是循环节了. 其实答案可以直接算的,我用个循环来找而已.直接算应该是len%k后剩下末尾那小串的长度,补k-len%k这么多个

[2016-02-04][HDU][3746][Cyclic Nacklace]

时间:2016-02-04 00:14:53 星期四 题目编号:HDU 3746 题目大意:给出一个字符串,把字符串补成循环的字符串,至少需要多少补充多少字符, 方法:kmp 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57

hdu 3746 Cyclic Nacklace KMP

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=3746 题目: Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed