2016年省赛G题, Parenthesis

Problem G: Parenthesis

Time Limit: 5 Sec  Memory Limit: 128 MB
Submit: 398  Solved: 75
[Submit][Status][Web Board]

Description

Bobo has a balanced parenthesis sequence P=p1 p2…pn of length n and q questions.

The i-th question is whether P remains balanced after pai and pbi  swapped. Note that questions are individual so that they have no affect on others.

Parenthesis sequence S is balanced if and only if:

1. S is empty;

2. or there exists balanced parenthesis sequence A,B such that S=AB;

3. or there exists balanced parenthesis sequence S‘ such that S=(S‘).

Input

The input contains at most 30 sets. For each set:

The first line contains two integers n,q (2≤n≤105,1≤q≤105).

The second line contains n characters p1 p2…pn.

The i-th of the last q lines contains 2 integers ai,bi (1≤ai,bi≤n,ai≠bi).

Output

For each question, output "Yes" if P remains balanced, or "No" otherwise.

Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2

Sample Output

No
Yes
No

比赛的时候,老O查个单词,我后来又查了一下,单词没看完意思,说是"不规则的",发现里面还有一个括号的意思,也就是说只有括号,当时还以为有其他字符,想了好久,好像其他字符在这里没有起到作用然后是第二个条件,可不可以反推,纠结了好久,最后还是直接模拟了一遍,虽然已经知道会tle,还是写了一下,当时只有这个题目A得人比较多一点。
解题报告:1、只有括号2、3个条件就是括号匹配的实质。

思路:  直接栈模拟是肯定不行的,就算要用栈模拟也不是普通的栈模拟,直接记录左括号的个数,这样模拟。然后这里询问次数10^5,n = 10^5,就是10^10了,这里用线段树优化,每次)(区间都是+2,  直接yes,要是(),就看-2是否是小于0.
#include <stdio.h>
#include <algorithm>

using namespace std;
int temp[100005];
char str[100005];

#define INF 0x3f3f3f3f

struct node
{
    int left,right,val;
} c[100005*4];

void build_tree(int l,int r,int root)
{
    c[root].left=l;
    c[root].right=r;
    if(l==r)
    {
        c[root].val=temp[l];
        return ;
    }
    int mid=(l+r)/2;
    build_tree(l,mid,root*2);
    build_tree(mid+1,r,root*2+1);
    c[root].val=min(c[root*2].val,c[root*2+1].val);
}

void query(int l,int r,int &min1,int root)
{
    if(c[root].left==l&&c[root].right==r)
    {
        min1=c[root].val;
        return ;
    }
    int mid=(c[root].left+c[root].right)/2;
    if(mid<l)
        query(l,r,min1,root*2+1);
    else if(mid>=r)
        query(l,r,min1,root*2);
    else
    {
        int min2;
        query(l,mid,min1,root*2);
        query(mid+1,r,min2,root*2+1);
        min1=min(min1,min2);
    }
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        scanf("%s",str+1);
        int counts = 0;
        for(int i=1; i<=n; i++)
        {
            if(str[i]==‘(‘)
                temp[i] = ++counts;
            else temp[i] = --counts;
        }

        build_tree(1,n,1);
        int ls,rs;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&ls,&rs);
            if(ls > rs)
                swap(ls,rs);

            if(str[ls]==‘)‘&&str[rs]==‘(‘)
            {
                puts("Yes");
                continue;
            }
            if(str[ls]==str[rs])
            {
                puts("Yes");
                continue;
            }
            if(str[ls]==‘(‘&&str[rs]==‘)‘)
            {
                int mins = INF;
                query(ls,rs-1,mins,1);
                if(mins<2)
                    puts("No");
                else puts("Yes");
                continue;
            }
        }
    }
    return 0;
}

				
时间: 2024-10-05 05:47:52

2016年省赛G题, Parenthesis的相关文章

HDU 5880 Family View (2016 青岛网络赛 C题,AC自动机)

题目链接  2016 青岛网络赛  Problem C 题意  给出一些敏感词,和一篇文章.现在要屏蔽这篇文章中所有出现过的敏感词,屏蔽掉的用$'*'$表示. 建立$AC$自动机,查询的时候沿着$fail$指针往下走,当匹配成功的时候更新$f[i]$ $f[i]$表示要屏蔽以第$i$个字母结尾的长度为$f[i]$的字符串. 原文地址:https://www.cnblogs.com/cxhscst2/p/8452147.html

哈尔滨理工大学2016新生赛G题

FBI Tree的描述如下: 我们可以把由0和1组成的字符串分为3类,全0的串成为B串,全1的串成为I串,既含0又含1的串则称为F串.FBI树是一种二叉树,它的节点类型也包括F串节点.B串节点和I串节点三种.由一个 长度为2^N的01串S可以构造出一颗FBI树T,递归的构造方法如下: (1)   T的根节点为R,其类型与串S的类型相同. (2)   若串S的长度大于1,将串S从中间分开,分为等长的左右子串S1和S2:由左子串S1构造R的左子树T1,由右子串S2构造R的右子树T2. 现在给出一个长

HDU 5003 Osu!(鞍山网络赛G题)

HDU 5003 Osu! 题目链接 就一签到题,排序之后for一遍计算出答案即可 代码: #include <cstdio> #include <cstring> #include <iostream> #include <string> #include <vector> #include <set> #include <map> #include <algorithm> #include <cmat

HDU5003 Osu! (2014年鞍山赛区网络赛G题)

1.题目描述:点击打开链接 2.解题思路:本题是一道简单的排序题,按照题意排序计算即可. 3.代码: #define _CRT_SECURE_NO_WARNINGS #include<iostream> #include<algorithm> #include<string> #include<sstream> #include<set> #include<vector> #include<stack> #include&

HDU 5886 Tower Defence(2016青岛网络赛 I题,树的直径 + DP)

题目链接  2016 Qingdao Online Problem I 题意  在一棵给定的树上删掉一条边,求剩下两棵树的树的直径中较长那的那个长度的期望,答案乘上$n-1$后输出. 先把原来那棵树的直径求出来.显然删掉的边不是这条直径上的边,那么这时答案就是这条直径的长度. 否则就是直径的某个端点到某一个点(要求连通)的距离的最大值. 在整条链上做两次$DP$之后枚举取较大值即可. #include <bits/stdc++.h> using namespace std; #define r

2019年FJNU低编赛 G题(dfs博弈)

###题目链接### 题目大意: 有一个 0 ~ n+1 的数轴,Alice 站在 0 点处,Bob 站在 n+1 点处.在 1 ~ n 上各有着权值. Alice 每次向右移动 1 格或两格 ,Bob 每次向左移动 1 格或 2 格(他们一定要移动),Alice 移动到 n+1 处停止,Bob 移动到 0 处停止,直到他们都停止的时候,此时若 Alice 所经过的数值总和大于 Bob 的数值总和,则 Alice 胜出,反则 Bob 胜出.Alice 先出手,两人足够聪明,走到的数值必须拿走,而

hdu 5443 (2015长春网赛G题 求区间最值)

求区间最值,数据范围也很小,因为只会线段树,所以套了线段树模板=.= Sample Input3110011 151 2 3 4 551 21 32 43 43 531 999999 141 11 22 33 3 Sample Output1002344519999999999991 1 # include <iostream> 2 # include <cstdio> 3 # include <cstring> 4 # include <algorithm>

2016湖大校赛 L题 The Sequence likes Ladder

题意:S1=a,Sn=a*(Sn-1)^k%m,且有(a,m)=1,给出i,求Si. 思路:首先我们可以写出Sn的通项a^(1+k+k^2+...k^n-1);其次注意到m的范围是10000以内,所以我们可以利用欧拉公式降幂. 注意到(a,m)=1;又欧拉定理可知a^x%m=a^(x%phi(m))*a^phi(m)%m,而a^phi(m)=1;所以 a^x%m=a^(x%phi(m))%m; 而幂是一个等比数列,可以利用快速矩阵幂计算,算出幂之后,再利用快速幂求出答案. #include<cs

2016广东工业大学校赛 E题 GDUT-oj1173

Problem E: 积木积水 Description 现有一堆边长为1的已经放置好的积木,小明(对的,你没看错,的确是陪伴我们成长的那个小明)想知道当下雨天来时会有多少积水.小明又是如此地喜欢二次元,于是他把这个三维的现实问题简化成二维的问题.设雨量无穷.积木不透水.积木间无缝连接,问在这个二次元的世界里,已放置好的积木会有多少单位的积水量? Input 第一行包含一个整数T(T≤100),表示接下来的测试样例个数. 每个测试样例有两行组成: 第一行包含一个整数N(N≤1e6),表示积木的列数