PAT 1109 Group Photo

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

All the people in the rear row must be no shorter than anyone standing in the front rows;

In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10^?4), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:
For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct student{
  string name;
  int height;
};
bool cmp(const student& stud1, const student& stud2){
  return stud1.height==stud2.height?stud1.name<stud2.name:stud1.height>stud2.height;
}
int main(){
  int n, k, cnt=0;
  cin>>n>>k;
  vector<student> vec(n);
  for(int i=0; i<n; i++)
    cin>>vec[i].name>>vec[i].height;
  sort(vec.begin(), vec.end(), cmp);
  for(int i=0; i<k; i++){
    int t;
    i==0?t=n%k+n/k:t=n/k;
    vector<string> q(t);
    int mid=t/2;
    q[mid]=vec[cnt++].name;
    for(int j=1; j<=t/2; j++){
      if(mid-j<0)
        break;
      q[mid-j]=vec[cnt++].name;
       if(mid+j>t-1)
        break;
      q[mid+j]=vec[cnt++].name;
    }
    for(int j=0; j<t; j++)
      j==0?cout<<q[j]:cout<<" "<<q[j];
    cout<<endl;
  }
  return 0;
}

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9501910.html

时间: 2024-08-30 13:37:28

PAT 1109 Group Photo的相关文章

PAT 1109 Group Photo[仿真][难]

1109 Group Photo(25 分) Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following: The number of people in each row must be N/K (round down to the nearest integer), with all the extra peopl

1109 Group Photo (25 分)

1109 Group Photo (25 分) Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following: The number of people in each row must be N/K (round down to the nearest integer), with all the extra peop

PAT (Advanced Level) 1109. Group Photo (25)

简单模拟. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<string> #include<algorithm> #include<iostream> using namespace std

PAT甲题题解-1109. Group Photo (25)-(模拟拍照排队)

题意:n个人,要拍成k行排队,每行 n/k人,多余的都在最后一排. 从第一排到最后一排个子是逐渐增高的,即后一排最低的个子要>=前一排的所有人 每排排列规则如下: 1.中间m/2+1为该排最高: 2.其他人按各自降序顺序,轮流排到中间最高的左边和右边: 举个例子 190 188 186 175 170 - - 190 - - - 188 190 - - - 188 190 186 - 175 188 190 186 - 175 188 190 186 170 3.当个子一样高时,名字按字典序顺序

【PAT甲级】1109 Group Photo (25分)(模拟)

题意: 输入两个整数N和K(N<=1e4,K<=10),分别表示人数和行数,接着输入N行每行包括学生的姓名(八位无空格字母且唯一)和身高([30,300]的整数).按照身高逆序,姓名字典序升序将学生从高到矮排列,将学生均分为N行输出,最先输出的一行人数包括除不尽的余数学生,每行中间(如果这一行学生人数为偶数则靠右的为中间)的学生最高,然后依次左边一位学生最高,右边一位学生最高,例如190, 188, 186, 175, 170->175, 188, 190, 186, 170. tric

1109 Group Photo

英文题目:https://pintia.cn/problem-sets/994805342720868352/problems/994805360043343872 中文题目:https://pintia.cn/problem-sets/994805260223102976/problems/994805272021680128 1 #include<iostream> 2 #include<vector> 3 #include<algorithm> 4 using n

A题目

1 1001 A+B Format(20) 2 1002 A+B for Polynomials(25) 3 1003 Emergency(25) 4 1004 Counting Leaves(30) 5 1005 Spell It Right(20) 6 1006 Sign In and Sign Out(25) 7 1007 Maximum Subsequence Sum(25) 8 1008 Elevator(20) 9 1009 Product of Polynomials(25) 10

HTML5之 Microdata微数据

- 为何需要微数据 长篇加累版牍,不好理解 微标记来标注其中内容,让其容易识辨 - RDFa Resource Description Framework http://www.w3.org/TR/microdata http://www.whatwg.org/specs/web-apps/current-work/multipage/links.html#microdata http://www.w3.org/TR/rdfa-in-html --- itemscope 标记 <articlei

python3.4爬虫批量下载音乐

最近在学习python,使用的版本为python3.4,开发环境为使用Pydev插件的eclipse.正好觉得http://www.dexiazai.com/?page_id=23上的音乐不错,决定使用python批量下载下来. 1.音乐地址 经过分析,页面嵌入的虾米播放器中的地址如下,后面以逗号分隔的字符为音乐的id,如音乐的地址为http://www.xiami.com/song/2088578 <span style="font-size:14px;"><spa