杭电1316


How
Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3804    Accepted Submission(s): 1498 

Problem Description

Recall the definition of the Fibonacci numbers:  f1 := 1 
f2 := 2  fn := fn-1 + fn-2 (n
>= 3) 
Given two numbers a
and b, calculate how many Fibonacci numbers are in the range [a, b].

Input

The input contains several test cases. Each test case
consists of two non-negative integer numbers a and b. Input is terminated by a =
b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no
superfluous leading zeros.

Output

For each test case output on a single line the number of
Fibonacci numbers fi with a <= fi <= b.

Sample Input

10 100 1234567890
9876543210 0 0

Sample Output

5 4

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <map>
using namespace std;
const int maxn=500;
const int base=1000000;
const int INF=99999999;
const int MIN=-INF;
char a[maxn][500];
char* add(char*a,char*b)//大数加法
{
int lena=strlen(a);
int lenb=strlen(b);
int i,j,k;
char c[500];
if(lena<lenb)
{
strcpy(c,a);
strcpy(a,b);
strcpy(b,c);
}
int A[500]= {0},B[500]= {0};
for(j=0,i=lena-1; i>=0; i--,j++)
A[j]=a[i]-‘0‘;
int lenA=j;
for(i=lenb-1,j=0; i>=0; i--,j++)
B[j]=b[i]-‘0‘;
int lenB=j;
for(i=0; i<lenB; i++)
A[i]+=B[i];
for(i=0; i<500; i++)
{
if(A[i]>9)
{
A[i+1]+=A[i]/10;
A[i]%=10;
}
}
for(i=500-1; i>=0; i--)if(A[i]!=0)break;
for(j=0; i>=0; i--)
c[j++]=A[i]+‘0‘;
c[j]=‘\0‘;
return c;
}
int comper(char*a,char*b)//自定义比较函数 相同是0 大于是1 小于是-1
{
int lena=strlen(a);
int lenb=strlen(b);
if(lena>lenb)
return 1;
else if(lena<lenb)
return -1;
else if(lena==lenb)
{
for(int i=0; i<lena; i++)
if(a[i]<b[i])
return -1;
else if(a[i]>b[i])
return 1;
}
return 0;

}
int main()
{
int n,m,i,j,k,t;
a[1][0]=‘1‘;
a[2][0]=‘2‘;
for(i=3; i<=maxn; i++)
{
strcpy(a[i],add(a[i-1],a[i-2]));
}
//for(i=1;i<50;i++)
// cout<<a[i]<<endl;

char a1[maxn],b1[maxn];
while(cin>>a1>>b1)
{
int lena1=strlen(a1);
int lenb1=strlen(b1);
if(lena1==1&&lenb1==1&&a1[0]==‘0‘&&b1[0]==‘0‘)return 0;
int cnt=0;
for(i=1; i<maxn; i++)
{
if(comper(a[i],a1)>=0&&comper(a[i],b1)<=0)
cnt++;
}
cout<<cnt<<endl;
}

return 0;
}

杭电1316

时间: 2024-10-28 20:08:55

杭电1316的相关文章

杭电ACM分类

杭电ACM分类: 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDIATE DECODABILITY

【转】对于杭电OJ题目的分类

[好像博客园不能直接转载,所以我复制过来了..] 1001 整数求和 水题1002 C语言实验题——两个数比较 水题1003 1.2.3.4.5... 简单题1004 渊子赛马 排序+贪心的方法归并1005 Hero In Maze 广度搜索1006 Redraiment猜想 数论:容斥定理1007 童年生活二三事 递推题1008 University 简单hash1009 目标柏林 简单模拟题1010 Rails 模拟题(堆栈)1011 Box of Bricks 简单题1012 IMMEDI

杭电 HDU 1164 Eddy&#39;s research I

Eddy's research I Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7117    Accepted Submission(s): 4268 Problem Description Eddy's interest is very extensive, recently  he is interested in prime

hdu 1016 Prime Ring Problem DFS解法 纪念我在杭电的第一百题

Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29577    Accepted Submission(s): 13188 Problem Description A ring is compose of n circles as shown in diagram. Put natural num

一个人的旅行 HDU杭电2066【dijkstra算法】

http://acm.hdu.edu.cn/showproblem.php?pid=2066 Problem Description 虽然草儿是个路痴(就是在杭电待了一年多,居然还会在校园里迷路的人,汗~),但是草儿仍然很喜欢旅行,因为在旅途中 会遇见很多人(白马王子,^0^),很多事,还能丰富自己的阅历,还可以看美丽的风景--草儿想去很多地方,她想要去东京铁塔看夜景,去威尼斯看电影,去阳明山上看海芋,去纽约纯粹看雪景,去巴黎喝咖啡写信,去北京探望孟姜女--眼看寒假就快到了,这么一大段时间,可不

杭电1162--Eddy&#39;s picture(Prim()算法)

Eddy's picture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8070    Accepted Submission(s): 4084 Problem Description Eddy begins to like painting pictures recently ,he is sure of himself to b

杭电1276--士兵队列训练问题

士兵队列训练问题 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4605    Accepted Submission(s): 2148 Problem Description 某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行

杭电1272 并查集找环+判断连通

杭电1272 并查集找环+判断连通 E - E Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Practice HDU 1272 Description 上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走.但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B

杭电ACM Java实现样例

若使用Java求解杭电ACM,答案提交必须注意两点: 1.类名一定得是Main,否则服务器无法编译: 2.必须用while进行输入判断. 以1000题测试题为例,代码如下: import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner scan=new Scanner(System.in); while(scan.hasNextInt()) { int a=scan.n