HDU_1027_Ignatius and the Princess II_全排列

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6701    Accepted Submission(s):
3964

Problem Description

Now our hero finds the door to the BEelzebub feng5166.
He opens the door and finds feng5166 is about to kill our pretty Princess. But
now the BEelzebub has to beat our hero first. feng5166 says, "I have three
question for you, if you can work them out, I will release the Princess, or you
will be my dinner, too." Ignatius says confidently, "OK, at last, I will save
the Princess."

"Now I will show you the first problem." feng5166 says,
"Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest
sequence among all the sequence which can be composed with number 1 to N(each
number can be and should be use only once in this problem). So it‘s easy to see
the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers,
N and M. You should tell me the Mth smallest sequence which is composed with
number 1 to N. It‘s easy, isn‘t is? Hahahahaha......"
Can you help Ignatius
to solve this problem?

Input

The input contains several test cases. Each test case
consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may
assume that there is always a sequence satisfied the BEelzebub‘s demand. The
input is terminated by the end of file.

Output

For each test case, you only have to output the
sequence satisfied the BEelzebub‘s demand. When output a sequence, you should
print a space between two numbers, but do not output any spaces after the last
number.

Sample Input

6 4
11 8

Sample Output

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

求第m个全排列。

用了个next_permutation(a,a+n)库函数。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

int a[1005];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<n;i++)
            a[i]=i+1;
        m--;
        while(m--)
        {
            next_permutation(a,a+n);
        }
        for(int i=0;i<n;i++)
        {
            if(i!=n-1)
                printf("%d ",a[i]);
            else
                printf("%d\n",a[i]);
        }
    }
    return 0;
}

时间: 2024-10-07 22:57:34

HDU_1027_Ignatius and the Princess II_全排列的相关文章

hdu1027 Ignatius and the Princess II 全排列

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1027 Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now

ignitius and princess 2(全排列)

A - Ignatius and the Princess II STL中的algorithm 的全排列应用 #include<stdio.h> #include<string.h> #include<algorithm> #define INF 0x3f3f3f3f #define ll long long #define N 100010 using namespace std; int a[N]; int main() { int n,m; while(scanf

Ignatius and the Princess II(全排列)

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6359    Accepted Submission(s): 3760 Problem Description Now our hero finds the door to the BEelzebub feng5166. He o

【全排列】HDU1027Ignatius and the Princess II/HDU1716排列2

全排列函数,666,上次蓝桥杯就沾了全排列的光.... next_pernutation(); 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1716 Problem Description Ray又对数字的列产生了兴趣: 现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数. Input 每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束. Output 对每组卡片按从小到

HDU 1027 Ignatius and the Princess II[DFS/全排列函数next_permutation]

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9458    Accepted Submission(s): 5532 Problem Description Now our hero finds the door to the BEelzebub feng5166. He op

HDU 1027 Ignatius and the Princess II(求第m个全排列)

传送门: http://acm.hdu.edu.cn/showproblem.php?pid=1027 Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 10388    Accepted Submission(s): 5978 Problem Description Now our

HDU1027 Ignatius and the Princess II【全排列】

Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11536 Accepted Submission(s): 6640 Problem Description Now our hero finds the door to the BEelzebub feng5166. He opens

(全排列)Ignatius and the Princess II -- HDU -- 1027

链接: http://acm.hdu.edu.cn/showproblem.php?pid=1027 Ignatius and the Princess II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 5822    Accepted Submission(s): 3433 Problem Description Now our h

hdu 1027 Ignatius and the Princess II (STL 全排列)

题目链接今天学了 全排列函数 之后,再回过头来看这一题,发现这时对于这样的题 就是一个字 秒 .主要函数有两个 next_permutation 和 prev_permutation这两个一个是向后找 一个是向前找,next的是往后,prev的是向前找.有的人可能不太明白我这里只的向前和向后的意思. 向前 就是 往 字典序小 的 方向 找 ,反之 就是向前. 举个例子把 :假设数组a[n],i<=m,next_permutation(a+i,a+m)就表示对a[i]到a[m]进行操作,每操作一次