1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1
digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written
0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra
space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes

1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No

4 4 1

#include <iostream>
using namespace std;
int result[100000000];
long i, j;

bool isPalindromic(int *result) {
    long begin, end;
    for(begin=0, end=i-1; begin<=end; begin++, end--) {
        if(result[begin]!=result[end]) {
            return false;
        }
    }
    return true;
}

void change(long a, long b) {
    i = 0;
    while(a != 0) {
        result[i++] = a % b;
        a /= b;
    }
}
int main() {
    int a, b;
    while(cin>>a>>b) {
        change(a, b);
        if(isPalindromic(result)) {
            cout<<"Yes"<<endl;
        } else {
            cout<<"No"<<endl;
        }

        for(j = i-1; j>0 ; j--) {
            cout<<result[j]<<" ";
        }
        cout<<result[j]<<endl;
    }
    return 0;
}
时间: 2024-10-14 12:09:36

1019. General Palindromic Number (20)的相关文章

1019 General Palindromic Number (20)(20 point(s))

problem A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most of

PAT Advanced 1019 General Palindromic Number (20分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons

PAT (Advanced Level) 1019. General Palindromic Number (20)

简单题. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<queue> #include<vector> using namespace std; int s[10000],tot; int n,b; bool check() { for(int i=0; i<=tot

PAT:1019. General Palindromic Number (20) AC

#include<stdio.h> #include<stdlib.h> int main() { int n,jin; scanf("%d%d",&n,&jin); if(0==n) //特判0的时候,就是回文数 { printf("Yes\n0"); return 0; } int arr[50],i=0; while(n!=0) { arr[i++]=n%jin; n/=jin; } int tag=0; for(int

PAT甲题题解-1019. General Palindromic Number (20)-又是水题一枚

n转化为b进制的格式,问你该格式是否为回文数字(即正着写和倒着写一样)输出Yes或者No并且输出该格式又是水题... #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> using namespace std; const int maxn=30; int a[maxn]; int n,b; int main() { scanf("%d %d&q

pat1019. General Palindromic Number (20)

1019. General Palindromic Number (20) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic

PAT 1019 General Palindromic Number[简单]

1019 General Palindromic Number (20)(20 分) A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Altho

PAT 甲级 1019 General Palindromic Number (进制转换,vector运用,一开始2个测试点没过)

1019 General Palindromic Number (20 分)   A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Althoug

A1019. General Palindromic Number (20)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers. Although palindromic numbers are most often cons