EXPEDI - Expedition 优先队列

题目描述

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

输入输出格式

输入格式:

The first line of the input contains an integer t representing
the number of test cases. Then t test cases follow. Each test case has
the follwing form:

  • Line 1: A single integer, N
  • Lines 2..N+1: Each line contains two space-separated integers
    describing a fuel stop: The first integer is the distance from the town
    to the stop; the second is the amount of fuel available at that stop.
  • Line N+2: Two space-separated integers, L and P

输出格式:

For each test case, output a single integer giving the minimum
number of fuel stops necessary to reach the town. If it is not possible
to reach the town, output -1.

输入输出样例

输入样例#1: 复制

1
4
4 4
5 2
11 5
15 10
25 10

输出样例#1: 复制

2

Input details
The truck is 25 units away from the town; the truck has 10 units
of fuel.  Along the road, there are 4 fuel stops at distances 4,
5, 11, and 15 from the town (so these are initially at distances
21, 20, 14, and 10 from the truck).  These fuel stops can supply
up to 4, 2, 5, and 10 units of fuel, respectively.

Output details:
Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more
units, stop to acquire 5 more units of fuel, then drive to the town.

Priority_queue即可解决;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
//#pragma GCC optimize(2)
//#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 100005
#define inf 0x3f3f3f3f
#define INF 9999999999
#define rdint(x) scanf("%d",&x)
#define rdllt(x) scanf("%lld",&x)
#define rdult(x) scanf("%lu",&x)
#define rdlf(x) scanf("%lf",&x)
#define rdstr(x) scanf("%s",x)
typedef long long  ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 1000000000
#define sq(x) (x)*(x)
#define eps 1e-3
typedef pair<int, int> pii;
#define pi acos(-1.0)
//const int N = 1005;
#define REP(i,n) for(int i=0;i<(n);i++)

inline ll rd() {
    ll x = 0;
    char c = getchar();
    bool f = false;
    while (!isdigit(c)) {
        if (c == ‘-‘) f = true;
        c = getchar();
    }
    while (isdigit(c)) {
        x = (x << 1) + (x << 3) + (c ^ 48);
        c = getchar();
    }
    return f ? -x : x;
}

ll gcd(ll a, ll b) {
    return b == 0 ? a : gcd(b, a%b);
}
ll sqr(ll x) { return x * x; }

/*ll ans;
ll exgcd(ll a, ll b, ll &x, ll &y) {
    if (!b) {
        x = 1; y = 0; return a;
    }
    ans = exgcd(b, a%b, x, y);
    ll t = x; x = y; y = t - a / b * y;
    return ans;
}
*/

ll qpow(ll a, ll b, ll c) {
    ll ans = 1;
    a = a % c;
    while (b) {
        if (b % 2)ans = ans * a%c;
        b /= 2; a = a * a%c;
    }
    return ans;
}

struct node {
    int dis, sum;
}stp[maxn];

bool cmp(node a, node b) {
    return a.dis < b.dis;
}

int T;
int l, p;
int main()
{
    //ios::sync_with_stdio(0);
    rdint(T);
    while (T--) {
        ms(stp); int n; rdint(n);priority_queue<int>q;
        for (int i = 0; i < n; i++)rdint(stp[i].dis), rdint(stp[i].sum);
        rdint(l); rdint(p);
        for (int i = 0; i < n; i++)stp[i].dis = l - stp[i].dis;
        stp[n].dis = l; stp[n].sum = 0;
        n++;
        sort(stp, stp + n, cmp);
        int cnt = p, loct = 0;// 油量为cnt,距出发点距离为loct
        bool fg = 0;
        int ans = 0;
        for (int i = 0; i < n; i++) {
            int Dis = stp[i].dis - loct;
            while (Dis > cnt) {
                if (q.empty()) {
                    fg = 1; break;
                }
                else {
                    int tmp = q.top(); q.pop();
                    cnt += tmp; ans++;
                }
            }
            if (fg)break;
            cnt -= Dis;
            q.push(stp[i].sum);
            loct = stp[i].dis;
        }
        if (fg)cout << -1 << endl;
        else cout << ans << endl;
    }
    return 0;
}


原文地址:https://www.cnblogs.com/zxyqzy/p/10086093.html

时间: 2024-10-02 19:13:53

EXPEDI - Expedition 优先队列的相关文章

H - Expedition 优先队列 贪心

来源poj2431 A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every

poj2431 Expedition优先队列

Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel ever

POJ2431 Expedition (优先队列)

题目链接: http://poj.org/problem?id=2431 题意: 一条路上有n个加油站,终点离起点的距离为L,然n个加油站离终点的距离为a[i],每个加油站可以给汽车加b[i]的油, 问最少加多少次可以到达终点,不能到达终点输出-1. 分析: 要想最少我们肯定是在马上要没有的时候加油,然后每次加的应该是最多的油. 因此我们走过第i个加油站的时候,把b[i]放入优先队列里,然后不能到达的时候 每次取出一个直到可以到达当前的位置,如果队列为空而且还不能动到达当前 位置则永远不可达.

poj 2431 Expedition(优先队列)

题目链接 http://poj.org/problem?id=2431 Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9243   Accepted: 2700 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor driver

poj 2431 Expedition (贪心+优先队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 6890   Accepted: 2065 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to

poj2431 Expedition (优先队列) 挑战程序设计竞赛

题目链接:http://poj.org/problem?id=2431 Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9148   Accepted: 2673 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor driver

poj 2431 Expedition (贪心加优先队列)

Expedition Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11538   Accepted: 3336 Description A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed t

【POJ - 2431】Expedition(优先队列)

Expedition 直接中文 Descriptions 一群奶牛抓起一辆卡车,冒险进入丛林深处的探险队.作为相当差的司机,不幸的是,奶牛设法跑过一块岩石并刺破卡车的油箱.卡车现在每运行一个单位的距离泄漏一个燃料单位. 为了修理卡车,奶牛需要沿着一条蜿蜒的长路行驶到最近的城镇(距离不超过1,000,000个单位).在这条路上,在城镇和卡车的当前位置之间,有N(1 <= N <= 10,000)燃料站,奶牛可以停下来获得额外的燃料(每站1..100个单位). 丛林对人类来说是一个危险的地方,对奶

POJ2431 Expedition(排序+优先队列)

思路:先把加油站按升序排列. 在经过加油站时,往优先队列里加入B[i].(每经过一个加油站时,预存储一下油量) 当油箱空时:1.如果队列为空(可以理解成预存储的油量),则无法到达下一个加油站,更无法到达目的地. 2.否则就取出队列里的最大元素,来给汽车加油(贪心思想) #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> #include<queue>