HDU 2767 Proving Equivalences



Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3676    Accepted Submission(s): 1352

Problem Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.

2. Ax = b has exactly one solution for every n × 1 matrix b.

3. Ax = b is consistent for every n × 1 matrix b.

4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the
four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a
lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.

* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

Source

NWERC 2008

题意:给你n个关系,m条推导,问你最少需要添加几条推导才能使任意两个关系之间可以互推。

然后这个问题便转化成一幅图,需要添加几条边,使得这个图变成强连通图。

思路:首先用tarjan把图变成DAG图,然后统计没有被连上的点(入度出度为0)。找最大的入度和出度,即代表最少需要添加几条边。

#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <stack>
using namespace std;
#define MAXN 200010
#define clr(x,k) memset((x),(k),sizeof(x))
struct node
{
    int st,to,next;
}
edge[MAXN];
int n,m,ct,id;
int head[MAXN],low[MAXN],dfn[MAXN],belong[MAXN],in[MAXN],to[MAXN];
//DFN[i]表示 遍历到 i 点时是第几次dfs
//Low[u] 表示 以u点为父节点的 子树 能连接到 [栈中] 最上端的点 的DFN值
//belong存的是缩点后的点。
//ct 是指相互的点到达可以缩成一个点的个数。
bool instack[MAXN];
stack<int>q;
void add_e(int i,int u,int v)
{
    edge[i].st=u;
    edge[i].to=v;
    edge[i].next=head[u];
    head[u]=i;
}
void tarjan(int i)
{
    int j;
    dfn[i]=low[i]=++id;
    q.push(i);
    instack[i]=1;
    for(int u=head[i]; ~u; u=edge[u].next)  //求强连通分量
    {
        j=edge[u].to;
        if(dfn[j]==0)
        {
            tarjan(j);
            if(low[i]>low[j])
                low[i]=low[j];
        }
        else if(instack[j]&&low[i]>low[j])
            low[i]=dfn[j];
    }
    if(dfn[i]==low[i])  //缩点
    {
        ct++;
        do
        {
            j=q.top();
            q.pop();
            instack[j]=0;
            belong[j]=ct;
        }
        while(i!=j);
    }
}
int main()
{
    int t,i,u,v,sum1,sum2;
    cin>>t;
    while(t--)
    {
        clr(head,-1);
        clr(low,0);
        clr(dfn,0);
        clr(belong,0);
        clr(in,0);
        clr(to,0);
        while(!q.empty())
            q.pop();
        cin>>n>>m;
        for(i=0; i<m; i++)
        {
            cin>>u>>v;
            add_e(i,u,v);
        }
        id=ct=0;
        for(i=1; i<=n; i++)
        {
            if(!dfn[i])
                tarjan(i);
        }
        if(ct==1) //所有的点可以任意到达,原图即为强连通图。
        {
            cout<<0<<endl;
            continue;
        }
        for(i=1; i<=ct; i++)
        {
            in[i]=to[i]=0;
        }
        for(i=0; i<m; i++)
        {
            if(belong[edge[i].st]!=belong[edge[i].to])
            {
                in[belong[edge[i].st]]++;
                to[belong[edge[i].to]]++;
            }
        }
        sum1=sum2=0;
        for(i=1; i<=ct; i++)
        {
            if(in[i]==0)
                sum1++;
            if(to[i]==0)
                sum2++;
        }
        cout<<max(sum1,sum2)<<endl;
    }
    return 0;
}
时间: 2024-10-02 23:13:01

HDU 2767 Proving Equivalences的相关文章

HDU 2767 Proving Equivalences (强联通)

http://acm.hdu.edu.cn/showproblem.php?pid=2767 Proving Equivalences Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2926    Accepted Submission(s): 1100 Problem Description Consider the followi

hdu 2767 Proving Equivalences 强连通缩点

给出n个命题,m个推导,问最少增加多少条推导,可以使所有命题都能等价(两两都能互推) 既给出有向图,最少加多少边,使得原图变成强连通. 首先强连通缩点,对于新图,每个点都至少要有一条出去的边和一条进来的边(这样才能保证它能到任意点和任意点都能到它) 所以求出新图中入度为0的个数,和出度为0的个数,添加的边就是从出度为0的指向入度为0的.这样还会有一点剩余,剩余的就乱连就行了. 所以只要求出2者的最大值就OK. #include <iostream> #include<cstring>

HDU 2767 Proving Equivalences(强连通 Tarjan+缩点)

HDU 2767 Proving Equivalences(强连通 Tarjan+缩点) ACM 题目地址:HDU 2767 题意: 给定一张有向图,问最少添加几条边使得有向图成为一个强连通图. 分析: Tarjan入门经典题,用tarjan缩点,然后就变成一个有向无环图(DAG)了. 我们要考虑的问题是让它变成强连通,让DAG变成强连通就是把尾和头连起来,也就是入度和出度为0的点. 统计DAG入度和出度,然后计算头尾,最大的那个就是所求. 代码: /* * Author: illuz <iil

hdu 2767 Proving Equivalences(强连通入门题)

1 /************************************************* 2 Proving Equivalences(hdu 2767) 3 强连通入门题 4 给个有向图,求至少加多少条边使得图是所有点都是强连通的 5 由a->b->c->a易知n个点至少要n条边,每个出度和入度都要大 6 于1.先求所有所有强连通分量,把每个强连通分量看成一个点 7 在找每个点的出度和入度,最后还差的出度和入度的最大值就是 8 答案. 9 10 ************

HDU 2767 Proving Equivalences(强联通缩点)

Proving Equivalences Problem Description Consider the following exercise, found in a generic linear algebra textbook. Let A be an n × n matrix. Prove that the following statements are equivalent: 1. A is invertible.2. Ax = b has exactly one solution

HDU 2767 Proving Equivalences (Tarjan縮點)

Time limit :2000 ms Memory limit :32768 kB Consider the following exercise, found in a generic linear algebra textbook. Let A be an n × n matrix. Prove that the following statements are equivalent: 1. A is invertible. 2. Ax = b has exactly one soluti

HDU 2767 Proving Equivalences 图论scc缩点

问一个图,最少需要加多少条边,使得这个图强联通. Tarjan缩点,重建图,令a=入度为0的scc个数,b=出度为0的scc个数,ans=max(a,b): 若图scc=1,本身强联通,ans=0: 1 #include<bits/stdc++.h> 2 using namespace std; 3 const int MAXN = 20010;//点数 4 const int MAXM = 200100;//边数 5 struct Edge { 6 int to,next; 7 }edge[

hdoj 2767 Proving Equivalences【求scc&amp;&amp;缩点】【求最少添加多少条边使这个图成为一个scc】

Proving Equivalences Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4263    Accepted Submission(s): 1510 Problem Description Consider the following exercise, found in a generic linear algebra t

hdu - 2667 Proving Equivalences(强连通)

http://acm.hdu.edu.cn/showproblem.php?pid=2767 求至少添加多少条边才能变成强连通分量.统计入度为0的点和出度为0的点,取最大值即可. 1 #include <iostream> 2 #include <cstdio> 3 #include <cmath> 4 #include <vector> 5 #include <cstring> 6 #include <algorithm> 7 #i