hdoj 4324 Triangle LOVE

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3903    Accepted Submission(s): 1537

Problem Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.

Sample Input

2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110

Sample Output

Case #1: Yes
Case #2: No

注意。注意,注意,取边,用字符串,不然超时!!!
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#include<string.h>
#include<queue>
#define N  2010
struct line
{
    int u,v,next;
}edge[N*N];
int n,m,inde[N],head[N],top=0;
void add(int u,int v)
{
    edge[top].u =u;
    edge[top].v =v;
    edge[top].next =head[u];
    head[u]=top++;
    inde[v]++;
}
void topo()
{
    int i,j,t=0,k=0,s;
    queue<int>Q;
    for(i=0;i<n;i++)
     {
         if(inde[i]==0)//入度为零入队
         {
             Q.push(i);
        }
     }
     while(!Q.empty() )
     {
         t=Q.front() ;
         Q.pop() ;
         inde[t]=-1;
         k++;//记录入队人数
         for(i=head[t];i!=-1;i=edge[i].next )
         {
              s=edge[i].v ;
             inde[s]--;
             if(inde[s]==0)
             Q.push(s);
        }
     }
     if(k<n)//判断是否有环
     printf("Yes\n");
     else
     printf("No\n");
}
int main()

{
    int i,j,u,v=1;
    scanf("%d",&m);
    while(m--)
    {
        top=0;
        memset(inde,0,sizeof(inde));
        memset(head,-1,sizeof(head));
        scanf("%d",&n);
         getchar();
         char a[N];
         for(i=0;i<n;i++)//必须用字符串,直接取数字超时
          {
              scanf("%s",a);
              for(j=0;j<n;j++)
               {
                   if(a[j]=='1')
                   add(i,j);
               }
          }
          printf("Case #%d: ",v++);
            topo();

    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-08-10 17:18:43

hdoj 4324 Triangle LOVE的相关文章

hdoj 4324 Triangle LOVE【拓扑排序判断是否存在环】

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 3566    Accepted Submission(s): 1395 Problem Description Recently, scientists find that there is love between any of two people. For

hdoj 4324 Triangle LOVE 【拓扑】

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2586    Accepted Submission(s): 1051 Problem Description Recently, scientists find that there is love between any of two people. Fo

拓扑排序/DFS HDOJ 4324 Triangle LOVE

题目传送门 题意:判三角恋(三元环).如果A喜欢B,那么B一定不喜欢A,任意两人一定有关系连接 分析:正解应该是拓扑排序判环,如果有环,一定是三元环,证明. DFS:从任意一点开始搜索,搜索过的点标记,否则超时.看是否存在两点路程只差等于2,如果存在,则说明有上述的三角环.其他做法. 收获:DFS搜索一定要用vis数组啊,否则很容易超时的 代码(拓扑排序): /************************************************ * Author :Running_T

HDU 4324 Triangle LOVE (拓扑排序)

Triangle LOVE Problem Description Recently, scientists find that there is love between any of two people. For example, between A and B, if A don't love B, then B must love A, vice versa. And there is no possibility that two people love each other, wh

HDU 4324:Triangle LOVE( 拓扑排序 )

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2271    Accepted Submission(s): 946 Problem Description Recently, scientists find that there is love between any of two people. For

hdu 4324 Triangle LOVE(拓扑排序)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4324 Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 3858    Accepted Submission(s): 1516 Problem Description Recently, scientists f

HDU 4324 Triangle LOVE(拓扑排序判环)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4324 题目: Problem Description Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possi

hdu 4324 Triangle LOVE(拓扑判环)

Triangle LOVE Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 3603    Accepted Submission(s): 1416 Problem Description Recently, scientists find that there is love between any of two people. Fo

hdu 4324 Triangle LOVE

本题链接:点击打开链接 本题大意: 题意分析(转载):此题可以一遍拓扑排序判环求解 即只需要找到一个环,就必定存在三元环 证明如下: 假设存在一个n元环,因为a->b有边,b->a必定没边,反之也成立所以假设有环上三个相邻的点a-> b-> c,那么如果c->a间有边,就已经形成了一个三元环,如果c->a没边,那么a->c肯定有边,这样就形成了一个n-1元环....所以只需证明n大于3时一定有三元环即可,显然成立. 具体请参见代码: #include<std