Niven Numbers
Time Limit: 2 Seconds Memory Limit: 65536 KB
A Niven number is a number such that the sum of its digits divides itself. For example, 111 is a Niven number because the sum of its digits is 3, which divides 111. We can also specify a number in another base b, and a number in base b is a Niven number if the sum of its digits divides its value.
Given b (2 <= b <= 10) and a number in base b, determine whether it is a Niven number or not.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of test cases. Each line of input contains the base b, followed by a string of digits representing a positive integer in that base. There are no leading zeroes. The input is terminated by a line consisting of 0 alone.
Output
For each case, print "yes" on a line if the given number is a Niven number, and "no" otherwise.
Sample Input
1
10 111
2 110
10 123
6 1000
8 2314
0
Sample Output
yes
yes
no
yes
no
问题链接:ZOJ1154 Niven Numbers
问题简述:(略)
问题分析:
????Niven数指数的各位数字之和能够整除数的数。对于指定的b进制数,问是否为Niven数?
????需要注意,题面中没有指定字符串的长度。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C语言程序如下:
/* ZOJ1154 Niven Numbers */
#include <stdio.h>
char s[128];
int main(void)
{
int t, b;
scanf("%d", &t);
while(t--) {
while(~scanf("%d", &b) && b) {
int sum = 0, num = 0, i;
scanf("%s", s);
for(i = 0; s[i]; i++) {
sum += s[i] - '0';
num = num * b + s[i] - '0';
}
printf("%s\n", num % sum == 0 ? "yes" : "no");
}
if(t) printf("\n");
}
return 0;
}
原文地址:https://www.cnblogs.com/tigerisland45/p/10355869.html