PAT Advanced 1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

这道题考察排序,注意rank,是有并列第一的。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
struct stu {
    string id;
    int score[4],r[4];
};
int choice;
bool cmp(stu s1, stu s2) {
    return s1.score[choice] > s2.score[choice];
}
vector<stu> v;
int main() {
    int M, N;
    cin >> M >> N;
    stu tmp;
    for(int i = 0; i < M; i++) {
        cin >> tmp.id >> tmp.score[0] >> tmp.score[1] >> tmp.score[2];
        tmp.score[3] = tmp.score[0] + tmp.score[1] + tmp.score[2];
        v.push_back(tmp);
    }
    for(choice = 0; choice < 4; choice++) {
        sort(v.begin(), v.end(), cmp);
        v[0].r[choice] = 1;
        for(int i = 1; i < M; i++) {
            if(v[i].score[choice] == v[i-1].score[choice])
                v[i].r[choice] = v[i-1].r[choice];
            else v[i].r[choice] = i + 1;
        }
    }
    while(N--) {
        cin >> tmp.id;
        int i;
        for(i = 0; i < M; i++)
            if(tmp.id == v[i].id) break;
        if(i == M) {
            cout << "N/A" << endl;
            continue;
        }
        int a = v[i].r[3],c = v[i].r[0],m = v[i].r[1],e = v[i].r[2];
        if(a <= c && a <= m && a <= e)
            cout << a << " " << "A" << endl;
        else if(c <= a && c <= m && c <= e)
            cout << c << " " << "C" << endl;
        else if(m <= c && m <= a && m <= e)
            cout << m << " " << "M" << endl;
        else if(e <= c && e <= m && e <= a)
            cout << e << " " << "E" << endl;
    }
    system("pause");
    return 0;
}

原文地址:https://www.cnblogs.com/littlepage/p/12246966.html

时间: 2024-10-08 05:07:44

PAT Advanced 1012 The Best Rank (25分)的相关文章

[PTA] PAT(A) 1012 The Best Rank (25 分)

目录 Problem Solution Analysis Code Problem portal: 1012 The Best Rank (25 分) Solution Analysis ?一名学生有三门科目,以及计算出的一个平均成绩,每一个成绩都会有一个排名,现在想要让你输出某一个同学最高的排名(四种成绩排名的最高),以及对应的科目 ?如果给定的同学的四种课程排名的名次信息已经存在,那么就很简单,在里面找到最小的名次,以及对应的科目输出即可. ?可以创建四个数组,数组的每个元素存储某一门科目的

1012 The Best Rank (25分) vector与结构体排序

1012 The Best Rank (25分) To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, w

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by e

PAT:1012. The Best Rank (25) AC

#include<stdio.h> #include<algorithm> using namespace std; struct Student { int mID; int grade[4]; //0对应平均A,1对应C,2对应M,3对应E }STU[2010]; char course[4]={'A','C','M','E'}; //所有的存储都对应ACME int Rank[10000000][4]={0}; //每个学号四个成绩对应的排名 int now=0; //排序的

PAT(A) 1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by e

PAT Advanced 1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of

PAT Advanced 1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

PAT Advanced 1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop()

PAT Advanced 1060 Are They Equal (25分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supp