ACdream1020:The Game about KILL

Problem Description

Teacher HU and his 40 students were trapped by the brigands. To show their power, the head of the brigands want to select one people to kill.

Teacher HU and his 40 students will stand in a circle, and every second person would leave, and the last people in the circle would be killed. For example, if there are 5 persons in the circle, counting proceeds as 2, 4, 1, 5 and person 3 will be killed. To
make his students alive, teacher HU calculated the position to be the last man standing, and sacrifice himself.

Now we consider a more common condition, if teacher HU has N - 1 students, which place should he stand to be the last person.

Input

There are multiple test cases.

Each test case only contains an integer N. (1 <= N <= 1,000,000,000)

Output

For each test case, output an integer indicating which place should teacher HU stand.

Sample Input

2
3

Sample Output

1
3

约瑟夫环,n太大,首先可以想到打表找看有没有规律
可以发现时有规律的
可以看到,只要是2的i次幂,那么存活的是1,后面的依次加2
例如4为1,5就是3,6->5,7->7,8->1

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define ll long long
ll f[50],n;

int main()
{
    int i;
    f[0] = 1;
    for(i = 1; i<31; i++)
        f[i] = f[i-1]*2;
    while(~scanf("%lld",&n))
    {
        for(i = 1; i<31; i++)
        {
            if(n<f[i])
                break;
        }
        printf("%lld\n",1+2*(n-f[i-1]));
    }

    return 0;
}

ACdream1020:The Game about KILL

时间: 2024-10-11 06:58:15

ACdream1020:The Game about KILL的相关文章

【转】linux下杀死进程(kill)的N种方法

转载一篇,最原始的出处已不可考,望见谅! 常规篇: 首先,用ps查看进程,方法如下: $ ps -ef --smx       1822     1  0 11:38 ?        00:00:49 gnome-terminalsmx       1823  1822  0 11:38 ?        00:00:00 gnome-pty-helpersmx       1824  1822  0 11:38 pts/0    00:00:02 bashsmx       1827    

11153 kill boss

11153 kill boss 时间限制:1000MS  内存限制:65535K提交次数:1090 通过次数:340 题型: 编程题   语言: G++;GCC Description Acmer最近喜欢上了玩某个游戏,这个游戏的格斗风格是以格挡,招架,攻击为主,acmer最近打一个boss打了几遍,还是没有打赢,但是经过几次失败后, acmer大概摸清了boss的出招规律,所以她做好了相应的出招式,acmer被boss砍掉n滴血后会挂掉,对应的只要acmer在挂掉前砍掉boss m滴血,acm

六、Linux/UNIX操作命令积累【kill、netstat、df、du】

在使用Linux/UNIX下,经常会使用文本界面去设置系统或操作系统,作者本人在工作的过程也在不断接触这方面的命令,所以为此特酝酿.准备.开始了本文的编写.本文主要记录自己平时遇到的一些Linux/UNIX下操作命令,记录与整理一下,一可加深印象,二可记录分享.希望各位看官,对于不合适的或有歧义的地方,给予指明与说明,以便共同学习与提高. [转载使用,请注明出处:http://blog.csdn.net/mahoking] 023 kill命令:查看进程及杀死进程 查看进程使用ps命令,本例演示

进程控制(kill)

kill:终止进程(或传送信号到某进程) kill  [options]  [process_ids] kill命令可以发送信号给进程,可以终止(terminate)(默认操作),中断(interrupt),暂停(suspend),销毁(crash)进程等.要影响进程的运行,你必须是该进程的所有者,或者你是superuser; 比如,终止进程13243,必须进行以下操作: $ kill 13243 如果上述操作不起作用,即有些程序并不理会该信号,可以加上 -KILL 选项或 -9 选项(两者相当

辛星浅析kill、pkill的区别

首先说一下kill命令,它是通过pid来杀死进程,要得到某个进程的pid,我们可以使用ps命令,默认情况下,kill命令发送给进程的终止信号是15,但是有些进程不会理这个信号,这样的话,可以用9信号来强制杀死,信号9是不会被忽略的强制性执行信号. 而killall和pkill都是使用命令名来终止进程的有效手段,它们不同于kill通过pid来杀死进程的方式,它可以理解为成批成批的杀死进程,当然这么做的危险性也相对提高了不少.当然它们也可以给进程发送相应的终止信号. 比如我们要杀死apache的相关

Process Kill Technology &amp;&amp; Process Protection Against In Linux

目录 0. 引言 1. Kill Process By Kill Command 2. Kill Process By Resource Limits 3. Kill Process By Code Injection Into Running Process Via GDB 4. Kill Process By Using Cross Process Virtual Memory Modify 5. Kill Process By Using ptrace To Inject .so 6. P

kill 指定端口的进程

命令: kill -9 $(lsof -i:8111|awk '{print $2}') 注: 1. kill -9 端口号, 其中-9代表强制删除进程. 2. lsof -i:port , lsof 全称是list open file,意思是列出系统的文件描述,-i 代表列出的是进程文件描述. 3.awk 的功能是过滤或搜索, '{print $2}'是对过滤的文件执行命令,意思是取过滤的文件或字符串每行的第二个字段. 4.$()是取小括号里面的命令返回值.

linux kill杀死进程

背景:这个命令总是记不住,在此稍作记录,方便查看! 1 杀死进程 1.1 查看进程 此时如果我想杀了火狐的进程就在终端输入: $ kill -s 9 1827 其中-s 9 制定了传递给进程的信号是9,即强制.尽快终止进程.各个终止信号及其作用见附录. 简单吧,但有个问题,进程少了则无所谓,进程多了,就会觉得痛苦了,无论是ps -ef 还是ps -aux,每次都要在一大串进程信息里面查找到要杀的进程,看的眼都花了. 进阶篇: 改进1: 把ps的查询结果通过管道给grep查找包含特定字符串的进程.

APUE学习笔记——10.9 信号发送函数kill、 raise、alarm、pause

转载注明出处:Windeal学习笔记 kil和raise kill()用来向进程或进程组发送信号 raise()用来向自身进程发送信号. #include <signal.h> int kill(pid_t pid,int signo); int raise(int signo); Both return: 0 if OK,?1 on error kill向进程号为pid的进程发送signo信号 能够看出 以下两行代码是等价的: kill(getpid(), signo); raise(sig