Big Event in HDU(母函数)

Big Event in HDU

                     Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

        Total Submission(s): 23902    Accepted Submission(s): 8424

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output

20 10
40 40

Author

lcy

题意: 题目其实理解起来就是一个把一堆数尽量分成相等的两部分,当不能分成相等的两部分时就保证A大于B;

意解: 母函数的转化,题目可以这样解,把一堆数的和累加起来,除以2,然后就像背包一样一直趋近这个数,就可以了;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;
const int M = 1e6 * 2; //注意范围;
int vis[M];//标记数组,标记一个数是否可以由给出的数组合得到;

struct M
{
    int a,b;
    void read()
    {
        scanf("%d %d",&a,&b);
    }
}m[100];

int main()
{
    int n;
    while(~scanf("%d",&n) && n > 0)
    {
        int sum = 0;
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            m[i].read();
            sum += m[i].a * m[i].b;
        }
        int ans = sum / 2;
        int res = 0;
        vis[0] = 1;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j <= m[i].b * m[i].a; j += m[i].a)
            {
                for(int k = 0; k <= res; k++)
                {
                    if(k > ans) break;
                    if(vis[k])
                    {
                        vis[k + j] = 1; //如果存在这样的数,则标记
                    }
                }
                res += m[i].b * m[i].a; //累加当前可以组成的最大的数
            }
        }
        for(int i = ans; i >= 0; i--)//倒着找,可以找出一组最接近的数
        {
            if(vis[i])
            {
                ans = i;
                break;
            }
        }
        printf("%d %d\n",sum - ans,ans);
    }
    return 0;
}
时间: 2024-10-13 11:48:01

Big Event in HDU(母函数)的相关文章

hdu 1171 Big Event in HDU(母函数|多重背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1171 题意:有n种物品,给出每种物品的价值和数目,要将这些物品尽可能的分成相等的两份A和B且A>=B ,输出A,B. 母函数可以过,但感觉最直接的方法应该是多重背包. 母函数的话,也是按总价值的一半求,从一半到小枚举,直到找到系数不为0的就是B. #include <stdio.h> #include <iostream> #include <map> #include <

HDU 1171-Big Event in HDU(母函数)

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 24538    Accepted Submission(s): 8632 Problem Description Nowadays, we all know that Computer College is the biggest department

hdu 1171 Big Event in HDU 母函数解法。。以后再来用背包A一下

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25973    Accepted Submission(s): 9139 Problem Description Nowadays, we all know that Computer College is the biggest department

HDU 1171 Big Event in HDU(母函数或01背包)

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 44151    Accepted Submission(s): 15191 Problem Description Nowadays, we all know that Computer College is the biggest department

组合数学 - 母函数的变形 --- hdu 1171:Big Event in HDU

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24002    Accepted Submission(s): 8458 Problem Description Nowadays, we all know that Computer College is the biggest department

杭电1171 Big Event in HDU(母函数+多重背包解法)

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23728    Accepted Submission(s): 8363 Problem Description Nowadays, we all know that Computer College is the biggest department

HDU1171 Big Event in HDU 【母函数】

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 22835    Accepted Submission(s): 8018 Problem Description Nowadays, we all know that Computer College is the biggest department

hdu 1171 Big Event in HDU(母函数)

链接:hdu 1171 题意:这题可以理解为n种物品,每种物品的价值和数量已知,现要将总物品分为A,B两部分, 使得A,B的价值尽可能相等,且A>=B,求A,B的价值分别为多少 分析:这题可以用母函数的思想解,不过求的不是方案数,而是判断尽可能接近总价值的一半的方案是否存在. 也可以用背包思想,每种物品的价值和数量已知,可以将总价值的一半作为容量,求最大价值,也就最接近所求值了 注:数组要开的稍微大一点,否则可能WA #include<stdio.h> #include<strin

HDU 1171 Big Event in HDU (母函数)

Big Event in HDU Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21671    Accepted Submission(s): 7598 Problem Description Nowadays, we all know that Computer College is the biggest department