poj 2075 Tangled in Cables

Tangled in Cables

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 6

Problem Description

You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start your business properly and are relying on parts you have found in an old warehouse you bought.
Among your finds is a single spool of cable and a lot of connectors. You want to figure out whether you have enough cable to connect every house in town. You have a map of town with the distances for all the paths you may use to run your cable between the
houses. You want to calculate the shortest length of cable you must have to connect all of the houses together.

Input

Only one town will be given in an input.

  • The first line gives the length of cable on the spool as a real number.
  • The second line contains the number of houses, N
  • The next N lines give the name of each house‘s owner. Each name consists of up to 20 characters {az,AZ,09} and contains no whitespace or punctuation.
  • Next line: M, number of paths between houses
  • next M lines in the form

< house name A > < house name B > < distance >

Where the two house names match two different names in the list above and the distance is a positive real number. There will not be two paths between the same pair of houses.

Output

The output will consist of a single line. If there is not enough cable to connect all of the houses in the town, output

Not enough cable

If there is enough cable, then output

Need < X > miles of cable

Print X to the nearest tenth of a mile (0.1).

Sample Input

100.0
4
Jones
Smiths
Howards
Wangs
5
Jones Smiths 2.0
Jones Howards 4.2
Jones Wangs 6.7
Howards Wangs 4.0
Smiths Wangs 10.0

Sample Output

Need 10.2 miles of cable

这题是最小树的变形,将各个名字转化为点,最小树求即可!当然还有长度要求!

代码:
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define N 1010
char s[10000][30];
double map[N][N],cost[N],m,outcome;
int country,road,v[N];
void prim()
{
	int i,j,next;
	double mincost;
	memset(v,0,sizeof(v));
	for(i=0;i<country;i++)
	{
	 cost[i]=map[0][i];

	 }
	 v[0]=1;
	 for(i=1;i<country;i++)//寻找最短的距离
	  {
	  	mincost=INF;
	  	for(j=0;j<country;j++)
	  	 {
	  	 	if(!v[j]&&mincost>cost[j])
	  	 	{
	  	 		mincost=cost[j];
	  	 		next=j;
			}
		   }
		   outcome+=mincost;
		   v[next]=1;
		   for(j=0;j<country;j++)//更新路径
		    {
		    	if(!v[j]&&cost[j]>map[next][j])
		    	{
		    		cost[j]=map[next][j];
				}
			}
	  }
}
int main()
{
	int i,j;
	double l;
	char a[30],b[30];
	while(scanf("%lf",&m)!=EOF)
	{
	scanf("%d",&country);
	for(i=0;i< country;i++)
	 scanf("%s",s[i]);
	 scanf("%d",&road);
	 for(i=0;i<country;i++)
	  {
	  	for(j=0;j<country;j++)
	  	 {
	  	 	if(i==j)
	  	 	map[i][j]=0;
	  	 	else
	  	 	map[i][j]=INF;
		   }
	  }
	 for(i=0;i<road;i++)//字符转化为点
	  {
	  	scanf("%s%s%lf",a,b,&l);
	  	int k,t;
	  	for(j=0;j<country;j++)
	  	{
	  		if(strcmp(s[j],a)==0)
	  		 k=j;
		}
		  for(j=0;j<country;j++)
		   {

		   		if(strcmp(s[j],b)==0)
	  		      t=j;
		   }
		    map[t][k]=map[k][t]=l;
	  }
	  prim();
	  if(outcome<=m)
	  printf("Need %.1f miles of cable\n",outcome);
	  else
	  printf("Not enough cable\n");
	return 0;
}
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-12-12 07:28:15

poj 2075 Tangled in Cables的相关文章

POJ 2075 Tangled in Cables (c++/java)

http://poj.org/problem?id=2075 题目大意: 给你一些人名,然后给你n条连接这些人名所拥有的房子的路,求用最小的代价求连接这些房子的花费是否满足要求. 思路: 昨天20分钟的题,输入不小心写错了- -|||||看世界杯半场休息随便看了下发现了....T T 用map进行下标的映射,然后求MST即可. c++ #include<cstdio> #include<string> #include<map> #include<algorith

POJ 2075 Tangled in Cables (kruskal算法 MST + map)

Tangled in Cables Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 6039   Accepted: 2386 Description You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start

POJ 2075:Tangled in Cables 【Prim】

Tangled in Cables Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other) Total Submission(s) : 2   Accepted Submission(s) : 1 Problem Description You are the owner of SmallCableCo and have purchased the franchise rights for

POJ 2075

#include<iostream> #include<stdio.h> #include<string> #include<map> #include<iomanip> #define MAXN 500 #define inf 1000000000 typedef double elem_t; using namespace std; double _m[MAXN][MAXN]; int pre[MAXN]; map<string,int

Tangled in Cables(Kruskal+map容器处理字符串)

/** 题意: 给你两个城市之间的道路(无向图),求出需要的 电缆.如果大于所提供的,就输出Not enough ... 否则输出所需要的电缆长度. 输入:N (给定的电缆总长度) m1 (有多少个城市—) str1 str2 str3 str4 : :(城市的名字) m2(相当于给出m2条边) a  b  c (a城市到b城市的距离为c) : : : : 输出: 所需的最短长度   若大于给定的长度  输出 Not enough cable 分析: 简单的最小生成树+字符串处理 用map容器映

图论常用算法之一 POJ图论题集【转载】

POJ图论分类[转] 一个很不错的图论分类,非常感谢原版的作者!!!在这里分享给大家,爱好图论的ACMer不寂寞了... (很抱歉没有找到此题集整理的原创作者,感谢知情的朋友给个原创链接) POJ:http://poj.org/ 1062* 昂贵的聘礼 枚举等级限制+dijkstra 1087* A Plug for UNIX 2分匹配 1094 Sorting It All Out floyd 或 拓扑 1112* Team Them Up! 2分图染色+DP 1125 Stockbroker

HOJ 题目分类

转自:http://blog.sina.com.cn/s/blog_65f3869301011a1o.html ******************************************************************************* 简单题(包括枚举,二分查找,(复杂)模拟,基础数据结构(栈.队列),杂题等 ****************************************************************************

poj2075

Tangled in Cables Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 6348   Accepted: 2505 Description You are the owner of SmallCableCo and have purchased the franchise rights for a small town. Unfortunately, you lack enough funds to start

ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

题目链接:ZOJ1372 POJ 1287 Networking 网络设计 Networking Time Limit: 2 Seconds      Memory Limit: 65536 KB You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible