poj——2752Seek the Name, Seek the Fame(kmp专练 找出前后相同的字串)

Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 16035 Accepted: 8158

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative
little cat works out an easy but fantastic algorithm:

Step1. Connect the father‘s name and the mother‘s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala‘, Mother=‘la‘, we have S = ‘ala‘+‘la‘ = ‘alala‘. Potential prefix-suffix strings of S are {‘a‘, ‘ala‘, ‘alala‘}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings
of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby‘s name.

Sample Input

ababcababababcabab

aaaaa

Sample Output

2 4 9 18

1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu

给定一个字符串s,从小到大输出s中既是前缀又是后缀的子串的长度。

此题非常简单,借用KMP算法的next数组,设s的长度为n,

则s串本身必定满足条件。其他满足条件的子串都有个特征,

就是该子串的最后一个字符肯定与s的最后一个字符相同。

这正是next数组发挥作用的时候。

从n - 1位既最后一位开始回滚,若s[next[n-1]] == s[n-1],

则子串s[0,1,2,...,next[n-1]]是满足条件的子串。

然后判断s[next[next[n-1]]] == s[n-1]是否成立,这样一直回滚,

直到next[next[.....next[n-1]]] == -1为止。把答案从大到小存下来,再从小到大输出即可。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int Next[400005];
char str[400005];
int ans[400005];
int cnt;
int len;

void getNext()
{
	Next[0] = -1;
	int i = 0, j = -1;
	while (i < len)
	{
		if (j == -1 || str[i] == str[j])
		{
			++i;
			++j;
			Next[i] = j;
		}
		else j = Next[j];
	}
}

int main()
{
	while (scanf("%s", str) != EOF)
	{
		len = strlen(str);
		getNext();
		cnt = 0;
		int t = Next[len - 1];
		while (t != -1)
		{
			if (str[t] == str[len - 1]) ans[cnt++] = t+1;
			t = Next[t];//跳回前一个与最后一个字符匹配的位置
		}
		for (int i = cnt - 1; i >= 0; --i)
		{
			printf("%d ", ans[i]);
		}
		printf("%d\n", len);
	}
	return 0;
}
时间: 2024-11-09 00:07:55

poj——2752Seek the Name, Seek the Fame(kmp专练 找出前后相同的字串)的相关文章

poj 2752Seek the Name, Seek the Fame 【kmp】

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14154   Accepted: 7049 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ 2752Seek the Name, Seek the Fame(next数组妙用 + 既是前缀也是后缀)

题目链接 题意:求一个字符串中 前缀 和 后缀 相同的长度 分析: 对于一个字符串他自己的长度肯定是可以的.然后如果满足 前缀 和 后缀相等,那个前缀 最后一个字符 一定 和 该字符串最后一个字符相等,不然不会满足条件. 所以 找 str[len - 1] 的next数组, 对于 next[len - 1] 来看看这个位置 是不是等于最后一个字符,如果相等,那么前 next[len - 1] 一定是可以的, 然后 在判断next[ next[len - 1] ]  是不是等于 str[len -

poj 2752 Seek the Name, Seek the Fame KMP

对于KMP算法中next函数的应用 题意是对于一个字符串的前缀和后缀比较是否相等,再把相等的可能按字符串长度进行输出 #include <iostream> #include<stdio.h> #include<string.h> using namespace std; int len; int next[1000005]; char s[1000005]; int kmp_next() { int i=0,j=-1; next[0]=-1; while(i<l

POJ 2752 Seek the Name, Seek the Fame KMP题解

本题是KMP的next数组的灵活运用. 具体就是看最后整个数列的最后一个字母,能有多少前缀. 理解了next数组就很容易了. #include <stdio.h> #include <string.h> #include <vector> using std::vector; const int MAX_N = 400001; char name[MAX_N]; int next[MAX_N], len; void genNext() { for (int i = 1,

POJ 2752 Seek the Name, Seek the Fame kmp失配函数next应用

点击打开链接 Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12791   Accepted: 6304 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give

POJ 2752 Seek the Name, Seek the Fame (KMP的next函数运用)

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14188   Accepted: 7068 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t

POJ - 2752 Seek the Name, Seek the Fame (KMP的next[]应用)

Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such b

POJ 2752 Seek the Name, Seek the Fame kmp(后缀与前缀)

题意: 给你一个串T,找出串T的子串,该串既是T的前缀也是T的后缀.从小到大输出所有符合要求的串的长度. 分析: 首先要知道KMP的next[i]数组求得的数值就是串T中的[1,i-1]的后缀与串T中的[0,i-2]前缀的最大匹配长度.         所以next[m](m为串长且串从0到m-1下标)的值就是与后缀匹配的最大前缀长度(想想是不是). next[next[m]]也是一个与后缀匹配的前缀长度,,,依次类推即可. 题解来自饶齐:http://blog.csdn.net/u013480

POJ2752 Seek the Name, Seek the Fame (kmp) 题解

Seek the Name, Seek the Fame Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 17094   Accepted: 8720 Description The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names t