Treap [POJ 1442] Black Box

Black Box

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7770   Accepted: 3178

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1

N Transaction i Black Box contents after transaction Answer
      (elements are arranged by non-descending)
1 ADD(3)      0 3
2 GET         1 3                                    3
3 ADD(1)      1 1, 3
4 GET         2 1, 3                                 3
5 ADD(-4)     2 -4, 1, 3
6 ADD(2)      2 -4, 1, 2, 3
7 ADD(8)      2 -4, 1, 2, 3, 8
8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8
9 GET         3 -1000, -4, 1, 2, 3, 8                1
10 GET        4 -1000, -4, 1, 2, 3, 8                2
11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.

Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

Source

Northeastern Europe 1996

#include <iostream>
#include <stdio.h>
#include <time.h>
using namespace std;
#define N 30100
#define INF 0x7fffffff

int val[N];
struct Treap
{
    int ch[N][2],fix[N],size[N];
    int top,root;

    inline void PushUp(int rt)
    {
        size[rt]=size[ch[rt][0]]+size[ch[rt][1]]+1;
    }
    void Newnode(int &rt,int v)
    {
        rt=++top;
        val[rt]=v;
        size[rt]=1;
        fix[rt]=rand();
        ch[rt][0]=ch[rt][1]=0;
    }
    void Init()
    {
        top=root=0;
        ch[0][0]=ch[0][1]=0;
        size[0]=val[0]=0;
        memset(size,0,sizeof(size));
    }
    void Rotate(int &x,int kind)
    {
        int y=ch[x][kind^1];
        ch[x][kind^1]=ch[y][kind];
        ch[y][kind]=x;
        PushUp(x);
        PushUp(y);
        x=y;
    }
    void Insert(int &rt,int v)
    {
        if(!rt)
            Newnode(rt,v);
        else
        {
            int kind=(v>=val[rt]);
            size[rt]++;
            Insert(ch[rt][kind],v);
            if(fix[ch[rt][kind]]<fix[rt])
                Rotate(rt,kind^1);
        }
    }
    int Find(int rt,int k)
    {
        int cnt=size[ch[rt][0]];
        if(k==cnt+1) return val[rt];
        else if(k<=cnt) return Find(ch[rt][0],k);
        else return Find(ch[rt][1],k-cnt-1);
    }
}t;
int main()
{
    int n,i,m;
    srand((int)time(0));
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        t.Init();
        for(i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
        }
        int last=1,x;
        for(i=1;i<=m;i++)
        {
            scanf("%d",&x);
            while(last<=x)
            {
                t.Insert(t.root,val[last]);
                last++;
            }
            printf("%d\n",t.Find(t.root,i));
        }
    }
    return 0;
}
时间: 2024-09-29 23:47:41

Treap [POJ 1442] Black Box的相关文章

POJ 1442 Black Box treap求区间第k大

题目来源:POJ 1442 Black Box 题意:输入xi 输出前xi个数的第i大的数 思路:试了下自己的treap模版 #include <cstdio> #include <cstring> #include <cstdlib> #include <ctime> using namespace std; struct Node { Node *ch[2]; int r; int v; int s; Node(){} Node(int v): v(v)

poj 1442 -- Black Box

Black Box Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 7183   Accepted: 2920 Description Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empt

[ACM] POJ 1442 Black Box (堆,优先队列)

Black Box Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 7099   Accepted: 2888 Description Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empt

POJ 1442 Black Box(优先队列)

题目地址:POJ 1442 这题是用了两个优先队列,其中一个是较大优先,另一个是较小优先.让较大优先的队列保持k个.每次输出较大优先队列的队头. 每次取出一个数之后,都要先进行判断,如果这个数比较大优先的队列的队头要小,就让它加入这个队列,队列头移到较小优先的队列中.然后当较大优先的数不足k个的时候,就让较小优先的队列的队头移到较大优先的队头中. 代码如下: #include <iostream> #include <cstdio> #include <string>

poj 1442 Black Box (treap树入门题)

1 /**************************************************** 2 题目: Black Box(poj 1442) 3 链接: http://poj.org/problem?id=1442 4 题意: 给n个数,m个询问,对第i数个询问前Xi个数中第 5 i小的是那个数. 6 算法: treap树 7 *****************************************************/ 8 #include<iostream

POJ 1442 Black Box(treap树)

题目链接:点击打开链接 思路:treap树模板题, 可以动态维护一个有序表, 支持在O(logN)的时间内完成插入.删除一个元素和查找第K大元素的任务. 当然, treap树能做到的还远远不止这些, 常常与其他数据结构嵌套. treap树是一种平衡二叉搜索树, 既满足堆的条件, 又满足排序二叉树的条件. 细节参见代码: #include <cstdio> #include <cstring> #include <algorithm> #include <iostr

POJ 1442 Black Box 基础Treap

高中的时候做过这个,是用两个堆搞的,现在看来其实就是实现一个很简答的数据结构,能够插入元素,找第k大,用平衡树来搞其实是大材小用了,就当做是练习吧. Treap是利用除了键值之外另外一个rand_key域的随机性来保证平衡的,所以说只要随机函数够好,理论上应该是平衡的,而且写起来比较方便. #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include &

数据结构(堆):POJ 1442 Black Box

Black Box Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 10658   Accepted: 4390 Description Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is emp

Black Box(POJ 1442&#183;TREAP实现)

传送门:http://poj.org/problem?id=1442 Black Box Time Limit: 1000MS   Memory Limit: 10000K       Description Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empt