题目1437:To Fill or Not to Fill(贪心算法)

题目描述:

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different
price. You are asked to carefully design the cheapest route to go.

输入:

For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that
the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line
are separated by a space.

输出:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance
= X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

样例输入:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
50 1300 12 2
7.10 0
7.00 600
样例输出:
749.17
The maximum travel distance = 1200.00

分析:

贪心策略:假设现在自己处于A站,要考虑的是A站要不要加油,加多少油的问题。找到当前可达范围内(距离A站cmax*davg)下一个要加油的站B。

A站可达范围内, 分三种情况:

①没有加油站,------- 快到终点了,则加适量油到终点;或者 Impossible,则A站加满油到哪算哪;

②有更便宜的加油站 ------- 则找到第一家比A便宜的加油站B,加尽可能少的油(也可能油够直接开过去)到B站;

③只有价格更高的加油站,------则当下A站加满油,寻找相对最便宜的加油站B 开过去。

对每一个加油站进行贪心选择。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;

struct gas_station{
    float price;
    int distance;

    bool operator < (const gas_station & A)const {
        return distance < A.distance;
    }

}buff[501];
int main()
{
    int Cmax,D,Davg,N;
    int dis;
    while(scanf("%d %d %d %d",&Cmax,&D,&Davg,&N)!=EOF){
        for(int i = 0; i < N; i++){
            scanf("%f %d",&buff[i].price,&buff[i].distance);
        }
        buff[N].distance = D;
        buff[N].price = 100000000;

        sort(buff,buff+N);

        if(buff[0].distance > 0){
            printf("The maximum travel distance = 0.00\n");
            continue;
        }

        dis = Cmax * Davg;//最大单次行车距离
        float sum = 0;//总费用
        float temp,remind_gas = 0;//剩余汽油量
        int i ,k;
        for(i = 0; i < N;i++){
            k = i+1;
            if(i != 0){
                remind_gas -= (float)(buff[i].distance-buff[i-1].distance)/Davg;
            }
            //找到当前站之后第一个价格比它低的加油站
            for(;k < N && buff[i].price <= buff[k].price;k++ )
                continue;
            if(buff[k].distance - buff[i].distance > dis){
                sum += (Cmax-remind_gas)*buff[i].price;
                remind_gas = Cmax;
            }else{
                temp = (float)(buff[k].distance-buff[i].distance)/Davg - remind_gas;
                if(fabs(temp)>1e-5&&temp >0){
                    sum += temp*buff[i].price;
                    remind_gas = (float)(buff[k].distance-buff[i].distance)/Davg;
                }
            }

            if(buff[i+1].distance - buff[i].distance>dis){
                double total_d = (double)(buff[i].distance + dis);
                printf("The maximum travel distance = %.2f\n",total_d);
                break;
            }
        }
        if(i==N){
            printf ("%.2f\n", sum);
        }

    }
    return 0;
}
 

注意:

比较浮点数是否大于零,需要加上fabs(temp),因为这个地方还wa了一次。

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-08 06:51:29

题目1437:To Fill or Not to Fill(贪心算法)的相关文章

九度oj 1437 To Fill or Not to Fill 2012年浙江大学计算机及软件工程研究生机试真题

题目1437:To Fill or Not to Fill 时间限制:1 秒 内存限制:128 兆 特殊判题:否 提交:1488 解决:345 题目描述: With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way fro

PAT 1033. To Fill or Not to Fill (25)(贪心)

解题思路: 其实题目本身不难,难就难在对贪心策略的选取 在每一个加油点应该做这样的判断: 1.首先计算从本加油点做多可能达到的加油点 2.如果有可达加油点的话: 2.1 寻找有无比当前加油点油价便宜的加油点,如果有的话就跑到该便宜的加油点,油量加到支持到该加油点即可 2.2 如果没有比当前加油点更便宜的加油点的话,又分两种情况: 2.2.1.如果本次加油可能直接到终点,就加可以到达终点的油量 2.2.2.否则的话,加满 3.如果没有可达加油点的话: 3.1 看是否可以直接达到终点 3.2 不能达

【贪心】PAT 1033. To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25) 时间限制 10 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 ZHANG, Guochuan With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to fin

PAT 1033 To Fill or Not to Fill[dp]

1033 To Fill or Not to Fill(25 分) With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may gi

pat1033. To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25) 时间限制 10 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 ZHANG, Guochuan With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to fin

1033 To Fill or Not to Fill (25 分)

1033 To Fill or Not to Fill (25 分) With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may g

1033. To Fill or Not to Fill (25) -贪心算法

题目如下: With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are

贪心算法之经典题目---订票

题目:一票务办公室为音乐会售票,出售某一固定数量的连号票(简称套票).购票订单以该套票中最小的座位号作为标志.由于不能满足所有订单,故而采用:若订单完全满足观众要求的票全价:若订单中至少一个座位与观众要求不同,则半价.现求怎样处理订单,才能使总收入最高.输入为套票里座位数量,订单数以及每个订单对应的座位号(最小的座位号为标志).输出订单处理结果,即处理后的套票号码.(不要求顺序,且输入数据都符合要求,最小座位号为1,订单可以不被接受.) 解题思路: 采用贪心算法,3个步骤: 1)  试图分配尽可

题目1437:To Fill or Not to Fill

时间限制:1 秒 内存限制:128 兆 (贪心有点复杂) 题目描述: With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may g