PAT 1146 Topological Order

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

#include<iostream> //水题, 考虑入度即可
#include<vector>
using namespace std;
int main(){
    int n, m;
    cin>>n>>m;
    vector<vector<int>> v(n+1);
    vector<int> indegree(n+1, 0);
    vector<int> ans;
    for(int i=0; i<m; i++){
        int s, e;
        cin>>s>>e;
        v[s].push_back(e);
        indegree[e]++;
    }
    int k, a;
    cin>>k;
    for(int i=0; i<k; i++){
        vector<int> t=indegree;
        int flag=0;
        for(int j=0; j<n; j++){
            cin>>a;
            if(t[a]!=0) flag=1;
            for(int p=0; p<v[a].size(); p++)
                t[v[a][p]]--;
        }
        if(flag==1) ans.push_back(i);
    }
    for(int i=0; i<ans.size(); i++)
        i==0?cout<<ans[i]:cout<<" "<<ans[i];
    return 0;
}

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9652308.html

时间: 2024-08-01 07:28:32

PAT 1146 Topological Order的相关文章

PAT 1146 Topological Order[难]

1146 Topological Order (25 分) This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options

1146 Topological Order (25 分)判断拓扑序列

1146 Topological Order (25 分) This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options

PAT甲级——1146 Topological Order (25分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options. Input Specification: Each in

PAT Advanced 1146 Topological Order (25) [拓扑排序]

题目 This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options. Input Specification: Each

拓扑排序(Topological Order)UVa10305 Ordering Tasks

2016/5/19 17:39:07 拓扑排序,是对有向无环图(Directed Acylic Graph , DAG )进行的一种操作,这种操作是将DAG中的所有顶点排成一个线性序列,使得图中的任意一对顶点u,v满足如下条件: 若边(u,v)∈E(G),则在最终的线性序列中出现在v的前面 好了,说人话:拓扑排序的应用常常和AOV网相联系,在一个大型的工程中,某些项目不是独立于其他项目的,这意味着这种非独立的项目的完成必须依赖与其它项目的完成而完成,不妨记为u,v,则若边(u,v)∈E(G),代

A题目

1 1001 A+B Format(20) 2 1002 A+B for Polynomials(25) 3 1003 Emergency(25) 4 1004 Counting Leaves(30) 5 1005 Spell It Right(20) 6 1006 Sign In and Sign Out(25) 7 1007 Maximum Subsequence Sum(25) 8 1008 Elevator(20) 9 1009 Product of Polynomials(25) 10

PTA Topological Sort

生病了好蓝过啊,哎还是家里好,生病都不能码代码了TAT-- 下面是题目: Write a program to find the topological order in a digraph. Format of functions: bool TopSort( LGraph Graph, Vertex TopOrder[] ); where LGraph is defined as the following: typedef struct AdjVNode *PtrToAdjVNode; s

Some facts about topological sort

Definition: a topological sort of a DAG G is a sort such that for all edge (i,j) in G, i precedes j. Then we have following corollaries: A sort is a topological sort of a DAG G iff for all i, j such that there is a path from i to j, i precedes j in t

Topological Sort

In what kind of situation will we need to use topological sort? Precedence(优先级) scheduling, say given a set of tasks to be completed with precedence constraints, in which order should we schedule the tasks? One simple example are classes in universit