[ACM] HDU 5086 Revenge of Segment Tree(所有连续区间的和)

Revenge of Segment Tree

Problem Description

In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the
structure is built. A similar data structure is the interval tree.

A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.

---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.

Input

The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

Output

For each test case, output the answer mod 1 000 000 007.

Sample Input

2
1
2
3
1 2 3

Sample Output

2
20

Hint

For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.
Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.
And one more little helpful hint, be careful about the overflow of int.

Source

BestCoder Round #16

解题思路:

给定n个数的数列,求所有连续区间的和。。最简单的一道题,智商捉急啊,没想到。。。。

对于当前第i个数(i>=1),我们只要知道有多少个区间包含a[i]就可以了,答案是 i*(n-i+1), i代表第i个数前面有多少个数,包括它自己,(n-i+1)代表第i个数后面有多少个数,包括它自己,然后相乘,代表前面的标号和后边的标号两两配对。

如图:

上图数列取得不恰当,标号和数正好相等,比如数列1,4,2,4,5,图也是和上图一样的。关键的是标号,而不是具体的数。

代码:

#include <iostream>
#include <stdio.h>
using namespace std;
#define ll long long
const ll mod=1000000007;
ll n;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        ll x;
        ll ans=0;
        for(ll i=1;i<=n;i++)
        {
            scanf("%I64d",&x);
            ans=(ans+i*(n-i+1)%mod*x%mod)%mod;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

注意输出 I64

时间: 2024-10-17 13:44:15

[ACM] HDU 5086 Revenge of Segment Tree(所有连续区间的和)的相关文章

[ACM] HDU 5086 Revenge of Segment Tree(全部连续区间的和)

Revenge of Segment Tree Problem Description In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structur

hdu 5086 Revenge of Segment Tree(BestCoder Round #16)

Revenge of Segment Tree                                                          Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 420    Accepted Submission(s): 180 Problem Description In comput

HUD 5086 Revenge of Segment Tree(递推)

http://acm.hdu.edu.cn/showproblem.php?pid=5086 题目大意: 给定一个序列,求这个序列的子序列的和,再求所有子序列总和,这些子序列是连续的.去题目给的第二组数据的 3 1 2 3 这个序列的子序列有 [1].[2].[3].[1.2].[2.3].[1.2.3],这些子序列的和是分别是1.2.3.3.5.6.再将这些和加起来 1+2+3+3+5+6=20这个就是最终的答案. 解题思路: 我们假设n等于5.序列为1.2.3.4.5.然后我们将它们如下排列

Revenge of Segment Tree (hdu 5086)

Revenge of Segment Tree Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1282    Accepted Submission(s): 324 Problem Description In computer science, a segment tree is a tree data structure for

hdu5086——Revenge of Segment Tree

Revenge of Segment Tree Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 383    Accepted Submission(s): 163 Problem Description In computer science, a segment tree is a tree data structure for s

HDU5086——Revenge of Segment Tree(BestCoder Round #16)

Revenge of Segment Tree Problem DescriptionIn computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure

HDU5086:Revenge of Segment Tree(规律题)

http://acm.hdu.edu.cn/showproblem.php?pid=5086 #include <iostream> #include <stdio.h> #include <math.h> #include <queue> #include <map> #include <stdlib.h> #include <algorithm> #include <string.h> #define mo

BestCoder Round #16 Revenge of Segment Tree (树状数组)

今天第一次参加bc,虽然由于运动会耽误了时间,但还是开始做了题目. 第一道题恰巧是最近做的树状数组类型,nlogn 复杂度.规律推算很简单.一个长度的区间累加过程中会消掉中间部分,区间长度的改变会导致减掉加上的部分改变.减掉的是最前面k-1,加上后面n-k+1个 第二题一直没很好明白题意,虽然认为不难. 起初没有用long long 溢出了两次,o(︶︿︶)o 唉   以后看到取模之类的直接ll #include<cstdio> #include<string> #include&

hdu 5086

Revenge of Segment Tree Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1175    Accepted Submission(s): 403 Problem Description In computer science, a segment tree is a tree data structure for s