POJ 题目2728 Desert King(最优比率生成树)

Desert King

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 21923   Accepted: 6123

Description

David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country to bring water to every village. Villages which are connected to his capital village
will be watered. As the dominate ruler and the symbol of wisdom in the country, he needs to build the channels in a most elegant way.

After days of study, he finally figured his plan out. He wanted the average cost of each mile of the channels to be minimized. In other words, the ratio of the overall cost of the channels to the total length must be minimized. He just needs to build the necessary
channels to bring water to all the villages, which means there will be only one way to connect each village to the capital.

His engineers surveyed the country and recorded the position and altitude of each village. All the channels must go straight between two villages and be built horizontally. Since every two villages are at different altitudes, they concluded that each channel
between two villages needed a vertical water lifter, which can lift water up or let water flow down. The length of the channel is the horizontal distance between the two villages. The cost of the channel is the height of the lifter. You should notice that
each village is at a different altitude, and different channels can‘t share a lifter. Channels can intersect safely and no three villages are on the same line.

As King David‘s prime scientist and programmer, you are asked to find out the best solution to build the channels.

Input

There are several test cases. Each test case starts with a line containing a number N (2 <= N <= 1000), which is the number of villages. Each of the following N lines contains three integers, x, y and z (0 <= x, y < 10000, 0 <=
z < 10000000). (x, y) is the position of the village and z is the altitude. The first village is the capital. A test case with N = 0 ends the input, and should not be processed.

Output

For each test case, output one line containing a decimal number, which is the minimum ratio of overall cost of the channels to the total length. This number should be rounded three digits after the decimal point.

Sample Input

4
0 0 0
0 1 1
1 1 2
1 0 3
0

Sample Output

1.000

Source

Beijing 2005

题目大意:

给你n个点,每个都有x,y,z坐标,建立一个三维生成树,是高度差之和和水平距离之和比率最小,求这个比率

ac代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#define INF 1<<30
struct s
{
	double x,y,z;
}ponit[1010];
int n,vis[1010];
double len[1010][1010],high[1010][1010],map[1010][1010];
double hlen(struct s a,struct s b)
{
	return fabs(a.z-b.z);
}
double dis(struct s a,struct s b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double prim(double mid)
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			map[i][j]=high[i][j]-mid*len[i][j];
		}
	}
	memset(vis,0,sizeof(vis));
	vis[1]=1;
	double sum=0;
	for(i=2;i<=n;i++)
	{
		int flag=-1;
		double minn=INF;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&map[1][j]<minn)
			{
				flag=j;
				minn=map[1][j];
			}
		}
		if(flag==-1)
			break;
		vis[flag]=1;
		sum+=map[1][flag];
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&map[1][j]>map[flag][j])
			{
				map[1][j]=map[flag][j];
			}
		}
	}
	return sum;
}
int main()
{
	//int n;
	while(scanf("%d",&n)!=EOF,n)
	{
		int i,j;
		for(i=1;i<=n;i++)
			scanf("%lf%lf%lf",&ponit[i].x,&ponit[i].y,&ponit[i].z);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				len[i][j]=len[j][i]=dis(ponit[i],ponit[j]);
				high[i][j]=high[j][i]=hlen(ponit[i],ponit[j]);
			}
		}
		double a,b,mid;
		a=0;
		b=100;
		while(b>=a)
		{
			mid=(a+b)/2;
			double temp=prim(mid);
			if(fabs(temp)<=0.00005)
				break;
			if(temp>=0.00005)
				a=mid;
			else
				b=mid;
		}
		printf("%.3lf\n",mid);
	}
}
时间: 2024-11-29 21:51:22

POJ 题目2728 Desert King(最优比率生成树)的相关文章

POJ 2728 Desert King (最优比率生成树---01分数规划)

题目地址:POJ 2728 01分数规划的应用之一-最优比率生成树. 跟普通的01分数规划类似,只是这题的验证函数改成了最小生成树来验证.弱用的迭代法. 代码如下: #include <iostream> #include <string.h> #include <math.h> #include <queue> #include <algorithm> #include <stdlib.h> #include <map>

POJ 2728 Desert King 最优比率生成树

Desert King Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 20978   Accepted: 5898 [Description] David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his co

ZOJ 2728 Desert King(最优比例生成树)

Desert King Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 20586   Accepted: 5777 Description David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his coun

【POJ】【2728】 Desert King 最优比率生成树

题意:给出每个点的坐标(x,y,z),两点间距离是x,y的直线距离,边权为z差,求∑边权 / ∑距离 的最小值. 最优比率生成树!(分数规划) 就是根据分数规划的思想建树,每次看得到的总和是正是负. 二分代码: #include<string.h> #include<stdio.h> #include<stdlib.h> #include<math.h> #define N 1010 typedef struct KSD { int x,y,z; }ksd;

POJ 2728 Desert King 最优比例生成树

最优比例生成树,迭代方法..... Desert King Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 21086   Accepted: 5916 Description David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels

poj 2728(Desert King) 最优比例生成树 (分数规划)

这题是最小生成树的一种扩展,就是求一棵树  使得 k =sigma(cost)/ sigma(len)  最小.   其中cost 为每条边花费,len为长度.  这实际上就是一个最优比例生成树.最优比例生成树的求解使用了分数规划的方法.  我们先任取k,假设k是最小值,那么sigma(ccost)-k*sigma(len)==0  .那么我们就新建图边权 为  ccosti-k*leni  .求一次最小生成树,如果生成树权值小于0,那么书名其实k还是有减小的空间的,否则,k不可能是最小.这样我

【POJ2728】Desert King 最优比率生成树

题目大意:给定一个 N 个点的无向完全图,边有两个不同性质的边权,求该无向图的一棵最优比例生成树,使得性质为 A 的边权和比性质为 B 的边权和最小. 题解:要求的答案可以看成是 0-1 分数规划问题,即:选定一个数 mid,每次重新构建边权为 \(a[i]-mid*b[i]\) 的图,再在图上跑一遍最小生成树(这里由于是完全图,应该采用 Prim 算法)判断最小值和给定判定的最小值的关系即可,这里为:若最小值大于 mid,则下界提高,否则上界下降. 代码如下 #include<cmath>

poj-2728Desert King(最优比率生成树)

题目连接: Desert King Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 23729   Accepted: 6631 Description David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over hi

poj 2728 Desert King

Desert King http://poj.org/problem?id=2728 Time Limit: 3000MS   Memory Limit: 65536K       Description David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country t