杭电 HDU 1033 Edge

Edge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2251    Accepted Submission(s): 1439

Problem Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded
along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts
of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in
a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming
90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The
input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the
command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget
the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

Source

University of Ulm Local Contest 2003

今天晚上哥哥也是醉了,熬夜到这时候,不负所望,AC之,其实这个题看起来高大上的样子,读了三遍才懂它什么意思。不过我的解法确实很麻烦,但虽然写的那么复杂,唉 起码锻炼思维逻辑能力了;

提交上去后,是各位小伙子们简直理解不了的亢奋哦!不知道最近疯狂的爱上acm了,以至于天天都不愿意去上课了丫的。接下来的代码看起来很苯蛋的样子,自己都服了。妈的。

上代码:

#include<iostream>
using namespace std;
#include<string>
int main()
{
	int t[200],k[200];
	string str1;
	string str[]={"moveto","lineto"};
	while(cin>>str1)
	{
		 t[0]=300;k[0]=420;
		 t[1]=310;k[1]=420;
		 int flag=0;
		cout<<t[0]<<" "<<k[0]<<" "<<str[0]<<endl
			<<t[1]<<" "<<k[1]<<" "<<str[1]<<endl;

		str1="  "+str1;
		for(int i=2;i<str1.size();i++)
		{
			switch(str1[i])
			{
			case 'V':
				{
					if(flag)
					{
						if((t[i-1]==t[i-2]))
						{
							if((k[i-1]>k[i-2]))
							{
								k[i]=k[i-1];
							   t[i]=t[i-1]-10;
							}
							else
							{
								k[i]=k[i-1];
								t[i]=t[i-1]+10;
							}

						}
						else
						{
							if(t[i-1]>t[i-2])
							{
							   t[i]=t[i-1];
							   k[i]=k[i-1]+10;
							}
							else
							{
								t[i]=t[i-1];
								k[i]=k[i-1]-10;
							}
						}
						cout<<t[i]<<" "<<k[i]<<" "<<str[1]<<endl;
					}
					else
					{
						cout<<t[1]<<" "<<k[1]+10<<" "<<str[1]<<endl;
						k[2]=k[1]+10;
						t[2]=t[1];
					}
					  flag=1;
					  break;
				}
			case'A':
				{
					if(flag)
					{
						if(t[i-1]==t[i-2])
						{
							if(k[i-1]<k[i-2])
							{
							  t[i]=t[i-1]-10;
							  k[i]=k[i-1];
							}
							else
							{
								t[i]=t[i-1]+10;
								k[i]=k[i-1];
							}
						}
						else
						{
							if(t[i-1]<t[i-2])
							{
							  k[i]=k[i-1]+10;
							  t[i]=t[i-1];
							}
							else
							{
								k[i]=k[i-1]-10;
								t[i]=t[i-1];
							}
						}
						cout<<t[i]<<" "<<k[i]<<" "<<str[1]<<endl;
						}
					 else
					 {
						 cout<<t[1]<<" "<<k[1]-10<<" "<<str[1]<<endl;
						 k[2]=k[1]-10;
						 t[2]=t[1];
					 }
					  flag=1;
					  break;
				}
			default:
				break;
			}

		}
		cout<<"stroke"<<endl
				<<"showpage"<<endl;
	}
	return 0;
时间: 2024-10-12 19:32:06

杭电 HDU 1033 Edge的相关文章

杭电 HDU 1164 Eddy&#39;s research I

Eddy's research I Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7117    Accepted Submission(s): 4268 Problem Description Eddy's interest is very extensive, recently  he is interested in prime

杭电 HDU 1038 Biker&#39;s Trip Odometer

Biker's Trip Odometer Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4745    Accepted Submission(s): 3144 Problem Description Most bicycle speedometers work by using a Hall Effect sensor faste

杭电 HDU 1098 Ignatius&#39;s puzzle

Ignatius's puzzle Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7068    Accepted Submission(s): 4883 Problem Description Ignatius is poor at math,he falls across a puzzle problem,so he has no

杭电 HDU 1163 Eddy&#39;s digital Roots

Eddy's digital Roots Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4904    Accepted Submission(s): 2743 Problem Description The digital root of a positive integer is found by summing the digi

杭电hdu 4861 Couple doubi

杭电 2014多校联训第一场   1001   Couple doubi   逗比夫妇 这标题我就不多说什么了. 题意:有K个球在桌上,每个球都有价值,第i个球的价值是1^i+2^i+...+(p-1)^i (mod p).其中p是一个素数,之后逗比男先选球,最后所有球总分高的获胜.如果逗比男获胜,那么输出“YES”否则输出“NO”.(逗比男和逗比女都采取最有策略). 当然这也p是奇素数的一个重要公式.曾有题是这个公式求和.当然如果你知道就很简单了.如果不知道,就打表找规律吧. 根据这一重要的公

杭电 HDU 1037 Keep on Truckin&#39;

Keep on Truckin' Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 9881    Accepted Submission(s): 6859 Problem Description Boudreaux and Thibodeaux are on the road again . . . "Boudreaux, we hav

杭电 HDU ACM 1397 Goldbach&#39;s Conjecture

Goldbach's Conjecture Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4976    Accepted Submission(s): 1901 Problem Description Goldbach's Conjecture: For any even number n greater than or equal

杭电 HDU ACM 5186 zhx&#39;s submissions

zhx's submissions Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1892    Accepted Submission(s): 507 Problem Description As one of the most powerful brushes, zhx submits a lot of code on many

杭电 HDU ACM 1025 Constructing Roads In JGShining&#39;s Kingdom

Constructing Roads In JGShining's Kingdom Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 17732    Accepted Submission(s): 5023 Problem Description JGShining's kingdom consists of 2n(n is no mo