Grading

题目描述:

Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other,
a judge is invited to make the final decision. Now you are asked to write a program to help this process.

For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:

? A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem‘s grade will be the average of G1 and G2.

? If the difference exceeds T, the 3rd expert will give G3.

? If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem‘s grade will be the average of G3 and the closest grade.

? If G3 is within the tolerance with both G1 and G2, then this problem‘s grade will be the maximum of the three grades.

? If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

Each input file may contain more than one test case.

Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
代码
#include <iostream>
#include <stdio.h>
//#include <cmath>
#include <cstdlib>

using namespace std;

int main()
{
    int P,T,G1,G2,G3,GJ;
    float GF;
    while(scanf("%d %d %d %d %d %d",&P,&T,&G1,&G2,&G3,&GJ)!=EOF)
    {
        //cout << P << " "<<T<< " "<<G1<< " "<<G2<< " "<<G3<< " "<<GJ << endl;
        if(abs(G1-G2) <= T)
        {
            GF = (float)(G1*1.0 + G2*1.0) /2;
            printf("%.1lf\n",GF);
        } else if(abs(G3-G2) <= T && abs(G3-G1) <= T)
        {
            float temp;
            if(G1 > G2)
            {
                temp = G1;
                if(G1 < G3)
                    temp = G3;
            } else
            {
                temp = G2;
                if(G2 < G3)
                    temp = G3;
            }
           printf("%.1lf\n",temp);
        } else if(abs(G3-G2) <= T || abs(G3-G1) <= T)
        {
            if(abs(G3-G2) <= T)
            {
                GF = (float)(G3 + G2)/2;
                printf("%.1lf\n",GF);
            }
            if(abs(G3-G1) <= T)
            {
                GF = (float)(G3 + G1)/2;
                printf("%.1lf\n",GF);
            }
        } else
        {
            GF = (float)GJ;
            printf("%.1lf\n",GF);
        }
    }
    return 0;
}

注意:

printf("%.1lf\n",GF);若GF为整数则输出零 需要强制类型转换
时间: 2024-10-08 02:26:07

Grading的相关文章

uva 111 History Grading(DP初步应用)

uva 111 History Grading Many problems in Computer Science involve maximizing some measure according to constraints. Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all

题目1002:Grading(题目背景基于高考打分的简单判断)

题目链接:http://ac.jobdu.com/problem.php?pid=1002 详解链接:https://github.com/zpfbuaa/JobduInCPlusPlus 参考代码: // // 1002 Grading.cpp // Jobdu // // Created by PengFei_Zheng on 2017/4/14. // Copyright © 2017年 PengFei_Zheng. All rights reserved. // #include <st

九度oj 1002 Grading 2011年浙江大学计算机及软件工程研究生机试真题

1 #include<iostream> 2 #include<queue> 3 #include<cstdio> 4 #include<cstring> 5 #include<cmath> 6 #include<algorithm> 7 using namespace std; 8 int map[15][15]; 9 int main(){ 10 int P,T,G1,G2,G3,GJ; 11 while(cin>>P

九度OJ 1002 Grading

题目1002:Grading 时间限制:1 秒 内存限制:32 兆 特殊判题:否 提交:15686 解决:4053 题目描述: Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam pro

History Grading

uva111:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=47 题意:看懂之后就是求两个串的最长公共子串. 题解:不过这里要注意一下,就是题目中假如说第一个数是2,表示事件1应该放在第二个位子,这样转化一下就可以了.以前集训的时候也搞过这样的东西,但是年代久远,往事早已随风而去.今天复习了一下,发现很简单的

uva 101 History Grading

Background Many problems in Computer Science involve maximizing some measure according to constraints. Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events co

九度OJ刷题——1002:Grading

题目描述: Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to eac

UVA 111 History Grading (最长公共子序列)

History Grading Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Background Many problems in Computer Science involve maximizing some measure according to constraints. Consider a history exam in which students are asked to put s

《A computer-aided healthcare system for cataract classification and grading based on fundus image analysis》学习笔记

Abstract This paper presents a fundus image analysis based computer aided system for automatic classification and grading of cataract, which provides great potentials to reduce the burden of well-experienced ophthalmologists (the scarce resources) an