c之PAT刷体--字符串-01--从字符串中找到特定字符

字符串-01. 在字符串中查找指定字符(15)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

白洪欢(浙江大学)

输入一个字符串S,再输入一个字符c,要求在字符串S中查找字符c。如果找不到则输出“Not found”;若找到则输出字符串S中从c开始的所有字符。

输入格式:

输入在第1行中给出一个不超过80个字符长度的、以回车结束的非空字符串;在第2行中给出一个字符。

输出格式:

在一行中按照题目要求输出结果。

输入样例1:

It is a black box
b

输出样例1:

black box

输入样例2:

It is a black box
B

输出样例2:

Not found

编译器

C (gcc 4.7.2) C++ (g++ 4.7.2) 
Java (javac 1.6.0) Java (gcj 4.7) 
Pascal (fpc 2.6.0)

使用高级编辑器

代码


 1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24


#include <stdio.h>
#include <stdlib.h>
 
int main()
{
 
    char string[80];
    gets(string);
    char ch;
    scanf("%c",&ch);
    int fact=0;
    int i;
    for(i=0;string[i]!=‘\0‘;i++){
        if(string[i]==ch){
           fact=1;
           break;
        }
    }
    if(fact==1)
        for(int j=i;string[j]!=‘\0‘;j++)
            printf("%c",string[j]);
    else printf("Not found");
    return 0;
}

执行结果:

时间: 2024-11-16 14:22:24

c之PAT刷体--字符串-01--从字符串中找到特定字符的相关文章

*字符串-01. 在字符串中查找指定字符

1 /* 2 * Main.c 3 * D1-字符串-01. 在字符串中查找指定字符 4 * Created on: 2014年8月18日 5 * Author: Boomkeeper 6 *****部分通过****** 7 */ 8 9 #include <stdio.h> 10 11 int mysearch(char ch, const char str[], int length) { 12 13 int j, ret = -1; 14 15 for (j = 0; j < le

在字符串中删除特定字符

63.在字符串中删除特定的字符.题目:输入两个字符串,从第一字符串中删除第二个字符串中所有的字符.例如,输入”They are students.”和”aeiou”, 则删除之后的第一个字符串变成”Thy r stdnts.”. 思路: 1. 位图法 将两个字符串分别转换成bitmap 然后对他们做异或xor运算,得到的结果即为排除了第二个字符串的所有字符, 然后对该结果依次与原字符串的所有字符进行与运算,结果不为零的即为所得    恩 位图真是个好东西啊...时间复杂度o(n+m) 花在了遍历

字符串-01. 在字符串中查找指定字符(15)

输入一个字符串S,再输入一个字符c,要求在字符串S中查找字符c.如果找不到则输出“Not found”:若找到则输出字符串S中从c开始的所有字符. 输入格式: 输入在第1行中给出一个不超过80个字符长度的.以回车结束的非空字符串:在第2行中给出一个字符. 输出格式: 在一行中按照题目要求输出结果. 输入样例1: It is a black box b 输出样例1: black box 输入样例2: It is a black box B 输出样例2: Not found 1 #include <

Python基础练习-004-提取字符串中的特定字符

已知一个字符串"axbyczdq", 如何得到"abcd" 分析过程:取出奇数位的字符再拼接,但是在python中,index从0开始,所以取偶数位.(学习重点:字符串与列表之间的相互转换) 原文地址:https://www.cnblogs.com/piaopiao-emmm/p/10064606.html

java 删除字符串中的特定字符

/** * Delete any character in a given String. * @param inString the original String * @param charsToDelete a set of characters to delete. * E.g. "az\n" will delete 'a's, 'z's and new lines. * @return the resulting String */ public static String

【lua】lua string.match 和 string.split 从字符串中寻找特定字符串并保存

local string = "{1,2,3,4}" local traString=string.match(string , "%d+,%d+,%d+,%d+") --此时tranString = "1,2,3,4",去掉"{","}" string = string.split(tranString , ",") string = {1,2,3,4} string[1]=1 str

java去除字符串中的特定字符

public static void updateFileNames(String url, String index){ File file = new File(url); //判断文件目录是否存在,且是文件目录,非文件 if(file.exists() && file.isDirectory()){ File[] childFiles = file.listFiles(); String path = file.getAbsolutePath(); for(File childFil

poj3650---将一个字符串中的特定字符转换

#include <stdio.h> #include <stdlib.h> #include<string.h> int main() { char str[100]; int i; while(gets(str) != NULL) { if(str[0] == '#') break; for(i=0 ;i < strlen(str); i++) { if(str[i] == ' ') printf("%%20"); else if(str[

DOS命令(cmd)批处理:替换字符串、截取字符串、扩充字符串、获取字符串长度

1.替换字符串,即将某一字符串中的特定字符或字符串替换为给定的字符串.举例说明其功能:========================================= @echo off set aa=伟大的中国!我为你自豪! echo 替换前:%aa% echo 替换后:%aa:中国=中华人民共和国% echo aa = %aa% set "aa=%aa:中国=中华人民共和国%" echo aa = %aa% pause ==============================