HDU 1050 Moving Tables (贪心)

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20302    Accepted Submission(s): 6889

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains
two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50 

Sample Output

10
20
30

Source

Asia 2001, Taejon (South Korea)

解题思路:贪心,考虑每次的最优解,则对面的两房间共同拥有它们所对应的区域,每次交错,都会产生一次冲突,就代表他们不能再同一次搬运,考虑到多次转移的交错的区域,最大交错的次数就代表了最小的搬运次数。

AC代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;

int room[205];

int main(){
//    freopen("in.txt", "r", stdin);
    int t, n, x, y;
    scanf("%d", &t);
    while(t--){
        memset(room, 0, sizeof(room));
        scanf("%d", &n);
        for(int i=0; i<n; i++){
            scanf("%d%d", &x, &y);
            if(x > y) swap(x, y);          //防止起始房间大于终止房间
            for(int i=(x+1)/2; i<=(y+1)/2; i++){
                room[i] ++;                //对应区域的交错次数增加
            }
        }
        int ans = 0;
        for(int i=1; i<=201; i++){
            if(ans < room[i])  ans = room[i];
        }
        printf("%d\n", ans*10);
    }
    return 0;
}
时间: 2024-08-08 01:29:12

HDU 1050 Moving Tables (贪心)的相关文章

--hdu 1050 Moving Tables(贪心)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050 AC code: #include<stdio.h> #include<string.h> int m[210]; int main(void) { int t,n,i,j,st,en,ma; scanf("%d",&t); while(t--) { memset(m,0,sizeof(m)); scanf("%d",&n)

HDU 1050 Moving Tables

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 23044    Accepted Submission(s): 7749 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a

HDU 1050.Moving Tables【细节与方法选取】【8月26】

Moving Tables Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. The floor has 200 rooms each on the north side and south side along the corridor. Recently the

HDU 1050 Moving Tables(贪心)

Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made

hdu 1050 Moving Tables(迷之贪心...)

题意:有400间房间按题目中图片所给的方式排列,然后给出要移动的n张桌子所要移动的范围,每张桌子要移动的范围不能出现重叠的区域:问最少要多少次才能移动完所有的桌子. 题解思路:把题目转换下,就是有n个区间,每次可以去除掉k个没有重叠部分的区间,最少要多少次能去掉所有区间.妥妥的,,贪心.可能会有人联想到经典的"区间调度问题".但很遗憾,在这里行不通:区间调度问题是按区间右端排序后尽可能选取结束时间早的,但这种贪心只是一次性选取尽可能多的区间,而本题是要求选取完所有区间所要花费次数最少.

贪心/Hdu 1050 Moving Tables

#include<cstdio> #include<cstring> using namespace std; int a[220]; int cmax(int a,int b){return a>b?a:b;} int main() { int T; scanf("%d",&T); for (int t=1;t<=T;t++) { int n; scanf("%d",&n); int x,y,xx,yy; int

hdoj 1050 moving tables

代码: #include <iostream> #include <algorithm> //#include <fstream> using namespace std; int f[201]; int main() { //ifstream cin("1050_input.txt");   //调试用 int t, n, i, j, s, e; cin >> t; while( t-- ){ memset( f, 0, sizeof(

HDOJ 1050 Moving Tables(经典贪心)

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 24553    Accepted Submission(s): 8116 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a

hdoj 1050 Moving Tables【贪心区间覆盖】

Moving Tables Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24316    Accepted Submission(s): 8053 Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a b