AC日记——求10000以内n的阶乘 openjudge 1.6 14

14:求10000以内n的阶乘

总时间限制: 
5000ms

内存限制: 
655360kB
描述

求10000以内n的阶乘。

输入
只有一行输入,整数n(0<=n<=10000)。
输出
一行,即n!的值。
样例输入
100
样例输出
93326215443944152681699238856266700490715968264381621468592963895217599993229915608941463976156518286253697920827223758251185210916864000000000000000000000000
来源
JP06

思路:

  模拟;

来,上代码:

#include<cstdio>

using namespace std;

int n,len,cur=1,s[500010];

int main()
{
    scanf("%d",&n);
    len=0;
    s[0]=1;
    for(int v=2;v<=n;v++)
    {
        for(int i=0;i<=len;i++) s[i]*=v;
        cur=0;
        for(int i=0;i<=len;i++)
        {
            s[i]+=cur;
            cur=0;
            if(s[i]>9) cur+=s[i]/10;
            s[i]%=10;
        }
        while(cur>0) s[++len]=cur%10,cur/=10;
    }
    for(int i=len;i>=0;i--) putchar(s[i]+‘0‘);
    return 0;
}
时间: 2024-12-10 09:34:04

AC日记——求10000以内n的阶乘 openjudge 1.6 14的相关文章

openjudge 14:求10000以内n的阶乘

14:求10000以内n的阶乘 总时间限制: 5000ms 内存限制: 655360kB 描述 求10000以内n的阶乘. 输入 只有一行输入,整数n(0<=n<=10000). 输出 一行,即n!的值. 样例输入 100 样例输出 93326215443944152681699238856266700490715968264381621468592963895217599993229915.... 1 #include <algorithm> 2 #include <bit

求10000以内n的阶乘(openjudge 2923)

求10000以内n的阶乘 总时间限制:  5000ms 内存限制:  655360kB 描述 求10000以内n的阶乘. 输入 只有一行输入,整数n(0<=n<=10000). 输出 一行,即n!的值. 样例输入 100 样例输出 9332621544394415268169923885626670049071596826438162146859296389521759999322991560894146397615651828625369792082722375825118521091686

求10000以内n的阶乘

总时间限制:  5000ms 内存限制:  655360kB 描述 求10000以内n的阶乘. 输入 只有一行输入,整数n(0<=n<=10000). 输出 一行,即n!的值. 样例输入 100 样例输出 93326215443944152681699238856266700490715968264381621468592963895217599993229915608941463976156518286253697920827223758251185210916864000000000000

1172:求10000以内n的阶乘

传送门:http://ybt.ssoier.cn:8088/problem_show.php?pid=1172 [题目描述] 求10000以内n的阶乘. [输入] 只有一行输入,整数n(0≤n≤10000). [输出] 一行,即n!的值. [输入样例] 4 [输出样例] 24 直接乘去就OK了 #include<iostream> #include<cstring> #define N 100010 using namespace std; int n,a[N],lena=1; i

求10000以内质数(以前都是直接打表,现在问到怎么求,瞬间词穷了,还是应该搞懂)

对于求10000以内质数,首先先考虑这个确定性范围的问题,后面再考虑复杂的. 前言摘抄:素数是除了1和它本身之外再不能被其他数整除的自然数.由于找不到一个通项公式来表示所有的素数,所以对于数学家来说, 素数一直是一个未解之谜.像著名的 哥德巴赫猜想.孪生素数猜想,几百年来不知吸引了世界上多少优秀的数学家.尽管他们苦心钻研,呕心沥血,但至今仍然未见分晓. 自从有了计算机之后,人们借助于计算机的威力,已经找到了2216091以内的所有素数. 求素数的方法有很多种,最简单的方法是根据素数的定义来求.对

筛法求10000以内的质数

#include<stdio.h>#define N 10000int main(){ int i,j,a[N]; for(i=2;i<N;i++) a[i]=1; for(i=2;i<N;i++) if(a[i]) for(j=i;i*j<N;j++) a[i*j]=0; for(i=2;i<N;i++) if(a[i]) printf("%d\t",i); return 0;}

求10000以内的素数

#include "iostream" #include "cmath" #include "memory.h" using namespace std; const int Max = 10000; bool numbers[Max]; void searchprime(){ memset(numbers, true, sizeof(numbers)); for (int i = 2; i < sqrt(Max) + 1; i++){ i

AC日记——判断字符串是否为回文 openjudge 1.7 33

33:判断字符串是否为回文 总时间限制:  1000ms 内存限制:  65536kB 描述 输入一个字符串,输出该字符串是否回文.回文是指顺读和倒读都一样的字符串. 输入 输入为一行字符串(字符串中没有空白字符,字符串长度不超过100). 输出 如果字符串是回文,输出yes:否则,输出no. 样例输入 abcdedcba 样例输出 yes 思路: 模拟: 来,上代码: #include<cstdio> #include<string> #include<cstring>

Python练习题 048:Project Euler 021:10000以内所有亲和数之和

本题来自 Project Euler 第21题:https://projecteuler.net/problem=21 ''' Project Euler: Problem 21: Amicable numbers Let d(n) be defined as the sum of proper divisors of n (numbers less than n which divide evenly into n). If d(a) = b and d(b) = a, where a ≠ b