Lab - MPLS VPN Configuration

MPLS show commads:

comands Description
show ip cef 查看cef LIB
show ip cef summary  
show ip cef vrf XXX detail  
show cef interface  
show adjacency detail  
show mpls interfaces  
show mpls interfaces detail  
show mpls forwarding-table  
show mpls forwarding-table x.x.x.x detail  
show mpls forwarding-table labels xx [detail]  
show mpls ldp discovery  
show mpls ldp neighbor  
show mpls ldp bindings  
show mpls ldp parameters  
show ip vrf interfaces  
show ip vrf detail xxx  
show ip protocols vf xxx  
show ip route vrf xxx  
show ip eigrp vrf xxx interfaces  
show ip eigrp vrf xxx neighbors  
show ip eigrp vrf xxx topology  
show ip eigrp vrf xxx traffic  
show ip bgp vpnv4 vrf xxx labels  
show ip pim mdt bgp  

Step 1: 配置IP地址与接口

Step 2:MPLS域启用IGP OPSF 协议

R3(config)#router ospf 1
R3(config-router)#network 10.10.3.3 0.0.0.0 area 0
R3(config-router)#network 1.1.34.3 0.0.0.0 area 0

R4(config)#router ospf 1
R4(config-router)#network 10.10.4.4 0.0.0.0 area 0
R4(config-router)#network 1.1.34.4 0.0.0.0 area 0
R4(config-router)#network 1.1.45.4 0.0.0.0 area 0

R5(config)#router ospf 1
R5(config-router)#network 1.1.45.5 0.0.0.0 area 0
R5(config-router)#network 10.10.5.5 0.0.0.0 area 0

且OSPF, Loopback 0 接口网络类型改成point-to-point

R1,R2,R3
interface loopback 0
ip ospf network point-to-point
R3#show ip route ospf
     1.0.0.0/24 is subnetted, 2 subnets
O       1.1.45.0 [110/128] via 1.1.34.4, 00:21:43, Serial1/2
     10.0.0.0/24 is subnetted, 3 subnets
O       10.10.4.0 [110/65] via 1.1.34.4, 00:22:27, Serial1/2
O       10.10.5.0 [110/129] via 1.1.34.4, 00:21:33, Serial1/2

Step 3: MPLS域内运行CEF, 相关接口开启MPLS转发, 修改MPLS的MTU 1512

R3(config)#ip cef
R3(config)#interface s1/2
R3(config-if)#mpls ip
R3(config-if)#mpls mtu 1512

R4(config)#ip cef
R4(config-if)#interface s1/2
R4(config-if)#mpls ip
R4(config-if)#mpls mtu 1512
R4(confg-if)#interface s1/0
R4(config-if)#mpls ip
R4(config-if)#mpls mtu 1512

R5(config)#ip cef
R5(config)#interface s1/0
R5(config-if)#mpls ip
R5(config-if)#mpls mtu 1512

step 4: 配置PE-CE端的连接

R1(config)#router rip

R1(config-router)#no auto-summary

R1(config-router)#version 2

R1(config-router)#netwrok 1.0.0.0

R1(config-router)#network 10.0.0.0

R2(config)#router eigrp 1

R2(config-router)#no auto-summary

R2(config-router)#network 1.1.23.2 0.0.0.0

R2(config-rotuer)#netwrok 10.10.2.2 0.0.0.0

R3(config)#ip vrf CompanyA

R3(config-vrf)#rd 1:1

R3(config-vrf)#router-target 1:1

R3(config)#interface s1/0

R3(config-if)#ip vrf forwarding CompanyA

% Interface Serial1/0 IP address 1.1.13.3 removed due to enabling VRF CompanyA

R3(config-if)#ip address 1.1.13.3 255.255.255.0

R3(config-if)#no shutdown

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#no auto-summary

R3(config-router)#network 1.0.0.0

R3(config)#ip vrf CompanyB

R3(config-vrf)#rd 2:1

R3(config-vrf)#route-target 2:1

R3(config)#interface s1/1

R3(config-if)#ip vrf forwarding CompanyB

% Interface Serial1/1 IP address 1.1.23.3 removed due to enabling VRF CompanyB

R3(config-if)#ip address 1.1.23.3 255.255.255.0

R3(config-if)#no shutdown

R3(config)#router eigrp 1

R3(config-router)#no auto-summary

R3(config-router)#network 1.1.23.3 0.0.0.0

R6(config)#router rip

R6(config-router)#no auto-summary

R6(config-router)#version 2

R6(config-router)#netwrok 1.0.0.0

R6(config-router)#network 10.0.0.0

R7(config)#router eigrp 1

R7(config-router)#no auto-summary

R7(config-router)#network 1.1.57.7 0.0.0.0

R7(config-router)#network 10.10.7.7 0.0.0.0

R5(config)#ip vrf ComapnyA

R5(config-vrf)#rd 1:1

R5(config-vrf)#route-target 1:1

R5(config)#interface s1/1

R5(config-if)#ip vrf forwarding CompanyA

% Interface Serial1/1 IP address 1.1.56.5 removed due to enabling VRF CompanyA

R5(config-if)#ip address 1.1.56.5 255.255.255.0

R5(config-if)#no shutdown

R5(config)#router rip

R5(config-router)#no auto-summary

R5(config-router)#version 2

R5(config-router)#address-family ipv4 vrf CompanyA

R5(config-router)#version 2

R5(config-router)#no auto-summary

R5(config-router)#network 1.0.0.0

R5(config)#ip vrf CompanyB

R5(config-vrf)#rd 2:1

R5(config-vrf)#route-target 2:1

R5(config)#interface s1/2

R5(config-if)#ip vrf forwarding CompanyB

% Interface Serial1/2 IP address 1.1.57.5 removed due to enabling VRF CompanyB

R5(config-if)#ip add 1.1.57.5 255.255.255.0

R5(config-if)#no shutdown

R5(config)#router eigrp 1

R5(config-router)#no auto-summary

R5(config-router)#address-family ipv4 vrf CompanyB

R5(config-router-af)#no auto-summary

R5(config-router-af)#network 1.1.57.5 0.0.0.0

Step 5: 创建MP-BGP路由用来传输VPNv4

R3(config)#router bgp 1

R3(config-router)#no auto-summary

R3(config-router)#no synchronization

R3(config-router)#neighbor 10.10.5.5 remote-as 1

R3(config-router)#neighbor 10.10.5.5 update-source loopback 0

R3(config-router)#address-family vpnv4

R3(config-router)#neighbor 10.10.5.5 active

R3(config-router)#neighbor 10.10.5.5 send-community

R5(config)#router bgp 1

R5(config-router)#no auto-summary

R5(config-router)#no synchronization

R5(config-router)#neighbor 10.10.3.3 remote-as 1

R5(config-router)#neighbor 10.10.3.3 update-source loopback 0

R5(config-router)#address-family vpnv4

R5(config-router)#neighbor 10.10.3.3 active

R5(config-router)#neighbor 10.10.3.3 send-community

Step 6: 相互重分布路由

R3(config)#router rip

R3(config-router)#address-family ipv4 vrf CompanyA

R3(config-router)#redistribute bgp 1 metric transparent

R3(config)#router bgp 1

R3(config-router)#address-family ipv4 vrf CompanyA

R3(config-router)#redistribute rip

R5(config)#router rip

R5(config-router)#address-family ipv4 vrf CompanyA

R5(config-router)#redistribute bgp 1 metric transparent

R5(config)#router bgp 1

R5(config-router)#address-family ipv4 vrf CompanyA

R5(config-router)#redistribute rip

时间: 2024-10-10 09:44:05

Lab - MPLS VPN Configuration的相关文章

LAB - MPLS VPN PE1-P-PE2 之间OSPF && PE-CE之间静态路由

LAB - MPLS VPN PE1-P-PE2 之间OSPF && PE-CE之间静态路由 Topology Step 1: Configure IP address Step 2:配置MPLS域内的IGP - OSPF R2(config)#router ospf 1 R2(config-router)#network 1.1.23.2 0.0.0.0 area 0 R2(config-router)#network 10.10.2.2 0.0.0.0 area 0R2(config)

IPv6/IPv4双栈的MPLS VPN——6VPE实战部署(华为和思科大融合)

个人理解,6VPE(IPv6VPN Provider Edge)是承载IPv6的MPLSVPN,是在保持原有MPLS BGPv4骨干不做大变动的情况下,一种IPv6 MPLS VPN过渡技术.基本部署步骤如下:PE与CE之间存在IPv6 VRF,建立BGPv6的邻居关系:PE与RR之间可以建立IPv6的BGP邻居关系,也可以建立IPv4邻居关系,同步复制VPNv4地址族到VPNv6地址族中,其他配置跟IPv4的MPLS VPN没有什么大区别. 以下为实验室测试环境下部署6VPE案例实战分析: 环

BGP/MPLS VPN之总结

一 MPLS技术基础 1.MPLS利用已有的路由信息建立虚连接---基于标签的转发路径,提高了转发效率,在面向无连接的IP网络增加了连接的属性,为IP网络提供了一定Qos保证,满足不同类型服务队Qos的要求. 2.(1)MPLS网络路由器分为两种角色,分别是LSR(标签交换路由器),LER(标签交换边缘路由器) (2)FEC(转发等价类):一组具备某些共同特征的数据流被MPLS网络看做同一类报文,进入MPLS网络时,被LER执行相同的标签映射,从而在整个MPLS网络中被看做是同一种报文,并以等价

MPLS VPN原理及配置思路

VPN中的角色: CE/PE/P overlay vpn:隧道建立在CE上 在ce和ce之间建立隧道,并直接传递路由信息.典型代表是GRE.IPSEC overlay vpn:隧道建立在pe上 在pe上为每一个vpn用户建立相应的GRE隧道,路由信息在pe和pe之间传递. 不同的vpn用户不能共享相同的地址空间,并且需要大量的ACL和策略路由,在实际中不具备可行性 overlay vpn的本质是一种静态vpn 1,所有的配置与部署都需要手工完成 2,由于是静态vpn,则无法反应网络的实时变化 p

MPLS VPN

目标:配置MPLS VPN 配置思路: R3,R5,R6,R4为运营商网络,配置MPLS,IGP协议为ospf 110,R3和R4配置为IBGP邻居,R1和R2为位于两地的同一公司A的子公司,R7和R8同样是位于两地的同一公司B的子公司,在R3上为每个子公司R1,R7启用vrf,并将相关接口加入相应vrf(比如,vrf 1 关连R3的s1/1口),R1与R3之间静态路由,R2与R4之间静态路由,在R4上为每个子公司R2,R8启用vrf,并将相关接口加入相应vrf,R7与R3之间启用ospf 协议

MPLS VPN Case1

如下图示: 实验目标:CE1和CE2的Loopback0互通.实验环境:1.P.PE1和PE2是运营商路由器.CE1和CE2是VPN用户.2.P.PE1和PE2运行OSPF 进程号1 Area 0.3.PE1和PE2为iBGP AS 1.4.CE1和CE2采用RIP V2. 实验步骤:1.在P.PE1和PE2路由器启用ip cef.2.在P.PE1和PE2路由器的互连接口启用mpls ip3.在P.PE1和PE2配置ospf 1.4.查看mpls vpn相关命令:show mpls ldp ne

什么是MPLS VPN ?

一.什么是MPLS VPN MPLS VPN是可管理的IP虚拟专用网络服务 (IP VPN),采用先进的多协议标签交换(MPLS)技术,将企业分布在不同地点的办事处及设备通过安全可靠.高效率的虚拟专用网络连接起来,实现数据.语音.视频传输或其他重要网络应用,兼具服务品质(QOS)保证. 二.产品特点 立足用户需求,通过成熟的技术手段,为企业客户提供"一站式"网络应用.信息增值.电子商务服务等数据通信整体解决方案 说明①:MPLS VPN是局域网解决方案,因此主要解决的是企业内部办公和I

MPLS VPN 之CE运行OSPF

实验拓扑图 实验描述:PE-R1.P-R2.PE-R3运行的IGP为OSPF,所属area 0,且运行MPLS,PE-R1.PE-R3配置MP-BGP,CE-R5.CE-R7路由器与PE路由器运行OSPF协议,且属于骨干区域0,配置MPLS VPN实现CE-R5与CE-R7互通: 一.PE-R1与PE-R3对于VRF Ting运行不同的OSPF进程时,对CE端的OSPF路由情况分析 部份配置如下: PE-R1: router ospf 12 vrf Ting redistribute bgp 1

L3 MPLS VPN InterAS Option A: Back-to-Back VRFs

Back-to-Back VRFs 优点: 配置思路简单,跟普通的域内MPLS VPN没有太多区别: 缺点: 在ASBR上需要有各个VRF,需要保存全网的VPNv4路由,ASBR之间需要多个接口分别划进每个VRF里.ASBR负担较重. 配置说明: 端口连接规律:RN E0/0 -- R(N+1)0/1 PE跟CE起OSPF协议,AS内部IGP使用EIGRP,ASBR之间使用RIP协议: CE端R1配置案例: hostname R1 interface Loopback0 ip address 1