求大神指点这个程序格式错在哪里了。

杭电1002题
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input

2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

这个是我的程序代码
#include <stdio.h>
#include <string.h>
int main ()
{
    char a[21][1001],b[21][1001];
    int c[21][2001]={{0}};
    int k[21]={0};
    int n,i,p,q,t,m;
    scanf ("%d",&n);
    for (i=1;i<=n;i++)
    {
        scanf ("%s %s",a[i],b[i]);
        p=strlen(a[i])-1;
        q=strlen(b[i])-1;
        while ((p>=0)&&(q>=0))
        {
            if(((a[i][p]-‘0‘)+(b[i][q]-‘0‘)+c[i][k[i]])>=10)
            {
                c[i][k[i]]=(a[i][p]-‘0‘)+(b[i][q]-‘0‘)+c[i][k[i]]-10;
                c[i][k[i]+1]++;
            }
            else
            c[i][k[i]]=a[i][p]-‘0‘+b[i][q]-‘0‘+c[i][k[i]];
            k[i]++;
            p--;
            q--;
        }

if (p>=0)
        {
            for (t=p;t>=0;t--)
            {
                c[i][k[i]]=(a[i][t]-‘0‘)+c[i][k[i]];
                k[i]++;
            }
        }
        else if (q>=0)
        {
            for (t=q;t>=0;t--)
            {
                c[i][k[i]]=(b[i][t]-‘0‘)+c[i][k[i]];
                k[i]++;
            }
        }
        if (c[i][k[i]]!=0)
        k[i]++;
  }
        for (i=1;i<=n;i++)
        {
          printf ("Case %d:\n",i);
          printf ("%s + %s = ",a[i],b[i]);
          for (m=k[i]-1;m>=0;m--)
          printf("%d",c[i][m]);
          if(i<n)
          printf ("\n\n");
        }
    return 0;
}

时间: 2024-10-06 01:06:05

求大神指点这个程序格式错在哪里了。的相关文章

水仙花问题求大神指点哪里有错!

6y4ys4姑窍星夏郊目<http://weibo.com/p20180413Pp/230927983240056418340864> h7pk9y眉皆牢梁皆悍<http://weibo.com/RnDShp/230927983077305872031744> h2bhnn拔诚浅任镜簇<http://weibo.com/20180413p/230927982948654052548608> w5ffv0淳汛运澜雷俣<http://weibo.com/UsitJp/

dll注册到GAC还是bin - 跪求大神指点 - sharepoint程序

通常来说程序在使用dll的时候,会先去GAC中查找是否有存在合适的dll,然后才会到应用程序下的bin目录去查找: 前几天遇到了一个奇葩问题,web项目工程添加了一个第三方dll的引用,然后把这个第三方的dll注册到了GAC里面,但是web程序在运行时,报错程序集未引用:然后就在bin目录下也copy了一份dll,然后程序就OK了:但是这个情况推翻了上面的逻辑,于是进行了多次测试修改,终于发现,如果在前台页面(aspx页面)中调用了第三方dll中的方法(<%%>的方式调用),则此第三方dll就

ssh2整合: No bean named &#39;sessionFactory&#39; is defined(求大神指点)

applicationContext.xml 中已经配置 <bean id="sessionFactory" class="org.springframework.orm.hibernate3.LocalSessionFactoryBean"> <property name="dataSource" ref="dataSource"/> <property name="hibernate

自己封装了一个EF的上下文类.,分享一下,顺便求大神指点

using System; using System.Collections.Generic; using System.Configuration; using System.Data; using System.Data.Entity; using System.Data.Entity.Core.Objects; using System.Data.Entity.Infrastructure; using System.Data.Entity.Migrations; using System

最近学到的知识概述,求大神指点后续的路该怎么规划

求大神指导迷津: 前端的路,已经走了一年多了,从懵懂地编码到现在的熟悉的操作,学会使用了svn.git.webstrom这些版本控制和开发软件,尤其是当学会用webstrom进行git提交代码时,才很惊喜的发现,学会使用好用的工具可以节省很多时间,大大提升工作的效率![工具很重要]. 在搭建好的框架下,去开发设计好的网页图,对我来说都是没问题的了,前段时间,在没有人指导的情况下,自己摸索着在现有的框架下,调用ztree完成一个功能,包括API接口该如何设计.保存后如何向后台传数据.[自学能力在成

页面显示多个计时器,有开始暂停按钮来控制倒计时的开关????求大神指点

是这样的,项目需要一个这样的效果我先上个图 需求是这样的,从数据库获取来的列表,组装时间换算成分钟,点击开始时换算成时分秒的格式倒计时,点击暂停按钮停止倒计时,向后台发送原因,可以开启多个倒计时,可以暂停任意一个,还可以点击开始后继续倒计时, 大神们,这可真难着了,这到底该怎么玩呢??? 这个需求是销售公司规定员工在规定时间内完成组装便可以得到奖励金,超过便没有,该怎么实现呢???

蓝桥杯 历届试题 约数倍数选卡片 求大神指点 首先声明,我的代码有问题!不喜勿进,若有意向,可以讨论,我百度不到这道题的题解

历届试题 约数倍数选卡片 时间限制:1.0s   内存限制:256.0MB 问题描述 闲暇时,福尔摩斯和华生玩一个游戏: 在N张卡片上写有N个整数.两人轮流拿走一张卡片.要求下一个人拿的数字一定是前一个人拿的数字的约数或倍数.例如,某次福尔摩斯拿走的卡片上写着数字"6",则接下来华生可以拿的数字包括: 1,2,3, 6,12,18,24 .... 当轮到某一方拿卡片时,没有满足要求的卡片可选,则该方为输方. 请你利用计算机的优势计算一下,在已知所有卡片上的数字和可选哪些数字的条件下,怎

获取网络时间失败,求大神指点

private void GainTime() { new Thread(new Runnable() { @Override public void run() { try { URL url=new URL("http://www.taobao.com"); URLConnection uc=url.openConnection(); uc.connect(); long id=uc.getDate(); Date date=new Date(id); SimpleDateForm

这个程序词索引表的程序 求大神指点错误在哪里

#include < stdio.h >#include < stdlib.h >#include < string.h >#define TRUE 1#define FALSE 0#define OK 1#define ERROR 0#define OVERFLOW -1#define MaxBookNum 1000 //假设只对1000本书建立索引表#define MaxKeyNum 2500 //索引表的最大容量#define MaxLineLen 500 //书