A1088. Rational Arithmetic (20)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;

//求最大公约数
long long gcd (long long a,long long b)
{
  if(b==0)return a;
  else
  {
  return gcd(b,a%b);
  }

} 

 struct Fraction{
     long long up,down;
     }a,b;

Fraction reduction (Fraction res)
{
    if(res.down<0)
    {
        res.up=-1*res.up;
        res.down=-1*res.down;
    }
    if(res.up==0)
    {
        res.down=1;
        }else
        {
        int d=gcd(abs(res.up),abs(res.down));
        res.up/=d;
        res.down/=d;
        }
     return res;
}     

Fraction add(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.down;
    res.up=a.up*b.down+a.down*b.up;
    return reduction(res);
    }
Fraction minusF(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.down;
    res.up=a.up*b.down-a.down*b.up;
    return reduction(res);
    }
Fraction multi(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.down;
    res.up=a.up*b.up;
    return reduction(res);
    }

Fraction divide(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.up;
    res.up=a.up*b.down;
    return reduction(res);
    }

void show(Fraction r)
{
    r=reduction(r);
    if(r.up<0)
    {
      printf("(");
    }
    if(r.down==1)printf("%lld",r.up);
    else if(abs(r.up)>r.down)
    {
      printf("%lld %lld/%lld",r.up/r.down,abs(r.up)%r.down,r.down);
    }else
    {
       printf("%lld/%lld",r.up,r.down);
    }
    if(r.up<0)
    {
      printf(")");
    }  

}
int main(int argc, char* argv[])
{

    scanf("%lld/%lld %lld/%lld",&a.up,&a.down,&b.up,&b.down);
    show(a);printf(" + ");show(b);printf(" = ");show(add(a,b));printf("\n");
    show(a);printf(" - ");show(b);printf(" = ");show(minusF(a,b));printf("\n");
    show(a);printf(" * ");show(b);printf(" = ");show(multi(a,b));printf("\n");
    show(a);printf(" / ");show(b);printf(" = ");

    if(b.up==0)printf("Inf");
    else show(divide(a,b));printf("\n");
    system("pause");
    return 0;
}
时间: 2024-10-13 13:37:26

A1088. Rational Arithmetic (20)的相关文章

1088. Rational Arithmetic (20)——PAT (Advanced Level) Practise

题目信息 1088. Rational Arithmetic (20) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient. Input Specification: Each input fi

pat1088. Rational Arithmetic (20)

1088. Rational Arithmetic (20) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient. Input Spe

1088. Rational Arithmetic (20)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient. Input Specification: Each input file contains one test case, which gives in one line the two rational number

A.1088 Rational Arithmetic (20)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient. Input Specification: Each input file contains one test case, which gives in one line the two rational number

A1088.Rational Arithmetic

题意 模拟分数的四则运算 思路分析 模拟,在输出过程中,若分子>分母,需要分离出整数部分与分数部分,并且如果项为负数需要带上() #include <bits/stdc++.h> using namespace std; typedef long long ll; struct fraction{ ll up; //分子 ll down; //分母 }a,b,result; ll gcd(ll a,ll b){ if(b == 0) return a; else return gcd(b

PAT (Advanced Level) 1088. Rational Arithmetic (20)

简单题. 注意:读入的分数可能不是最简的.输出时也需要转换成最简. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<iostream> #include<algor

PAT甲题题解-1088. Rational Arithmetic (20)-模拟分数计算

输入为两个分数,让你计算+,-,*,\四种结果,并且输出对应的式子,分数要按带分数的格式k a/b输出如果为负数,则带分数两边要有括号如果除数为0,则式子中的结果输出Inf模拟题最好自己动手实现,考验细节处理,其它没啥好说的. #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> using namespace std; long long numerato

1081. Rational Sum (20)【模拟】——PAT (Advanced Level) Practise

题目信息 1081. Rational Sum (20) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum. Input Specification: Each input file contains one test case. Each case star

pat1081. Rational Sum (20)

1081. Rational Sum (20) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum. Input Specification: Each input file contains one