hdoj 1035 Robot Motion

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7974    Accepted Submission(s):
3685

Problem Description

A robot has
been programmed to follow the instructions in its path. Instructions for the
next direction the robot is to move are laid down in a grid. The possible
instructions are

N north (up the page)
S south (down the page)
E
east (to the right on the page)
W west (to the left on the page)

For
example, suppose the robot starts on the north (top) side of Grid 1 and starts
south (down). The path the robot follows is shown. The robot goes through 10
instructions in the grid before leaving the grid.

Compare what happens in
Grid 2: the robot goes through 3 instructions only once, and then starts a loop
through 8 instructions, and never exits.

You are to write a program that
determines how long it takes a robot to get out of the grid or how the robot
loops around.

Input

There will be one or more grids for robots to navigate.
The data for each is in the following form. On the first line are three integers
separated by blanks: the number of rows in the grid, the number of columns in
the grid, and the number of the column in which the robot enters from the north.
The possible entry columns are numbered starting with one at the left. Then come
the rows of the direction instructions. Each grid will have at least one and at
most 10 rows and columns of instructions. The lines of instructions contain only
the characters N, S, E, or W with no blanks. The end of input is indicated by a
row containing 0 0 0.

Output

For each grid in the input there is one line of output.
Either the robot follows a certain number of instructions and exits the grid on
any one the four sides or else the robot follows the instructions on a certain
number of locations once, and then the instructions on some number of locations
repeatedly. The sample input below corresponds to the two grids above and
illustrates the two forms of output. The word "step" is always immediately
followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5

NEESWE

WWWESS

SNWWWW

4 5 1

SESWE

EESNW

NWEEN

EWSEN

0 0

Sample Output

10 step(s) to exit

3 step(s) before a loop of 8 step(s)

做题时两个地方被坑到:

1、刚开始的时候横纵坐标搞反了

2、输出的结果错误后来发现输入的时候数组是从0开始的而在搜索判断中却是从数组中1 开始判断

#include<stdio.h>
#include<string.h>
#define MAX 110
char map[MAX][MAX];//所要走的地图
int vis[MAX][MAX];//用来记录当前走了多少步
int n,m,t;
int x2,y2;//用于记录当前步的上一步
void dfs(int x1,int y1)
{
	if(x1>n||x1<1||y1<1||y1>m)//如果超出地图范围则证明已经走出去了
	{
		printf("%d step(s) to exit\n",vis[x2][y2]);
		return ;
	}
	else if(vis[x1][y1])//如果不为0则证明此处已经走过形成环
	{
		printf("%d step(s) before a loop of %d step(s)\n",vis[x1][y1]-1,vis[x2][y2]-vis[x1][y1]+1);
	    return ;
	}
	vis[x1][y1]=vis[x2][y2]+1;//当前走的步数是上一步加1
	x2=x1;y2=y1;
	if(map[x1][y1]==‘W‘)//向左走
	y1-=1;
	else if(map[x1][y1]==‘S‘)//向下走
	x1+=1;
	else if(map[x1][y1]==‘E‘)//向右走
	y1+=1;
	else if(map[x1][y1]==‘N‘)//向上走
	x1-=1;
	dfs(x1,y1);
}
int main()
{
	int j,i,s,k;
	int x1,x2,y1,y2;
	while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
	{
		scanf("%d",&t);
		for(i=1;i<=n;i++)
		{
			getchar();
			for(j=1;j<=m;j++)
			{
				scanf("%c",&map[i][j]);
			}
		}
	    x1=1;y1=t;//起点
	    x2=x1;y2=y1;
	    memset(vis,0,sizeof(vis));//数组清零
	    dfs(x1,y1);
	}
	return 0;
}

  

时间: 2024-10-01 16:22:30

hdoj 1035 Robot Motion的相关文章

HDU 1035 Robot Motion Union Find 并查集题解

本题的类型我一看就想到使用并查集解了,因为要查找是否有环,这是并查集的典型用法. 但是由于本题数据实在是太水了,故此有人使用直接模拟都过了.这让本题降了个档次. 这里使用并查集解.而且可以根据需要简化并查集函数,代码还是很好打的. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include &l

HDOJ 题目1035 Robot Motion(模拟)

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7372    Accepted Submission(s): 3389 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

[ACM] hdu 1035 Robot Motion (模拟或DFS)

Robot Motion Problem Description A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are N north (up the page) S south (down t

杭电 HDU 1035 Robot Motion

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7488    Accepted Submission(s): 3431 Problem Description A robot has been programmed to follow the instructions in its path. Instruc

HDU 1035 Robot Motion

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3466    Accepted Submission(s): 1608 Problem Description A robot has been programmed to follow the instructions in its path. Instruct

HDU 1035 [Robot Motion] 模拟 记忆

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1035 题目大意:给出一个地图,每个点都指定下一步的方向.问移动情况(何时走出地图或几步后进入多长的循环) 关键思想:模拟+记忆化.我的做法是访问过的点vis置1,往后每走一步,走过的所有点vis++,因为每个点都可能是循环的节点.后面回到一个vis>1的点,vis-1就是循环长度了.(也可以记录到每个点的步数,最后点的步数差值就是循环长度) 代码如下 //模拟 记忆.可优化 #include <i

HDU ACM 1035 Robot Motion 简单模拟题

分析:一步步的走,走出矩阵则说明没有环,若走到已经走过的地方,说明有环,按格式输出结果,OK. #include<iostream> using namespace std; #define N 15 int dir[4][2]={-1,0,1,0,0,-1,0,1}; char map[N][N]; int vis[N][N]; char ch[]="NSWE"; int n,m; int id(char c) { int i; for(i=0;i<4;i++) i

poj1573&amp;&amp;hdu1035 Robot Motion(模拟题)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接: HDU:http://acm.hdu.edu.cn/showproblem.php?pid=1035 POJ:   http://poj.org/problem?id=1573 Description A robot has been programmed to follow the instructions in its path. Instructions for

POJ 1573 Robot Motion 搜索

Robot Motion Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6297    Accepted Submission(s): 2952 Problem Description A robot has been programmed to follow the instructions in its path. Instruc