HDU 搜索练习 连连看

连连看

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27989 Accepted Submission(s):
6952

Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

Sample Input

3 4

1 2 3 4

0 0 0 0

4 3 2 1

4

1 1 3 4

1 1 2 4

1 1 3 3

2 1 2 4

3 4

0 1 4 3

0 2 4 1

0 0 0 0

2

1 1 2 4

1 3 2 3

0 0

Sample Output

YES

NO

NO

NO

NO

YES

题意应该都懂了,,

思路分析:

  搜索BFS,但是注意。标记两次转角的方法,,直接来代码吧

# include <iostream>
# include <fstream>
# include <cstring>
# include <queue>
using namespace std;

int map[1001][1001];
int is[1001][1001];
int n, m;
int q;
struct Dian
{
    int x, y, dir, jishu;
}k1, k2;

int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};

void f();
bool border(int, int);

int main()
{
    //fstream cin("aaa.txt");
    memset(is, 0, sizeof(is));
    while(cin >> n >> m)
    {
        if(n == 0 && m == 0)
        break;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                cin >> map[i][j];
        cin >> q;
        for(int i = 0; i < q; i++)
        {
            cin >> k1.x >> k1.y >> k2.x >> k2.y;
            if(map[k1.x][k1.y] != map[k2.x][k2.y])
            {
                cout << "NO" << endl;
                continue;
            }

            if(map[k1.x][k1.y] == 0 || map[k2.x][k2.y] == 0)
            {
                cout << "NO" << endl;
                continue;
            }

            f();
        }
    }

    return 0;
}

void f()
{
    memset(is, 0, sizeof(is));
    queue <Dian> a;
    Dian tep, t;
    tep.x = k1.x;
    tep.y = k1.y;
    tep.dir = -1;
    tep.jishu = 0;
    a.push(tep);
    while(!a.empty())
    {
        tep = a.front();
        a.pop();
        is[tep.x][tep.y] = 1;

        if(tep.x == k2.x && tep.y == k2.y)
        {
            cout << "YES" << endl;
            return ;
        }
       // cout << "haha" << endl;
        for(int i = 0; i < 4; i++)
        {
            t.x = tep.x + dir[i][0];
            t.y = tep.y + dir[i][1];
            t.dir = i;
            t.jishu = tep.jishu;

            if(!border(t.x, t.y)) // 出边界
                continue;
            if(is[t.x][t.y])
                continue;
           // cout << t.x << " " << t.y <<endl;
            //cout << is[t.x][t.y] << endl;
            if(map[t.x][t.y] && !(t.x == k2.x && t.y == k2.y)) //是数字并且
                continue;
            if(tep.dir != t.dir && tep.dir != -1)// 走的方向判断
                t.jishu++;
           // cout << t.jishu << endl;
            if(t.jishu > 2)
                continue;
            a.push(t);
            is[t.x][t.y] = 1;
        }
    }
    cout << "NO" << endl;
}
bool border(int x1, int y1)
{
    if(x1 > 0 && x1 <= n && y1 > 0 && y1 <= m)
    return true;
    return false;
}
时间: 2024-10-17 14:35:55

HDU 搜索练习 连连看的相关文章

hdu 1175(BFS) 连连看

题目在这里:http://acm.hdu.edu.cn/showproblem.php?pid=1175 大家都很熟悉的连连看,原理基本就是这个,典型的搜索.这里用的是广搜. 与普通的搜索比不同的是要求转折的线不能转折超过两次,就是在结构体中多开一个step(储存转折的次数)和一个dir(记录此刻的方向) 方向初始为-1,当行走一步后的方向与走之前不同的时候,step就应该加一, 然后还要注意的是为了保证得到的是所有的路线中转折次数最小的,这里的visit数组要用来保存每个点的最小转折次数, 所

HDU(1175),连连看,BFS

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=1175 越学越不会,BFS还是很高级的. 连连看 Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 30994    Accepted Submission(s): 7694 Problem Description “连 连看”相

HDU 搜索练习 Oil Deposits

Oil Deposits Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 61 Accepted Submission(s) : 25 Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil

HDU 搜索练习 The magic apple tree

The magic apple tree Time Limit : 3000/1000ms (Java/Other) Memory Limit : 65535/32768K (Java/Other) Total Submission(s) : 26 Accepted Submission(s) : 2 Problem Description Sailormoon girls all like eating many kinds of fruit, such as banana, grape, a

HDU 搜索练习 Red and Black

Red and Black Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 23 Accepted Submission(s) : 13 Problem Description There is a rectangular room, covered with square tiles. Each tile is colored either

杭电 HDU ACM 1175 连连看(麻烦的bfs)

连连看 Time Limit:10000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u SubmitStatusPracticeHDU 1175 Description "连连看"相信很多人都玩过.没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子.如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去.不好

HDU 搜索练习 非常可乐

非常可乐 Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 51 Accepted Submission(s) : 21 Problem Description 大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为.因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一

HDU 搜索练习 Rescue

Rescue Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other) Total Submission(s) : 44 Accepted Submission(s) : 13 Problem Description Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described a

HDU 搜索练习 Catch him

Catch him Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 797 Accepted Submission(s): 361 Problem Description 在美式足球中,四分卫负责指挥整只球队的进攻战术和跑位,以及给接球员传球的任务.四分卫是一只球队进攻组最重要的球员,而且一般身体都相对比较弱小,所以通常球队会安排5-7名大汉来