POJ 1459

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p
max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c
max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at
most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l
max(u,v) of power delivered by u to v. Let Con=Σ
uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p
max(u)=y. The label x/y of consumer u shows that c(u)=x and c
max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l
max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines).
Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l
max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p
max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c
max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and
are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a
separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum
value of Con is 15. The second data set encodes the network from figure 1.

Source

Southeastern Europe 2003

题意:给出一些发电站和一些用户,给出发电站的发电量和用户的接收量,求用户最大的接收量。

思路:多源多汇最大流问题,建立一个超级源点和一个超级汇点,求最大流即可,模板题。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
#define maxn 100+5
#define inf 0x7fffffff
int n,np,nc,m;
int s,t,edge[maxn][maxn],pre[maxn];
int EK()
{
  int minflow,maxflow = 0;
  while(1)
  {
    memset(pre, 0, sizeof(pre));
    minflow = inf;
    queue<int> q;
    q.push(s);
    while(!q.empty())  //BFS寻找增广路
   {
     int u = q.front();
     q.pop();
     for(int i = 0;i < n+2;i ++)
    {
     if(edge[u][i] > 0 && pre[i] == 0 )
     {
       pre[i] = u;
       q.push(i);
     }
    }
   }
   //cout << "here" << endl;
   if(pre[t] == 0) break;
   for(int i = t; i != s;i = pre[i])
   minflow = min(minflow, edge[pre[i]][i]);
   for(int i = t; i != s;i = pre[i])
   {
     edge[pre[i]][i] -= minflow;
     edge[i][pre[i]] += minflow;
   }
   maxflow += minflow;
   //cout << maxflow <<endl;
  }

  return maxflow;
}
int main()
{
 char a,b,c;
 int from,to,cost;
 while(scanf("%d%d%d%d", &n, &np, &nc, &m) != EOF)
 {
   s = n ;
   t = n + 1;

   for(int i = 1; i <= m;i ++)
   {
     cin >> a >> from >> b >> to >> c >> cost;
     edge[from][to] = cost;
     //cout <<from <<" "<<to<<" "<<cost<<endl;
   }
   for(int i = 0; i < np;i ++)
   {
	 cin >> a >> to >> b >> cost;
	 edge[s][to] = cost;
     //cout <<s<<" "<<to <<" "<<cost <<endl;

   }
   for(int i = 0; i < nc;i ++)
   {
     cin >>a>>from>>b>>cost;
     edge[from][t] = cost;
     //cout <<from <<" "<<t<<" "<<cost<<endl;
   }
   int ans = EK();
   printf("%d\n", ans);

 }
 return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-11-05 16:35:00

POJ 1459的相关文章

POJ 1459 Power Network(网络流 最大流 多起点,多汇点)

Power Network Time Limit: 2000MS   Memory Limit: 32768K Total Submissions: 22987   Accepted: 12039 Description A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied

poj 1459 Power Network, 最大流,多源多汇

点击打开链接 多源多汇最大流,虚拟一个源点s'和一个汇点t',原来的源点.汇点向它们连边. #include<cstdiO> #include<cstring> #include<iostream> #include<algorithm> #include<queue> #include<vector> using namespace std; const int maxn = 500 + 5; const int INF = 100

POJ 1459 Power Network(ISAP 裸最大流)

题目链接:http://poj.org/problem?id=1459 注意输入格式就行,还是ISAP #include <iostream> #include <cstdlib> #include <cstdio> #include <cstring> #include <queue> #include <algorithm> const int N = 210; const int maxn = 300; const int ma

poj 1459 多源多汇点最大流

Sample Input 2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20 7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7 (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5 (0)5 (1)2 (3)2 (4)1 (5)4 7个点包括电站和用户,2个电站,3个用户,13条边,输入13条边,输入2个电站,输入3个用户 Sample Output 15 6 增加一个源点一个汇点

poj 1459 Power Network (dinic)

Power Network Time Limit: 2000MS   Memory Limit: 32768K Total Submissions: 23059   Accepted: 12072 Description A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied

POJ 1459 Power Network 最大流

建模不难,就读入有点麻烦,无脑拍完dinic 1A happy- #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cstdlib> #i

初涉网络流 POJ 1459 Power Network

怒搞一下午网络流,又去我一块心病. 从2F到SAP再到Dinic终于过掉了.可是书上说Dinic的时间复杂度为v*v*e.感觉也应该超时的啊,可是过掉了,好诡异. 后两种算法都是在第一种的基础上进行优化.第一种方法就是不停的寻找增广路,后两种引进了层次网络的概念,第三种又改善了寻找增广路的方法. 现在只能理解到这里了... #include <algorithm> #include <iostream> #include <cstring> #include <c

POJ 1459 Power Network 经典网络流构图问题 最大流,EK算法

题目链接:POJ 1459 Power Network Power Network Time Limit: 2000MS   Memory Limit: 32768K Total Submissions: 23347   Accepted: 12231 Description A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport line

POJ 1459 &amp; ZOJ 1734 Power Network (网络最大流)

http://poj.org/problem?id=1459 http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1734 Power Network Time Limit: 2000MS   Memory Limit: 32768K Total Submissions: 22674   Accepted: 11880 Description A power network consists of nodes (power s

poj 1459 Power Network 多源多汇网络流

题目链接:http://poj.org/problem?id=1459 题意: 总共有N个点,M条边,有np个点是加油站即源点,有nc个点是消耗点,即汇点. 给出M条边的容量,每个源点最大的流出量和每个汇点的最大流入量. 求最多可以消耗多少. 思路: 多源多汇网络流就是增加一个超级源点和超级汇点. 把超级源点向每个源点连一条边,容量为该源点流出的最大量. 把每个汇点向超级汇点连一条边,容量为该汇点规定的最大流入量. 然后求最大流. 1 //#include <bits/stdc++.h> 2