Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34106 Accepted Submission(s): 12255
Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b‘s last digit number.
Sample Input
7 66 8 800
Sample Output
9 6
#include<stdio.h>
#include<math.h>
main()
{
int a,b,i,j,c,x[1000],h;
while(scanf("%d%d",&a,&b)!=EOF)
{
c=a%10;
j=1;
x[1]=a%10;
for(i=2;i<=100;i++)
{
c=c*x[1];
c=c%10;
j++;
//printf("%d\n",c);
x[j]=c;
if(x[1]==x[j])
break;
}
h=b%(j-1);
if(h==0)
h=j-1;
printf("%d\n",x[h]);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。