PAT甲级1002 链表实现方法

题目:

1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题目大意就是给定两个多项式 F1=aN1*x^N1+aN2*x^N2+aN3*x^N3+.....和F2=bN1*x^N1+bN2*x^N2+bN3*x^N3+..... 求两个多项式的和
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<iomanip>
using namespace std;
template <class T>
class Link
{
public:
    T data1,data2;
    Link<T> *next;
    Link(const T d1,const T d2,Link<T> *nex=NULL)
    {
        data1=d1;
        data2=d2;
        next=nex;
    }
    Link()
    {
        data1=0;
        data2=0;
        next=NULL;
    }
};
template <class T>
class InkLink
{
private:
    Link<T> *head;
    int lon;
public:
    InkLink()
    {
        head=new Link<T>;
        lon=0;
    }
    void display2()
    {
        Link<T> *p;
        p=head->next;
        cout << lon ;
        while(p!=NULL)
        {
            printf(" ");
            printf("%d %.1lf",(int)p->data1,p->data2);
            p=p->next;
        }
        cout <<endl;
    }
    bool insertDesc(const T value1,const T value2)
    {
        if(head->next==NULL)
        {
            head->next=new Link<T>(value1,value2);
            lon++;
            return true;
        }
        Link<T> *p,*q;
        p=head->next;
        q=head;
        while(p!=NULL&&((p->data1)>value1))
        {
            q=p;
            p=p->next;
        }
        if(p==NULL||((p->data1)<value1))
        {

            q->next=new Link<T>(value1,value2,p);
            lon++;
        }
        else if(p->data1==value1)
        {
            p->data2+=value2;
            if(p->data2==0)
            {
                if(p->next!=NULL)q->next=p->next;
                else q->next=NULL;
                delete p;
                lon--;
            }
        }
        return true;
    }
    void clearLink()
    {
        Link<T> *p,*q;
        p=head->next;
        q=p;
        while(p!=NULL)
        {
            p=p->next;
            delete q;
            q=p;
        }
        lon=0;
        head->next=NULL;
    }
};
int main()
{
    InkLink<double> l;
    int n;
    double a,b;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%lf%lf",&a,&b);
            l.insertDesc(a,b);
        }
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%lf%lf",&a,&b);
            l.insertDesc(a,b);
        }
        l.display2();
        l.clearLink();
    }
    return 0;
}
/*
2 1 2.4 0 3.2
2 2 1.5 0 -3.2
*/

这道题交了无数回,踩过了所有的坑。。。首先多项式的系数可以为负数,当系数减到0的时候要删掉这个节点。还有就是精确到小数点后一位。最后要控制格式,答案末尾直接输出回车,不要有空格。最后一组样例的结果应该是0,同样不能输出空格,没过的可能需要注意一下这点。

原文地址:https://www.cnblogs.com/LowBee/p/8976040.html

时间: 2024-10-13 08:29:00

PAT甲级1002 链表实现方法的相关文章

PAT 甲级1002 A+B for Polynomials (25)

1002. A+B for Polynomials (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, an

PAT甲级1002.A+B for Polynomials (25)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805526272000000 解题思路: 由于是求两个多项式之和,并且多项式的指数是从大到小进行排列的,相加时有合并和消除的操作 因此选用了较为灵活的链表结构,将输入的第一个多项式使用链表存储起来,将第二个多项式的项依次输入, 对于加数每个项和被加数的每项的指数进行比较,如果大于其指数则插入在其前面,如果小于其指数,则比较 被加数的后一项,如果等于其指数,则将两

PAT甲级1002水题飘过

1 #include<iostream> 2 #include<string.h> 3 using namespace std; 4 5 double a[1005]; 6 7 int main(){ 8 int n1, n2; 9 while(scanf("%d", &n1) != EOF){ 10 memset(a, 0, sizeof(a)); 11 for(int i = 1; i <= n1; i++){ 12 int x; 13 dou

PAT甲级考试题库1001 A+B Format 代码实现及相关知识学习

准备参加九年九月份的PAT甲级证书考试,对网站上的题目进行总结分析: 1001题 A+B Format (20 分) Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits). 计算a+b的值并以一定格式输出其和sum(数字需要

PAT甲级1005 Spell It Right

题目:PAT甲级 1005 题解:水题.看到题目的第一时间就在想一位一位的mod,最后一加一转换就完事了.结果看到了N最大为10的100的次方,吓得我赶紧放弃这个想法... 发现碰到这种情况用字符串十分好用,这道题应该考察的就是这一点.大致思路就是把数字的每一位放到字符串中,然后通过ASCII码得到每一位的相加结果num,然后把num一位一位的放到stack中,使用stack是因为它先进先出的特性,最后输出就行了. 代码: 1 #include<cstdio> 2 #include<qu

建立单链表的方法

#include<iostream> using namespace std; struct node{ int d; struct node *next; };//定义结点 node *build1()//头插法构造单链表 { node *p;//指向新建结点 node *head;//头指针 head=NULL; p=head; int x; cin>>x;  while(x!=-1)  {  p=new node;  p->d=x;  p->next=head;

PAT甲级考前整理

终于在考前,刷完PAT甲级130道题目,不容易!!!每天沉迷在刷题之中而不能超脱,也是一种境界.PAT甲级题目总的说卡题目的比较多,卡测试点的比较少,有些题目还会有题意混淆,这点就不吐槽了吧.静下心来耍这130道题,其实磨练的是一种态度与手感,养成的是一种习惯.热爱AC没有错!! 130道题目主要的考点: 1.排序:快速排序,直接插入排序,希尔排序,分治排序,堆排序. 2.图论:拓扑排序.最短路径.深度搜索.广度搜索. 3.树:树的遍历.完全二叉树.AVL. 4.其他:并查集,模拟,哈希.背包.

PAT甲级专题|最短路

PAT甲级最短路 主要算法:dijkstra 求最短最长路.dfs图论搜索. 1018,dijkstra记录路径 + dfs搜索路径最值 25分,错误点暂时找不出.. 如果只用dijkstra没法做,只能得20分 #include<bits/stdc++.h> using namespace std; const int inf = 0x3f3f3f3f; const int maxn = 510; int cmax,n,ter,m; int caps[maxn]; int g[maxn][m

【PAT甲级】1070 Mooncake (25 分)(贪心水中水)

题意: 输入两个正整数N和M(存疑M是否为整数,N<=1000,M<=500)表示月饼的种数和市场对于月饼的最大需求,接着输入N个正整数表示某种月饼的库存,再输入N个正数表示某种月饼库存全部出手的利润.输出最大利润. trick: 测试点2可能包含M不为整数的数据.(尽管题面说明M是正整数,可是根据从前PAT甲级题目的经验,有可能不是整数.....) 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using names