POJ 3311 Hie with the Pie (Floyd + 状压dp 简单TSP问题)

Hie with the Pie

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5019   Accepted: 2673

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before
he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you
to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer
n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be
n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the
n locations (numbers 1 to n). The jth value on the
i
th line indicates the time to go directly from location i to location
j without visiting any other locations along the way. Note that there may be quicker ways to go from
i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location
i to j may not be the same as the time to go directly from location
j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

East Central North America 2006

题目链接:http://poj.org/problem?id=3311

题目大意:一个人要送n份货,给出一个矩阵,表示任意两个点间的直接路径的时间,求从起点0送完这n份货(到达指定的n个地点)再回到起点0的最短时间

题目分析:n不大,可以进行状态压缩,首先用Floyd处理一下任意两点的最短路,dp[i][j]表示在状态i的条件下到城市j的最短时间,显然如果i == (1 << (j - 1)),表示从只经过城市j,这时候dp[i][j] = dis[0][j],否则就是要经过别的城市到达j,这里枚举当前状态下经过的除了j的其他城市,注意一定是当前状态下,这里类似Floyd,最后dp[(1 << n) - 1][i]表示经过了所有店到达i我们只要枚举dp[(1 << n) - 1][i] + dis[i][0]的最小值即可

#include <cstdio>
#include <algorithm>
using namespace std;
int const INF = 0xfffffff;
int dp[(1 << 11)][11], n;
int dis[11][11];

void Floyd()
{
    for(int k = 0; k <= n; k++)
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                if(dis[i][j] > dis[i][k] + dis[k][j])
                    dis[i][j] = dis[i][k] + dis[k][j];
}

int main()
{
    while(scanf("%d", &n) != EOF && n)
    {
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                scanf("%d", &dis[i][j]);
        Floyd();
        for(int i = 0; i <= (1 << n) - 1; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(i == (1 << (j - 1)))
                    dp[i][j] = dis[0][j];
                else
                {
                    dp[i][j] = INF;
                    for(int k = 1; k <= n; k++)
                        if((k != j) && (i & (1 << (k - 1)))) //当前状态下
                            dp[i][j] = min(dp[i][j], dp[i ^ (1 << (j - 1))][k] + dis[k][j]);
                }
            }
        }
        int ans = dp[(1 << n) - 1][1] + dis[1][0];
        for(int i = 2; i <= n; i++)
            ans = min(ans, dp[(1 << n) - 1][i] + dis[i][0]);
        printf("%d\n", ans);
    }
}
时间: 2024-10-23 00:25:37

POJ 3311 Hie with the Pie (Floyd + 状压dp 简单TSP问题)的相关文章

POJ 3311 Hie with the Pie floyd+状压DP

链接:http://poj.org/problem?id=3311 题意:有N个地点和一个出发点(N<=10),给出全部地点两两之间的距离,问从出发点出发,走遍全部地点再回到出发点的最短距离是多少. 思路:首先用floyd找到全部点之间的最短路.然后用状态压缩,dp数组一定是二维的,假设是一维的话不能保证dp[i]->dp[j]一定是最短的.由于dp[i]记录的"当前位置"不一定是能使dp[j]最小的当前位置.所以dp[i][j]中,i表示的二进制下的当前已经经过的状态,j

POJ 3311 Hie with the Pie (状压DP)

题意: 每个点都可以走多次的TSP问题:有n个点(n<=11),从点1出发,经过其他所有点至少1次,并回到原点1,使得路程最短是多少? 思路: 同HDU 5418 VICTOR AND WORLD (可重复走的TSP问题,状压DP)这道题几乎一模一样. 1 //#include <bits/stdc++.h> 2 #include <iostream> 3 #include <cstdio> 4 #include <cstring> 5 #includ

POJ 3311 Hie with the Pie(状压DP + Floyd)

题目链接:http://poj.org/problem?id=3311 Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait fo

POJ 3311 Hie with the Pie(状压dp or dfs)

Language: Default Hie with the Pie Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 5057   Accepted: 2695 Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutba

POJ 3311 Hie with the Pie(Floyd+状态压缩DP)

贴一个TSP讲解:点击打开链接 错误的转移方程 dp[i][j] 把i当作了步数,以为至多走N步就可以了.作死啊 #include<cstdio> #include<iostream> #include<cstring> #include<algorithm> #define maxn 1100 #define inf 0x3f3f3f3f const double eps=1e-8; using namespace std; int dp[12][1<

poj 3311 Hie with the Pie(状态压缩dp)

Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be

POJ 3311 Hie with the Pie (状压DP)

状态压缩DP dp[i][j]表示在i状态(用二进制表示城市有没有经过)时最后到达j城市的最小时间 转移方程dp[i][j]=min(dp[i][k]+d[k][j],dp[i][j]) d[k][j]是k城市到j城市的最短距离 要先用flody处理 #include<bits.stdc++.h> using namespace std; int d[20][20],dp[1<<11][20]; int n,m; void flody() { for(int k=0;k<=n

POJ 3311 Hie with the Pie TSP+Floyd

保证每个点访问过一次就行,然后会到原点. 这种情况可以先做一边floyd,然后跑tsp就好. #include <cstdio> #include <cstring> #include <iostream> #include <map> #include <set> #include <vector> #include <string> #include <queue> #include <deque&g

poj 3311 Hie with the Pie 【旅行商+回原点】

题目:poj 3311 Hie with the Pie 题意:就是批萨点小二要送批萨,然后给你每个点的距离,有向的,然后让你就走一次回到原点的最短路. 分析:因为给出的是稠密图,所以要处理一下最短路,floyd 然后TSP就好. 枚举每个状态,对于当前状态的每一个已经走过的点,枚举是从那个点走过来的,更新最短路 状态:dp[st][i] :st状态下走到点 i 的最短路 转移方程:dp[st][i]=min(dp[st&~(1<<i)][j]+mp[j][i],dp[st][i]);