B - Radar Installation poj 1328【贪心】

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1题意:给出坐标点的总数n和雷达辐射半径R,再给你n个坐标,问在X轴上最少需要多少个雷达可以覆盖所有坐标点。思路:待更新。。。。
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define N 1100
struct node {
    double x1,x2;
}c[N];

double cmp(struct node a,struct node b)
{
    if(a.x1 > b.x1 )
        return a.x1 < b.x1 ;
}
int main()
{
    int i,j,n,R,ans,t=0;
    double x,y,coords;
    while(scanf("%d%d",&n,&R),n!=0&&R!=0)//不能用(n+R)作为循环条件,因为3 -3这种情况不满足
    {
        ans = 1;
        if(R <= 0)//先判断半径是否满足条件
            ans = -1;

        for(i = 1; i <= n; i ++)
        {
            scanf("%lf%lf",&x,&y);//坐标是实数
            if(fabs(y) > R)//纵坐标大于半径时  不满足条件
            {
                ans = -1;
            }
            else
            {
                coords = sqrt(R*R-y*y);
                c[i].x1 = x - coords;//计算与x轴相交的左右端点
                c[i].x2 = x + coords;
            }
        }
        if( ans == -1)
        {
            printf("Case %d: %d\n",++t,ans);
            continue;
        }
        sort(c+1,c+1+n,cmp);//结构体排序
        coords = c[1].x2 ;//初始化为最左坐标的右端点 

        for(i = 2; i <= n; i ++)
        {
            if(c[i].x1 > coords)//如果下一个坐标的左端点大于上一个坐标右端点 说明两者没有公共区间
            {
                ans ++;
                coords = c[i].x2 ;
            }
            else if(c[i].x2 < coords)//如果下一个坐标的右端点小于上一个坐标的右端点,说明存在公共区间
                coords = c[i].x2 ;
        }
        printf("Case %d: %d\n",++t,ans);
    }
    return 0;
}
时间: 2024-10-02 04:33:11

B - Radar Installation poj 1328【贪心】的相关文章

Radar Installation -poj 1328

Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 60277   Accepted: 13583 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea sid

POJ 1328 Radar Installation 雷达安装 贪心问题求解

题目链接: POJ 1328 Radar Installation Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coas

POJ 1328 Radar Installation(经典贪心)

Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 54143   Accepted: 12178 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point loca

poj 1328贪心

Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, s

poj 1328 贪心

/* 贪心.... 处理处每个点按照最大距离在x轴上的映射 然后我们就有了一些线段 目的是选取尽量少的点 使得每个线段内都有点出现 我们按照左端点排序 然后逐一处理 假设第一个雷达安在第一个线段的右端点 若下一条与之无交点 则再按一个雷达 若完全覆盖 贪心的 我们把雷达移动到下一条的右端点 这样这个雷达就又多覆盖了一个岛 */ #include<iostream> #include<cstdio> #include<cstring> #include<algori

POJ 1328、Radar Installation 贪心

jQuery的属性操作非常简单,下面以一个a元素来说明属性的获取/设置/删除操作 <body> <a>jquery.com</a> </body> 添加属性 $('a').attr('href', 'http://www.jquery.com') 添加多个属性 $('a').attr({'href':'http://www.jquery.com', 'title':'jquery.com'}) 获取属性 $('a').attr('href') class属性

POJ 1328 Radar Installation 贪心题解

本题是贪心法题解,不过需要自己观察出规律,这就不容易了,很容易出错. 一般网上做法是找区间的方法. 这里给出一个独特的方法: 1 按照x轴大小排序 2 从最左边的点循环,首先找到最小x轴的圆 3 以这个圆判断可以包括右边的多少个圆,直到不可以包括下一个点,那么继续第2步,画一个新圆. 看代码吧,应该很清晰直观的了. 效率是O(n),虽然有嵌套循环,但是下标没有重复,一遍循环就可以了,故此是O(n). #include <stdio.h> #include <cmath> #incl

Poj 1328 Radar Installation 贪心

题目链接:http://poj.org/problem?id=1328 Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 52768   Accepted: 11867 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the othe

[ACM] POJ 1328 Radar Installation (贪心,区间选点问题)

Radar Installation Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 51131   Accepted: 11481 Description Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point loca